Jump to content

Trunk Username in To field for each call


gegan
 Share

Recommended Posts

My ITSP has requested that the account username be send in the INVITE for each outgoing call for authentication purposes. I thought I had setup the trunk correctly as the REGISTER succeeds (Status 200) but when I try to make a call I get 400 Bad Request.

 

When I look at the INVITE request in the SIP from field it has '40@localhost'.

 

What the ITSP wants is username@your_pbx_IP address.

 

How can I configure this.

 

Thanks,

 

George

Link to comment
Share on other sites

My ITSP has requested that the account username be send in the INVITE for each outgoing call for authentication purposes. I thought I had setup the trunk correctly as the REGISTER succeeds (Status 200) but when I try to make a call I get 400 Bad Request.

 

When I look at the INVITE request in the SIP from field it has '40@localhost'.

 

What the ITSP wants is username@your_pbx_IP address.

 

How can I configure this.

 

Thanks,

 

George

 

Use the "Remote Party/Privacy Indication" under the trunk page to control this. Maybe "No Indication" will do the trick for you. But you can try other options if your provider requires something else

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...