Jump to content
Vodia PBX forum
Wim van Ommen

Setting ANI on Huntgroup does not Work.

Recommended Posts

I tried these settings as the are described on the www.pbxnsipsupport.com site (below the ------)

 

I am using 3.4.0.3201 (Linux)

 

I have a Huntgroup that has my mobile as the final stage.

I set the ANI to a number that is valid on my trunk.

If I call from an internal phone to the Huntgroup, a call comes through on my mobile but not with the ANI I set on the Huntgroup, but with the global ANI.

If I call from an external number the pbx does try to call my phone, but instead of using the ANI I set on the Huntgroup, I see in the log that it tries to setup a call from the external number to my mobile.

This would be brilliant if my provider would allow it, but they don't.

My impression was that setting the ANI on the Huntgroup would resolve this.

Is this a bug? How can I get this to work the way I want to?

------

Final Stage and Dial Plans

If you want to redirect the call at the final stage to an outside number (e.g. a contact centre answering calls on your behalf), then you should assign a dial plan to the hunt group OR use the domain default.

 

Calls will be routed off the hunt group and out to the dial plan when the final stage is met.

 

You can even set the ANI for each hunt group so that the contact centre can recognise the calling Hunt Group.

Share this post


Link to post
Share on other sites

i have also tried changing the outbound ANI but with no results its clear to me that that setting is there for that reason, but yet it never works for me

Share this post


Link to post
Share on other sites

I guess on the trunk you need to choose the mode "No Indication" where the RFC3325 is the default. Your service provider is probably not able to deal with RFC3325 indications.

 

We also added a Related-Call-ID header which might be used by the service provider to verify that this is a redirected call and no caller-ID spoofing. But of course almost nobody supports it.

Share this post


Link to post
Share on other sites

Dialing my cellphone only works when I set the trunk I'm using to dial out to remote party ID or no indication, the problem is that this still does not set any ANI, it just uses the main ANI of my trunk. Any other ideas?

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...