Jump to content
Vodia PBX forum
Leonmeijer

Extension to "off-site" pbx doesn't register

Recommended Posts

Hello,

 

I ran my PBXnSIP always locally but moved the server to a datacenter now.

I've configured the phone (a snom 360) as follows:

 

Identity Active: ON.

Account: 100 (pbxnsip extension).

Password: the password

Registar: localhost (pbxnsip domain).

Outbound proxy: IP.of.external.host

Auth. username: 100 (pbxnsip extension).

 

Then, when I check the PBXnSIP I see the following log (level 9).

 

REGISTER sip:localhost SIP/2.0
Via: SIP/2.0/UDP 10.0.0.250:2051;branch=z9hG4bK-2s6f0e0n3kfe;rport
From: "100" <sip:100@localhost>;tag=84y005zlh7
To: "100" <sip:100@localhost>
Call-ID: 3c26700ccf85-rdt8ol2pksam@snom360-00041329827D
CSeq: 1 REGISTER
Max-Forwards: 70
Contact: <sip:100@10.0.0.250:2051;line=q2o58ags>;q=1.0;flow-id=1;+sip.instance="<urn:uuid:b4909cfe-3dd3-4353-b064-addd22cead39>";audio;mobility="fixed";duplex="full";description="snom360";actor="principal";events="dialog";methods="INVITE,ACK,CANCEL,BYE,REFER,OPTIONS,NOTIFY,SUBSCRIBE,PRACK,MESSAGE,INFO"
User-Agent: snom360/6.5.13
Supported: gruu
Allow-Events: dialog
X-Real-IP: 10.0.0.250
WWW-Contact: <http://10.0.0.250:80>
WWW-Contact: <https://10.0.0.250:443>
Expires: 3600
Content-Length: 0


[9] 2010/05/05 18:16:51: SIP Tr udp:my.own.external.ip:2051: 
SIP/2.0 401 Authentication Required
Via: SIP/2.0/UDP 10.0.0.250:2051;branch=z9hG4bK-2s6f0e0n3kfe;rport=2051;received=195.241.108.161
From: "100" <sip:100@localhost>;tag=84y005zlh7
To: "100" <sip:100@localhost>;tag=3b5e38fe8e
Call-ID: 3c26700ccf85-rdt8ol2pksam@snom360-00041329827D
CSeq: 1 REGISTER
User-Agent: pbxnsip-PBX/4.0.1.3499
WWW-Authenticate: Digest realm="localhost",nonce="3ba3badbfee7cb13a1ef832e9ae76784",domain="sip:localhost",algorithm=MD5
Content-Length: 0

 

It appears that the phone sends it's "Real-ip" as the local ip of the phone.

The phone isn't behind any firewall and I din't change the password(s) or any other setting.

 

Can anyone help me out?

Share this post


Link to post
Share on other sites

In this case I would check if you can upgrade the phone to version 8.2.29. And I would really really double check the passwords. Do you have multiple domains? Then make sure that the domain is part of the username. 8.2.29 supports the simple user@domain notation.

 

It does not have anything to do with the SBC, I am pretty sure.

Share this post


Link to post
Share on other sites
In this case I would check if you can upgrade the phone to version 8.2.29. And I would really really double check the passwords. Do you have multiple domains? Then make sure that the domain is part of the username. 8.2.29 supports the simple user@domain notation.

 

It does not have anything to do with the SBC, I am pretty sure.

 

I've upgraded to the latest v8 firmware, and double-checked control+c, control+v'ed a new password (copied from notepad, pasted in both pbx and phone password fields).

 

I still get these 401 auth required messages... I also tried a new extension but didn't work too... I did a brand new pbxnsip installation... if you have any ideas let me know, i'll keep on trying some settings with the @domain thing (btw, no I only have a "localhost" domain).

Share this post


Link to post
Share on other sites

It looks like my snom won't save the password, I've set the PBXnSIP password to blank and... there you go " 200 OK" it's registered.

So it's a snom related error, now it's registered it only won't call e.g. the mailbox the phone keeps saying "calling" but that might be a codec or firewall related error i gues...

Share this post


Link to post
Share on other sites
It looks like my snom won't save the password, I've set the PBXnSIP password to blank and... there you go " 200 OK" it's registered.

So it's a snom related error, now it's registered it only won't call e.g. the mailbox the phone keeps saying "calling" but that might be a codec or firewall related error i gues...

 

How do you reboot? Maybe it does not save it when you pull the plug. Try rebooting from the keyboard menu (maintenance, reboot).

Share this post


Link to post
Share on other sites
How do you reboot? Maybe it does not save it when you pull the plug. Try rebooting from the keyboard menu (maintenance, reboot).

 

Well I didn't reboot at all, but now I did it both pulling the plug and via the maintenance menu but nothing, still the password is blank. Other settings are saved correctly btw.

Share this post


Link to post
Share on other sites
Well I didn't reboot at all, but now I did it both pulling the plug and via the maintenance menu but nothing, still the password is blank. Other settings are saved correctly btw.

 

Well, I have played arround with a lot of things, other pc's compatibilty view (IE8) saving and rebooting using the phone, webinterface and the plug. Tried to reset all to default but the phone is just "ignoring" / " not saving" the password. The log doesn't show anything related to saving the extension (phone log).

 

I ran out of options on this one...

Share this post


Link to post
Share on other sites
I ran out of options on this one...

Please provide us the content of the phone's system info WUI page, so we know the status of your phone.

 

When log level is set to 7, the log shows setting changes and after 20 secs even that the changes are written to the setting file.

Now one can change arbitrary settings and check if the phone noticed the change or not.

 

Pulling the plug is always bad. Resetting values to factory defaults can never be wrong. ;-)

Share this post


Link to post
Share on other sites
Please provide us the content of the phone's system info WUI page, so we know the status of your phone.

 

When log level is set to 7, the log shows setting changes and after 20 secs even that the changes are written to the setting file.

Now one can change arbitrary settings and check if the phone noticed the change or not.

 

Pulling the plug is always bad. Resetting values to factory defaults can never be wrong. ;-)

 

Here is the phone's log which shows it sets the password (password not shown) I can't find wheater it is saved or not, but in the pbxnsip I can see that it isn't <_<

 

 

 

[6] 7/5/2010 17:27:21: new Tag: >70bmx126qn5qyfld< Filename: log.htm
[9] 7/5/2010 17:27:22: Timer: webserver/webserver.cpp (192): [close]
[6] 7/5/2010 17:27:23: webserver::request 77: GET /line_login.htm?l=1 HTTP/1.1
[6] 7/5/2010 17:27:23: Basic authentication.
[6] 7/5/2010 17:27:23: new Tag: >elvtzq3n6bl1klib< Filename: line_login.htm
[9] 7/5/2010 17:27:25: Timer: webserver/webserver.cpp (192): [close]
[9] 7/5/2010 17:27:33: Timer: sip/registrar.cpp (720): [set_nr_timeout]
[9] 7/5/2010 17:27:33: Timer: sip/sip_send.cpp (1421): [send_packet]
[9] 7/5/2010 17:27:36: Timer: sip/network.cpp (751): [message_repetition]
[6] 7/5/2010 17:27:36: webserver::request 78: POST /line_login.htm?l=1 HTTP/1.1
[6] 7/5/2010 17:27:36: Basic authentication.
[7] 7/5/2010 17:27:36: settings::apply_value: user_pass = '******', set.need_apply: 0, finished: 1, need reboot to apply: 0
[8] 7/5/2010 17:27:36: Routing to outbound proxy sip:ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=url ? sip:ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: naptr ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=srv tls _sips._tcp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sips._tcp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=srv tcp _sip._tcp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sip._tcp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=srv udp _sip._udp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sip._udp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=a udp ip2.lmeijer.nl 5060
[8] 7/5/2010 17:27:36: DNS cache_lookup: a ip2.lmeijer.nl -> 80.69.83.97
[8] 7/5/2010 17:27:36: route_pending_packet 1003384: entry=udp 80.69.83.97 5060
[8] 7/5/2010 17:27:36: Send Packet REGISTER
[9] 7/5/2010 17:27:36: result of get_ip_adr:80.69.83.97 192.168.1.110
[9] 7/5/2010 17:27:36: result of get_ip_adr:80.69.83.97 192.168.1.110
[5] 7/5/2010 17:27:36: sip::send_register: reregister timer for line 0 set to 300s
[8] 7/5/2010 17:27:36: Routing to outbound proxy sip:ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=url ? sip:ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: naptr ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=srv tls _sips._tcp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sips._tcp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=srv tcp _sip._tcp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sip._tcp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=srv udp _sip._udp.ip2.lmeijer.nl
[8] 7/5/2010 17:27:36: DNS cache_lookup: srv _sip._udp.ip2.lmeijer.nl -> 
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=a udp ip2.lmeijer.nl 5060
[8] 7/5/2010 17:27:36: DNS cache_lookup: a ip2.lmeijer.nl -> 80.69.83.97
[8] 7/5/2010 17:27:36: route_pending_packet 1003385: entry=udp 80.69.83.97 5060
[7] 7/5/2010 17:27:36: Trusted IP Addresses: udp:80.69.83.97
[6] 7/5/2010 17:27:36: new Tag: >cb160p5fvnfej1d8< Filename: line_login.htm
[9] 7/5/2010 17:27:37: Timer: sip/sip_send.cpp (791): [route_pending_packet]
[8] 7/5/2010 17:27:37: Send Packet REGISTER
[9] 7/5/2010 17:27:37: result of get_ip_adr:80.69.83.97 192.168.1.110
[9] 7/5/2010 17:27:37: result of get_ip_adr:80.69.83.97 192.168.1.110
[9] 7/5/2010 17:27:38: Timer: webserver/webserver.cpp (192): [close]
[8] 7/5/2010 17:27:38: Sending Keepalive to Watchdog
[9] 7/5/2010 17:27:38: Timer: sip/sip_send.cpp (620): [resend_packet]
[8] 7/5/2010 17:27:38: Send Packet REGISTER
[9] 7/5/2010 17:27:38: result of get_ip_adr:80.69.83.97 192.168.1.110
[9] 7/5/2010 17:27:38: result of get_ip_adr:80.69.83.97 192.168.1.110
[6] 7/5/2010 17:27:38: webserver::request 79: GET /log.htm HTTP/1.1
[6] 7/5/2010 17:27:38: Basic authentication.
[6] 7/5/2010 17:27:38: new Tag: >pikheruujxtml6nx< Filename: log.htm

 

And here the system information from the web interface:

 

 System Information: 
Phone Type: snom360-SIP 
MAC-Address: 00041329827D 
IP-Address: 192.168.1.110 
Firmware-Version: snom360-SIP 8.2.29 20821 
Firmware-URL:  
Production Information: Mac:00041329827D;Version:Standard;Hardware:snom360 (H: R2A);Date:15/05/08;Copyright(C) snom technology AG 
Uptime: 1 days, 19 hours, 4 minutes 
LCS: 1 days, 19 hours, 4 minutes (0) 
Memfree: 440 K 
CPU: 0.01 0.02 0.00 1/10 78   
Bootloader-Version: 1.1.3-u 
Provisioning: snom Provisioning 

SIP Identity Status: 
Identity 1 Status: 100@localhost: Network Failure 
Identity 2 Status:  
Identity 3 Status:  
Identity 4 Status:  
Identity 5 Status:  
Identity 6 Status:  
Identity 7 Status:  
Identity 8 Status:  
Identity 9 Status:  
Identity 10 Status:  
Identity 11 Status:  
Identity 12 Status:  

Ethernet Status: 
Net Port: Connection Type: 100 Mbit Full Duplex 
 Status: connected 

PC Port: Connection Type: 100 Mbit Full Duplex 
 Status: connected

Share this post


Link to post
Share on other sites

Ah didn't notice the 20sec thing, well here we go:

 

[5] 7/5/2010 17:36:18: Applying Settings...

[6] 7/5/2010 17:36:18: Attempt to write the file /snomconfig/config.xml which has not changed.

[6] 7/5/2010 17:36:18: Attempt to write the file /snomconfig/firmware.xml which has not changed.

[6] 7/5/2010 17:36:18: Attempt to write the file /snomconfig/fkeys.xml which has not changed.

[6] 7/5/2010 17:36:18: Attempt to write the file /snomconfig/tbook.xml which has not changed.

[6] 7/5/2010 17:36:18: Attempt to write the file /snomconfig/dialplan.xml which has not changed.

 

(just put another password in, clicked save, wait 20sec and.... NOT saved)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...