Jump to content

Cisco 7961 - Registration fails


snom Canada
 Share

Recommended Posts

Hello,

 

Does anyone have suycessfully made a cisco 7961G work with pbxnsip 1.5.2.10a running on windows server 2000

 

We have a trace (pbxnsip):

 

[0] 20071007123919: SIP Rx udp:200.123.47.50:18148:

REGISTER sip:66.46.213.1 SIP/2.0

Via: SIP/2.0/UDP 192.168.3.81:5080;branch=z9hG4bK3fcbb041

From: <sip:5149048083@66.46.213.1>;tag=0017e03419da000c2cc88fbb-e9a5f8ed

To: <sip:5149048083@66.46.213.1>

Call-ID: 0017e034-19da0002-73c8cff0-8dfe5212@192.168.3.81

Max-Forwards: 70

Date: Sun, 07 Oct 2007 16:39:19 GMT

CSeq: 111 REGISTER

User-Agent: Cisco-CP7961G/8.3.0

Contact: <sip:5149048083@192.168.3.81:5080;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0017e03419da>";+u.sip!model.ccm.cisco.com="30018"

Supported: (null),X-cisco-xsi-6.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:20 Name=SEP0017E03419DA Load=SIP41.8-3-1S Last=Phone-Keypad"

Expires: 3600

 

[0] 20071007123919: SIP Tx udp:200.123.47.50:18148:

SIP/2.0 200 Ok

Via: SIP/2.0/UDP 192.168.3.81:5080;branch=z9hG4bK3fcbb041;rport=18148;received=200.123.47.50

From: <sip:5149048083@66.46.213.1>;tag=0017e03419da000c2cc88fbb-e9a5f8ed

To: <sip:5149048083@66.46.213.1>;tag=14990

Call-ID: 0017e034-19da0002-73c8cff0-8dfe5212@192.168.3.81

CSeq: 111 REGISTER

Contact: <sip:5149048083@192.168.3.81:5080;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0017e03419da>";+u.sip!model.ccm.cisco.com=30018;expires=90

Content-Length: 0

 

Even if we see in wireshark that the request is sent back to the phone, the phone never get the "X" removed and still show unregistered.

 

Somehow pbxnsip thinks that the phone is registered. But will never be able to pass calls to or from the 7961G.

 

The request sent to the phone seems to be on the wrong port number. (49157) the port is in fact 5080. we see that with wireshark 0.99.6.

 

Digisoft VOIP

Link to comment
Share on other sites

The problem here is that the Cisco phone sends UDP packets from a different port than it is listening on. This is extremly NAT unfriendly, and such a phone will never work behind NAT (FYI).

 

There is a setting on the phone called "NAT friendly UDP ports" or so that turns this off. If you toggle this flag the Cisco phone will use the port 5060 for sending and receiving.

 

Cisco is one of the few phones that do this. Practically all other phones use the same port for sending and receiving.

Link to comment
Share on other sites

The problem here is that the Cisco phone sends UDP packets from a different port than it is listening on. This is extremly NAT unfriendly, and such a phone will never work behind NAT (FYI).

 

There is a setting on the phone called "NAT friendly UDP ports" or so that turns this off. If you toggle this flag the Cisco phone will use the port 5060 for sending and receiving.

 

Cisco is one of the few phones that do this. Practically all other phones use the same port for sending and receiving.

 

If you have test and know this flag could be please let me know. There is a setting call <voipControlPort> but somehow pbxnsip do not respect that. Even if the request is properly made to pbxnsip.

 

pbxnsip log >>>> Contact: <sip:5149048083@192.168.3.81:5067;transport=udp>

 

pbxnsip try to contact on a diferent port 49157 we do not understand why this port is used. THIS IS NOT OK!

 

*****

After .....

We have done a test, use 49157 in voipControlPort

 

[0] 20071008112635: SIP Tm udp:200.123.47.50:25195:

SIP/2.0 200 Ok

Via: SIP/2.0/UDP 192.168.3.81:49157;branch=z9hG4bK0b10f88f;rport=25195;received=200.123.47.50

From: <sip:5149048083@66.46.213.1>;tag=0017e03419da00069aa3774f-92fc4a8f

To: <sip:5149048083@66.46.213.1>;tag=32250

Call-ID: 0017e034-19da0002-42362800-44b269f6@192.168.3.81

CSeq: 105 REGISTER

Contact: <sip:5149048083@192.168.3.81:49157;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0017e03419da>";+u.sip!model.ccm.cisco.com=30018;expires=90

Content-Length: 0

 

[0] 20071008112636: SIP Rx udp:200.123.47.50:25195:

REGISTER sip:66.46.213.1 SIP/2.0

Via: SIP/2.0/UDP 192.168.3.81:49157;branch=z9hG4bK0b10f88f

From: <sip:5149048083@66.46.213.1>;tag=0017e03419da00069aa3774f-92fc4a8f

To: <sip:5149048083@66.46.213.1>

Call-ID: 0017e034-19da0002-42362800-44b269f6@192.168.3.81

Max-Forwards: 70

Date: Mon, 08 Oct 2007 15:26:34 GMT

CSeq: 105 REGISTER

User-Agent: Cisco-CP7961G/8.3.0

Contact: <sip:5149048083@192.168.3.81:49157;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-0017e03419da>";+u.sip!model.ccm.cisco.com="30018"

Supported: (null),X-cisco-xsi-6.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:20 Name=SEP0017E03419DA Load=SIP41.8-3-1S Last=Phone-Keypad"

Expires: 3600

 

PS : Somehow the request came back on 49158 seen in wireshark.

 

*****

 

explanation :

 

<voipControlPort>

UDP port to listen for incoming SIP messages (defaults to 5060). Note that this is not the port the phone uses to send SIP messages. This odd behavior is RFC compliant but highly non-standard and breaks symmetric NAT traversal workarounds commonly deployed by VOIP providers.

Link to comment
Share on other sites

This odd behavior is RFC compliant but highly non-standard and breaks symmetric NAT traversal workarounds commonly deployed by VOIP providers.

 

I remember that the older versions had a flag that you can switch off in the user interface. But it seems that this flag is not available in the version 8 any more?! I check my phone here, but even the unlocking does not work for me any more...

 

Maybe there are too many Cisco engineers in the IETF working groups and this is their way of making everyone upgrading to IPv6.

Link to comment
Share on other sites

  • 3 months later...

Don't know if this helps or applies...

But it works for me on the older Cisco phones and V7 or 6.5

 

Steve

 

nat_enable: "1"

voip_control_port: "5060"

 

 

start_media_port: "11200"

end_media_port: "11300

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...