Jump to content

2.1 release available


Recommended Posts

Okay, we made the 2.1 version publically available.

 

The release notes can be found at http://wiki.pbxnsip.com/index.php/Release_Notes_2.1.0. IMHO there are a lot of good fixes and also some interesting new features and 2.1 will be a great release!

 

As stated there, there is not reason to upgrade running systems unless there is a good reason in the release notes. If you just want to try the new version, please ask for a demo key and run the trial on a seperate test machine.

Link to post
Share on other sites

Strange problem today (Polycom 550\2.1.0.2111)

 

1) Call came in to a hunt group

2) Colleague answered

3) Transferred the call to me

4) I was chatting away (~5 minutes)

5) Call cut off (I didn't press anything!)

6) The Caller was then immediately transferred into my voicemail!?

 

The SIP Logs suggest that the PBX sent my phone a BYE, then immediately put the call into my voicemail??

 

I have the logs if you would like to review?

Link to post
Share on other sites

Should the "upgrade" option with the installer work? Tried it on our office PBX (v2111) and it seemed to work, but after checking the version it was still 2111. Renamed the exe, did a repair install and it put the 2115 exe in...

Link to post
Share on other sites

Deleating the password fixed the problem. I think what might have happened is maybe version 2.1 is case sensitive on the user name. On the two computers I tried my user name was cached all lower case and in the PBX.XML file the user name was upper and lower case. The standard seems to be user names are not case sensitive and passwords are.

Link to post
Share on other sites

I was using 2115 today as well and had the same thing happen...

 

I was chatting away (~5 minutes)

Call cut off (I didn't press anything!)

The Caller was then immediately transferred into my voicemail!?

 

 

Also noticed with 2115 the TAPI works great, but the missed call emails with the Click To Dial link no longer takes any username/password I give... The same extension and admin username/password work fine from the web interface...

 

david

Link to post
Share on other sites
We tried the upgrade with a stopped process, that worked. Maybe the problem is with running service.

 

Tried it with a stopped service this morning, upgrading from standard 2.0.3.1715, still the same thing. Also it didn't put any provisioning files in the HTML folder, so I'm not sure if it actually did much. And in this instance, a repair install with the service stopped didn't fix it either.

 

In the end I copied the PBX folder to a new location, uninstalled PBXnSIP, re-installed with 2.1 and copied the config files back over again - this seemed to work, but I'm concerned there may be settings/features that are in the new version that were overwritten by the old files. Do you know if there are any like this or not? I've got a fair few PBX's to update to 2.1 and could do with knowing the best way to do it.

 

UPDATE: It seems the version on the website doesn't contain any of the HTML files for the autoprovisioning of phones.. Was this only in the RC installer and didn't make it to the final one??

 

Thanks

Link to post
Share on other sites
Okay, we made the 2.1 version publically available.

 

The release notes can be found at http://wiki.pbxnsip.com/index.php/Release_Notes_2.1.0. IMHO there are a lot of good fixes and also some interesting new features and 2.1 will be a great release!

 

As stated there, there is not reason to upgrade running systems unless there is a good reason in the release notes. If you just want to try the new version, please ask for a demo key and run the trial on a seperate test machine.

 

Sine Oct 8 2007 it gives this release notes. But were I can find a manual with the descriotion, how the new features can be used?

For examble I have some questions to use RTP pass-through, provisioning adressbook and function keys for Snom-phones or what I can do that at redirected calls is shown the number from the caller and not from the redirected extension.

Link to post
Share on other sites
or what I can do that at redirected calls is shown the number from the caller and not from the redirected extension.

Hmm... this sounds like it could possibly be related to my 2.1 Exchange UM problem.

 

Update: I have been doing some testing using a clean 2.1 install on a separate machine with a demo key, set up two test users with a completely new (3-digit) dial plan on the same Exchange server, used X-Lite to test, and the problem exists on the test server as well.

Link to post
Share on other sites

We have not had 2115 give the issue with the calls where you are in the middle of a conversation and the other end of the call just all of sudden goes to voice mail, but it did happen once last week with a good clean connection...

 

still can't get click to dial in the email to work with 2115, it takes no username/password... This worked in all other versions...

 

all and all very happy with 2115 and it's working great, hopefully the call issue with the user going to voicemail during a call will not come back...

 

david

Link to post
Share on other sites
We have not had 2115 give the issue with the calls where you are in the middle of a conversation and the other end of the call just all of sudden goes to voice mail, but it did happen once last week with a good clean connection...

 

still can't get click to dial in the email to work with 2115, it takes no username/password... This worked in all other versions...

 

all and all very happy with 2115 and it's working great, hopefully the call issue with the user going to voicemail during a call will not come back...

 

david

 

We've experienced the same issue with Polycom 500/600 phones where they were in conversation and all of a sudden lost the call and had the caller transfered to voicemail. We've only had it occur twice and it was isolated to one domain.

 

We've also experienced some issues with transfers on the Linksys phones. It seems to be a hit and miss proposition. I will get a sip trace gathered and email it in.

Link to post
Share on other sites

I think this problem arises when the PBX for whatever reason lost the call and the phone sends a Re-INVITE. In SIP, a Re-INVITE and a INVITE look the same, but the problem is that the Request-URI actually is the phone's own number. That means for the PBX the phone calls its own number, which is the voicemail.

Link to post
Share on other sites
Update: I have been doing some testing using a clean 2.1 install on a separate machine with a demo key, set up two test users with a completely new (3-digit) dial plan on the same Exchange server, used X-Lite to test, and the problem exists on the test server as well.

Since I can reproduce this using a brand new test PBXnSIP installation, I really doubt that this problem is related to just us. I've looked at the trunk settings suggested in the other thread for the Exchange SIP Gateway and I've toggled every other setting that seems related but no luck. Now that I have a test out-of-the-box PBXnSIP installation reproducing the same problem, I can change settings to my heart's content if it's a setting. Whether or not it is a setting, I'm positive that it's related to 2.1 - it wasn't doing this on our production 2.0.3 install, and now both our production and test 2.1 installs are doing the same thing.

 

I really have to get this fixed for our users, who have been pretty patient with me thus far with beta builds and the phone system migration in general. I'll do whatever I can -- my hunch is that it's something internal that I can't fix with a setting, but I would be glad to be wrong. Help?!?

Link to post
Share on other sites
I really have to get this fixed for our users, who have been pretty patient with me thus far with beta builds and the phone system migration in general. I'll do whatever I can -- my hunch is that it's something internal that I can't fix with a setting, but I would be glad to be wrong.

 

Sorry, can we open a new topic on this? I lost the context here... What was the problem???

Link to post
Share on other sites

not sure if this is a 2.1 issue, but do not believe we had the issue before...

 

I have an Agent group setup to call 3 extensions, when a user picks up on one of the extensions, the other two phones get a missed call... Should it not detect that the Agent group got an answer and not show a missed call?

 

I read about this on here somewhere but cannot find it and didn't think it happened before 2.1...

 

They are Polycom IP 430 SIP phones... I read this should work due to RFC 3326 headers or something, is there a setting in pbxnsip? did anything change with this in 2.1?

 

david

Link to post
Share on other sites

As far as I know Polycom does not support the Reason header yet:

 

CANCEL sip:42@192.168.9.227 SIP/2.0

Via: SIP/2.0/UDP 192.168.0.206:5060;branch=z9hG4bK-3c72e22ec1814c8612b6c6085db54721;rport

From: "Hunt Group (41)" <sip:41@localhost>;tag=39657

To: <sip:72@localhost>

Call-ID: 7898709d@pbx

CSeq: 20811 CANCEL

Max-Forwards: 70

Reason: SIP;cause=200;text="Call completed elsewhere"

Content-Length: 0

 

Answer:

 

SIP/2.0 487 Request Cancelled

Via: SIP/2.0/UDP 192.168.0.206:5060;branch=z9hG4bK-3c72e22ec1814c8612b6c6085db54721;rport

From: "Hunt Group (41)" <sip:41@localhost>;tag=39657

To: <sip:72@localhost>;tag=F833CB16-42D3D563

CSeq: 20811 INVITE

Call-ID: 7898709d@pbx

Contact: <sip:42@192.168.9.227>

User-Agent: PolycomSoundPointIP-SPIP_550-UA/2.2.0.0047

Content-Length: 0

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...