Jump to content
Vodia PBX forum
davidav

admin console setup for Mac OS X Server

Recommended Posts

Mac OS X installation is a little tricky because there is currently no installation package (wiki installation guide for OS X refers to an installation package which is not currently available)

The Mac OS X instructions should probably also stress more clearly the need to change the port for the pbxnsip admin console. It runs as its own webserver and most OS X Servers will already be running the preconfigured webserver on port 80. I changed to port 81 and can now logon to the admin console - by using url: http://localhost:81.

Share this post


Link to post
Share on other sites
Mac OS X installation is a little tricky because there is currently no installation package (wiki installation guide for OS X refers to an installation package which is not currently available)

The Mac OS X instructions should probably also stress more clearly the need to change the port for the pbxnsip admin console. It runs as its own webserver and most OS X Servers will already be running the preconfigured webserver on port 80. I changed to port 81 and can now logon to the admin console - by using url: http://localhost:81.

 

That is a generic requirement of the PBX. Nothing specific to Mac OS. Yes, we will mention it in installation and upgrade manuals, if it is not there already.

Share this post


Link to post
Share on other sites

Mac OS X installation is a little tricky because there is currently no installation package (wiki installation guide for OS X refers to an installation package which is not currently available)

The Mac OS X instructions should probably also stress more clearly the need to change the port for the pbxnsip admin console. It runs as its own webserver and most OS X Servers will already be running the preconfigured webserver on port 80. I changed to port 81 and can now logon to the admin console - by using url: http://localhost:81.

 

I'm new to the product -

Can someone help me with the process to change from port 80 to port 81?

 

I'm installing on a new Mac mini server and in fact the Mac's own webserver runs on port 80.

Install ran properly and finished. When I launch browser to http://localhost, I get the "MAC OS X Server" screen "please select from these available web services: My Page, Wikis, Blogs. Can snom be added to this page as a service?

 

How do I know that snom PBX service is running?

Share this post


Link to post
Share on other sites

Take a look at the pbx.xml file and set the ports that you like.

 

Thanks for the prompt reply. I appreciate it. I'm really looking forward to using this product on the Mac mini server.

 

Where do I find that file PBX.XML? I've searched the hard disk and can't locate PBX.XML. I see an snomone folder in a folder named Library.

 

Within the snomone folder, there are two audio folders, a PBX folder and two other files, pbxcntrl-darwin9.0. If I open the PBX folder, there is a PBX file, but I see nothing in it related to Port 80 when I open it with a text editor.

 

What am I missing? Thanks again...

Share this post


Link to post
Share on other sites

Oh it is generated the first time the system starts up... Obviously you di not get to that point yet! You can fix it with this: cd into the directory where you installed the PBX, then start the PBX process manually with this:

 

./pbxctrl-mac --http-port 8080 --https-port 8081 --no-daemon

 

This will also print the console output, in case there is other trouble you will be able to see it.

Share this post


Link to post
Share on other sites

Oh it is generated the first time the system starts up... Obviously you di not get to that point yet! You can fix it with this: cd into the directory where you installed the PBX, then start the PBX process manually with this:

 

./pbxctrl-mac --http-port 8080 --https-port 8081 --no-daemon

 

This will also print the console output, in case there is other trouble you will be able to see it.

 

You are correct - I did not get to the point of starting the system.

 

Please explain in more detail the fix:

cd into the directory where I installed the PBX..

and then what exactly do I do in the folder PBX?

Where do I enter that line of code? How do I start the PBX process?

And don't I need to change it to another port than port 80 due to conflict with Mac mini web server on port 80? Thanks...

Share this post


Link to post
Share on other sites

You need a shell (a "terminal"); I think you can find more information here: http://macdevcenter.com/pub/a/mac/2001/12/14/terminal_one.html. But you don't have to read the whole book, all you need is the "cd" command (change directory). You can use "ls" to see what is in that directory, just to make sure that you are in the right place.

Share this post


Link to post
Share on other sites

You need a shell (a "terminal"); I think you can find more information here: http://macdevcenter.com/pub/a/mac/2001/12/14/terminal_one.html. But you don't have to read the whole book, all you need is the "cd" command (change directory). You can use "ls" to see what is in that directory, just to make sure that you are in the right place.

 

Thanks... that link was very helpful. OK, got that accomplished and attempted to start the system and got this.."FATAL: Could not open TCP port 80 for HTTP/HTTPS" in a file named pbx_startup_err.txt

 

I do have a PBX.XML file now - what do I use to edit it?

 

How do I know what port numbers to change HTTP: and HTTPS: to??

 

Thanks...

Share this post


Link to post
Share on other sites

You need a shell (a "terminal"); I think you can find more information here: http://macdevcenter.com/pub/a/mac/2001/12/14/terminal_one.html. But you don't have to read the whole book, all you need is the "cd" command (change directory). You can use "ls" to see what is in that directory, just to make sure that you are in the right place.

 

OK, got pbx.xml edited to http 81 https 82, attempted to start the PBX and get this:

 

miniserver:snomone don$ ./pbxctrl-darwin9.0 --http-port 8081 --https-port 8082 --no-daemon

Starting up

Bus error

miniserver:snomone don$

 

Now what? Thanks...

Share this post


Link to post
Share on other sites

OK, got pbx.xml edited to http 81 https 82, attempted to start the PBX and get this:

 

miniserver:snomone don$ ./pbxctrl-darwin9.0 --http-port 8081 --https-port 8082 --no-daemon

Starting up

Bus error

miniserver:snomone don$

 

Now what? Thanks...

 

FATAL: Could not open TCP port 389 for HTTP/HTTPS

Share this post


Link to post
Share on other sites

FATAL: Could not open TCP port 389 for HTTP/HTTPS

 

Ok. Please run the same command with "--no-check-ports" as an additional argument on the command line. This will tell the PBX to start even if there was a port issue. Then (assuming the "Bus error" is gone), login to the PBX web interface (I see that you have provided the port 8081 as the http port on the command line) as system admin. Navigate to Admin->settings->Ports page. At the bottom on that page you have the LDAP port set to 389. Change it something else and restart the PBX.

Share this post


Link to post
Share on other sites

Ok. Please run the same command with "--no-check-ports" as an additional argument on the command line. This will tell the PBX to start even if there was a port issue. Then (assuming the "Bus error" is gone), login to the PBX web interface (I see that you have provided the port 8081 as the http port on the command line) as system admin. Navigate to Admin->settings->Ports page. At the bottom on that page you have the LDAP port set to 389. Change it something else and restart the PBX.

 

OK, this is what I saw when I did that - Still can't open the web interface...

 

miniserver:snomone don$ ./pbxctrl-darwin9.0 --http-port 8081 --https-port 8082 --no-daemon --no-check-ports

Starting up

[1] 20110124153629: Starting up version 2011-4.2.0.3959

[1] 20110124153629: Working Directory is /Library/snomone

[5] 20110124153630: Starting threads

[0] 20110124153630: Could not bind socket to port 389 on IP 0.0.0.0

[0] 20110124153630: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20110124153630: Could not bind socket to port 389 on IP [::]

[0] 20110124153630: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20110124153630: UDP: bind() to port 0.0.0.0:161 failed

[0] 20110124153630: Could not open UDP port 161 for SNMP

[0] 20110124153630: UDP: bind() to port [::]:161 failed (errno=13)

[0] 20110124153630: Could not open UDP port 161 for SNMP

[0] 20110124153630: UDP: bind() to port 0.0.0.0:69 failed

[0] 20110124153630: Could not open UDP port 69 for TFTP

[0] 20110124153630: UDP: bind() to port [::]:69 failed (errno=13)

[0] 20110124153630: Could not open UDP port 69 for TFTP

[1] 20110124153630: UDP: TOS could not be set

[5] 20110124153630: Set scheduling priority to 15

Share this post


Link to post
Share on other sites

Maybe be you should send the access (ssh or some sort of remote system access) info to support@pbxnsip.com. We should be able to figure that out.

You mentioned that you could not login to the web interface. Remember to use the port 8081 when you try to login to the web interface.

Share this post


Link to post
Share on other sites

I am reviving this topic because upgrade to OS X Yosemite has created a new problem.

I can run the Snom One admin console at http://localhost:81 (changed port per above) but after installing Snom One I can no longer access the OS X Server's web server. The Websites service in OS X Server (Yosemite) appears to point apache to its own configuration files so maybe the Snom One admin console is starting apache and interfering with OS X Server's website configuration?

Has anybody managed to get Snom One and OS X Server (Yosemite)'s Websites service running together? Any ideas?

Share this post


Link to post
Share on other sites

I already did this before logging the issue. The pbx.xml file has been updated to include:

- <ip_http_port>81</ip_http_port><ip_https_port>444</ip_https_port>

 

This change enabled me to access the pbx admin console on port 81. The problem is that I can no longer access the OS X web server on port 80 (or on the default port which I assume is also 80). I also changed the LDAP port just in case that was causing an issue.

 

PS. Can someone please also update the Wiki (http://wiki.snomone.com/index.php?title=Restarting_the_System) to provide correct instructions for stopping & starting the pbx on Mac OS X. I found several other forum posts on this and it seems that the software has been updated to use current auto-start process on OS X but the documentation on the Wiki is out of date (StartupItems are clearly no longer used) and I couldn't find anything with correct instructions on how to manually restart the system, leaving a full OS X restart as the only option (not desirable when server is running other services).

Share this post


Link to post
Share on other sites

Setting up Snom One on another Mac Mini. The Wiki is still wrong for stopping & starting pbx on OS X. Correct commands are:

 

unload -F /Library/LaunchDaemons/com.vodia.pbx.plist

load -F /Library/LaunchDaemons/com.vodia.pbx.plist

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...