Jump to content

Helo command rejected: need fully-qualified hostname


UKenGB
 Share

Recommended Posts

This is the error I get from postfix when it rejects email sent from the pbx. It is because snomONE is using 'localhost' in the 'helo' to the SMTP server, which is postfix on the same machine on which snomONE is running. There are several ways to fix this:-

 

Remove that restriction from postix's config. I'd rather not do that as it may open the door for abuse by others.

 

Configure postfix to accept a helo using localhost. What I've tried hasn't worked so would be grateful for pointers on this one.

 

Configure snomONE to use a different name in the 'helo'.

 

This last options is preferable, but I cannot find how to change that. Can anyone explain how I can change the name snomONE uses in the helo when sending email notifications of voicemail?

Link to comment
Share on other sites

OK, got postfix to accept the helo from Localhost, but now there's another problem:-

 

status=bounced (mail for mx.home loops back to myself)

 

The email is being sent by snomONE and accepted by postfix, which than complains about it looping.

 

Can anyone suggest how to configure postfix to accept these email messages from snomONE running on the same machine?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...