Jump to content
Vodia PBX forum
R. Baltzer

Exchange 2010 UM and PBXnSIP 4.2

Recommended Posts

Hi,

 

I have upgraded my working configuration PBXnSIP 3.4.0.3201 (with a configured and working Exchange 2010 UM server connection) to PBXnSIP 4.2.0.3958.

Everything is working fine except one thing:

I cannot play a voicemail message anymore on my PBXnSIP connected sip-phones.

 

When I click in Outlook on "Play on phone" then I get the following error message on my Exchange server:

 

An outbound call to sip:907@192.168.0.35;user=phone couldn't be established. The selected outbound gateway "(PBXNSIP 192.168.0.35:5060 outbound=True secured=False)" returned the error "Peer to peer endpoint does not support authentication.". The caller ID used for this call was 'sip:907@EXCH.LAN.LOCAL;user=phone'. Contact the vendors who support your VoIP gateway and IP PBX hardware for help troubleshooting the SIP response error code specified in the event description. You can also run diagnostic tests on your VoIP gateway or IP PBX hardware to make sure the devices are operational. Additional information: Peer to peer endpoint does not support authentication.

 

At the same time I see the following error message on PBXnSIP:

 

[8] 2010/11/22 17:17:57: Received SIP connection 48 from 192.168.0.10:30325

[5] 2010/11/22 17:17:57: Identify trunk (IP address and DID match) 2

[8] 2010/11/22 17:17:57: Call from an user 907

[8] 2010/11/22 17:17:57: To is <sip:907@192.168.0.35;user=phone>, user 55, domain 1

[8] 2010/11/22 17:17:57: To user 907

[8] 2010/11/22 17:17:57: Set the To domain based on From user 907@localhost

[8] 2010/11/22 17:17:57: Call state for call object 5: idle

[8] 2010/11/22 17:17:57: Call state for call object 5: alerting

[8] 2010/11/22 17:17:57: Play audio_moh/noise.wav

[7] 2010/11/22 17:17:57: set_codecs: for 24f8e252-8d1e-4637-873c-49bef5ab4587 codecs "", codec_preference count 6

[7] 2010/11/22 17:17:57: set_codecs: for 20985dd5@pbx codecs "", codec_preference count 6

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: adding codec pcma/8000 to available list

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: adding codec pcmu/8000 to available list

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: adding codec g722/8000 to available list

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: adding codec g726-32/8000 to available list

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: adding codec gsm/8000 to available list

[7] 2010/11/22 17:17:57: update_codecs for 20985dd5@pbx: codec_preference size 6, available codecs size 6

[3] 2010/11/22 17:17:57: Via is empty, cannot send reply

[3] 2010/11/22 17:17:57: Last message repeated 2 times

[5] 2010/11/22 17:17:57: Call 20985dd5@pbx: Last request not finished

[8] 2010/11/22 17:17:57: Call 20985dd5@pbx: Response does not correspond to open request

[8] 2010/11/22 17:17:58: Last message repeated 2 times

[7] 2010/11/22 17:17:58: Call 20985dd5@pbx: Clear last INVITE

[5] 2010/11/22 17:17:58: INVITE Response 487 Request Terminated: Terminate 20985dd5@pbx

[8] 2010/11/22 17:18:00: Packet authenticated by transport layer

[8] 2010/11/22 17:18:05: Last message repeated 4 times

[6] 2010/11/22 17:18:05: SIP TCP/TLS timeout on 192.168.0.10:30325, closing connection

[8] 2010/11/22 17:18:05: Release SIP thread 48

 

When I click on "Play on phone" my sip-phone rings one time and then tells me that the connection was ended.

 

This "Play on phone" functionality was working fine with PBXnSIP 3.4.0.3201.

 

Can anyone tell me what is going on?

Nothing else was changed, only the PBXnSIP software was upgraded to the latest 4.2 release.

 

Kind regards,

 

Rene.

Share this post


Link to post
Share on other sites

Can you post the snom ONE log with SIP debug or PM it to me?

 

To get the log with maximum debug level:

 

- go to Admin -> Settings -> Logging

- set "Log Level" to 9 and "Log Length" to 500

- enable all logs except for "Analyze audio levels"

- also set the following logs to to Yes: "Log REGISTER", "Log SUBSCRIBE/NOTIFY", "Log other messages", "Log call messages"

- press "Save"

- go to Status -> Logfile and press 'Clear'

- make the test, then press 'Reload', copy the log and attach it here or send it to me

Share this post


Link to post
Share on other sites

Can you post the snom ONE log with SIP debug or PM it to me?

 

To get the log with maximum debug level:

 

- go to Admin -> Settings -> Logging

- set "Log Level" to 9 and "Log Length" to 500

- enable all logs except for "Analyze audio levels"

- also set the following logs to to Yes: "Log REGISTER", "Log SUBSCRIBE/NOTIFY", "Log other messages", "Log call messages"

- press "Save"

- go to Status -> Logfile and press 'Clear'

- make the test, then press 'Reload', copy the log and attach it here or send it to me

 

Hi Katerina,

 

I have PM'ed you.

Thanks in advance.

 

Kind regards,

Rene

Share this post


Link to post
Share on other sites

I managed to reproduce this and here is what fixed it: set the IP address of the Outlook server under "Explicitly list addresses for inbound traffic:" in the trunk settings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...