Jump to content

Incorrect server IP in provisioning


Kenny Munro
 Share

Recommended Posts

I'm having a problem getting provisioning working.

 

I have SnomONE build 4.2.0.3958 (also tried 3966) running on Windows 2008 R2. The windows box has 4 public IP addresses:

 

92.X.X.168 - 92.X.X.171

 

SnomOne is configured to be bound to the last of these (.171) which is fine, the web interface etc appears on the correct IP.

 

During the provisioning process, however, the phones just hang. After a bit of digging, I discovered that the response to the initial provisioning request is as follows:

 

<?xml version="1.0" encoding="utf-8"?>

<setting-files>

<file url="http://92.X.X.168:80/prov/snom_3xx_fw.xml?model=snom370" />

<file url="https://92.X.X.168:443/prov/snom_3xx_phone.xml?model=snom370" />

<file url="https://92.X.X.168:443/prov/snom_3xx_fkeys.xml?model=snom370" />

<file url="https://92.X.X.168:443/prov/snom_web_lang.xml?model=snom370" />

<file url="https://92.X.X.168:443/prov/snom_gui_lang.xml?model=snom370" />

<file url="https://92.X.X.168:443/tftp/snom_370_custom.xml" />

</setting-files>

 

As there's a completely different web server running on .168, this obviously doesn't work!

 

Is there a setting somewhere that I've omitted to set or is this a bug?

 

Many thanks,

Kenny

Link to comment
Share on other sites

Right, for SIP sockets the PBX should use the right socket; however for TFTP it is a bit tricky because TFTP requests that the respones must be sent from another socket, so that the PBX essentially asks the OS what local IP address that socket would use. That's where it essentially asks the OS for the local address on an unbound socket. For configuration data that would be a kind of problem; especially if you plan to run several instances one for each IP address (multiple cores).

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...