Jump to content

Unable to register : 403 error from Snom 300 log


Alexandre
 Share

Recommended Posts

Hello,

 

I just bought a Snom 300 phone and I tried to register it with Snom One.

 

 

I was previously using a Swissvoice IP10S with the same credentials which was perfectly working.

 

So I entered same login information into the SNOM 300 administration and when I check the log, the remote PBX answers 403.

 

I triple checked the credentials which are correct.

 

So are there any explaination ? Could my IP address from which the SNOM 300 be blacklisted on PBX ?

 

 

Here's a an extract of LOG error from PBX (Log Level = 9)

 

SIP Rx udp:89.84.168.67:62468:
REGISTER sip:88.191.99.29 SIP/2.0
Via: SIP/2.0/UDP 89.84.168.67:62468;branch=z9hG4bK-yn78lr9wn2vk;rport
From: "Alexandre" <sip:11@88.191.99.29>;tag=3hf8uadbng
To: "Alexandre" <sip:11@88.191.99.29>
Call-ID: 3c2670d6d52f-d6cwk6dr9li4
CSeq: 482 REGISTER
Max-Forwards: 70
Contact: <sip:11@89.84.168.67:62468;line=s8n6xjgq>;reg-id=1;q=1.0;+sip.instance="<urn:uuid:f43d6649-3418-48b9-bd49-c06075206763>";audio;mobility="fixed";duplex="full";description="snom300";actor="principal";events="dialog";methods="INVITE,ACK,CANCEL,BYE,REFER,OPTIONS,NOTIFY,SUBSCRIBE,PRACK,MESSAGE,INFO"
User-Agent: snom300/8.2.29
Allow-Events: dialog
X-Real-IP: 192.168.1.7
Supported: path, gruu
Expires: 3600
Content-Length: 0

[9] 2010/12/12 11:37:16:	Resolve 51992: aaaa udp 89.84.168.67 62468
[9] 2010/12/12 11:37:16:	Resolve 51992: a udp 89.84.168.67 62468
[9] 2010/12/12 11:37:16:	Resolve 51992: udp 89.84.168.67 62468
[7] 2010/12/12 11:37:16:	SIP Tx udp:89.84.168.67:62468:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 89.84.168.67:62468;branch=z9hG4bK-yn78lr9wn2vk;rport=62468
From: "Cyberlex" <sip:11@88.191.99.29>;tag=3hf8uadbng
To: "Cyberlex" <sip:11@88.191.99.29>;tag=57bc4a8867
Call-ID: 3c2670d6d52f-d6cwk6dr9li4
CSeq: 482 REGISTER
User-Agent: snom-PBX/4.2.0.3950
Content-Length: 0

[9] 2010/12/12 11:37:20:	Remote site 89.84.168.67 closed the connection

 

And from the SNOM 300 log's side:

 

8] 12/12/2010 11:53:40: Routing to outbound proxy sip:88.191.99.29
[8] 12/12/2010 11:53:40: route_pending_packet 1000974: entry=url ? sip:88.191.99.29
[8] 12/12/2010 11:53:40: route_pending_packet 1000974: entry=udp 88.191.99.29 5060
[8] 12/12/2010 11:53:40: Send Packet REGISTER
[9] 12/12/2010 11:53:40: result of get_ip_adr:88.191.99.29 192.168.1.7
[9] 12/12/2010 11:53:40: result of get_ip_adr:88.191.99.29 192.168.1.7
[5] 12/12/2010 11:53:40: sip::send_register: reregister timer for line 0 set to 300s
[8] 12/12/2010 11:53:40: Routing to outbound proxy sip:88.191.99.29
[8] 12/12/2010 11:53:40: route_pending_packet 1000975: entry=url ? sip:88.191.99.29
[8] 12/12/2010 11:53:40: route_pending_packet 1000975: entry=udp 88.191.99.29 5060
[7] 12/12/2010 11:53:40: Trusted IP Addresses: udp:88.191.99.29
[2] 12/12/2010 11:53:41: Registrar 11@88.191.99.29 refused with code 403
[5] 12/12/2010 11:53:41: Will try to reregister in 300 seconds

 

 

 

 

I'm stucking on the point as such error isn't explained in pbx log.

 

THe result is just a 403 error on Snom phone.

 

Firmware of phone : 8.2.29

 

 

Thank you for your previous help,

 

Alex

Link to comment
Share on other sites

Looks like you are using "STUN" on the phone. That is not good/neccessary, the PBX takes care about devices behind NAT. You should also use TLS as transport layer so that the traffic can get encrypted. Probably the best way is just to automatically provision the phone. But anyway, this is not the problem here.

 

Possible reasons for "403 Forbidden":

  • You set the IP address in the extension settings ("Trusted IP Addresses" in the extension/registration settings)
  • The From- and To-domain are not the same (should not be the problem here)
  • If you try to subscribe to dialog, the endpoint must have the permission for hat (not the case here because you try to register)

So my guess is the first one; clear the trusted IP addresses and try again.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...