Jump to content

BLF light not working


DaveC
 Share

Recommended Posts

Hi

 

I have a problem with the BLF indicators not working, can anyone help?

 

Running Snom One Version 2011-4.2.0.3958 (Win32)

Using Snom 320's/360's FW 8.4.18

 

The function keys on each phone are set as follows

 

<fkey idx="0" context="active" label="" perm="">blf <sip:600@192.168.110.3;user=phone></fkey>

<fkey idx="1" context="active" label="" perm="">blf <sip:602@192.168.110.3;user=phone></fkey>

<fkey idx="2" context="active" label="" perm="">blf <sip:604@192.168.110.3;user=phone></fkey>

<fkey idx="3" context="active" label="" perm="">blf <sip:606@192.168.110.3;user=phone></fkey>

<fkey idx="4" context="active" label="" perm="">blf <sip:608@192.168.110.3;user=phone></fkey>

<fkey idx="5" context="active" label="" perm="">blf <sip:610@192.168.110.3;user=phone></fkey>

<fkey idx="6" context="active" label="" perm="">dest <sip: *87@192.168.110.3;user=phone/></fkey>

<fkey idx="7" context="active" label="" perm="">blf <sip:601@192.168.110.3;user=phone></fkey>

<fkey idx="8" context="active" label="" perm="">blf <sip:603@192.168.110.3;user=phone></fkey>

<fkey idx="9" context="active" label="" perm="">blf <sip:605@192.168.110.3;user=phone></fkey>

<fkey idx="10" context="active" label="" perm="">blf <sip:607@192.168.110.3;user=phone></fkey>

<fkey idx="11" context="active" label="" perm="">blf <sip:609@192.168.110.3;user=phone></fkey>

 

Make a call to any of the extensions and the lights come on as they should, and the lights follow correctly when they are blind transferred.

 

Problems occur when an attended transfer takes place,

 

Example

 

Call comes into Reception on 600, the call needs to be transferred to 601. 600 places call on hold, dials 601 and informs the user that there is a call for them. The transfer button is then pressed to perform the transfer and the call process is complete, however, the 601 indicator lamp does not illuminate on extension 600. Blind transfer works fine and the indicator light comes on as it should....

 

Obvious problem with this, as with one of our customers, is that the Receptionist on 600 does not know when 601 has finished on that call, defeating the object of the BLF.

 

Am i missing a setting somewhere? Is there a different option i can use to get round this?

 

Thanks in advance.

Link to comment
Share on other sites

There were some issues in the transfer/park/pickup area. I am assuming that these were the root cause for he BLF issues. These issues have been recently fixed and will be part of the update version that is coming out by the end of the week. If you want to use this "beta" version before the release, please send email to support@pbxnsip.com.

Link to comment
Share on other sites

Beta version obtained, thanks.

 

I have just installed this, rebooted the phones, and now they no longer get their settings from the custom xml files in the tftp folder, meaning the function keys and other options do not provision.

 

Have I missed something in the setup?

Link to comment
Share on other sites

Too many people complained that the custom files could not be found, so we took it out... Anyway, you can easily put it back in by adding the line snom_821_custom.xml in the web interface (web page control/templates):

 

<?xml version="1.0" encoding="utf-8"?>
<setting-files>
 <file url="{http-url}/snom_3xx_fw.xml?model=snom821" />
 <file url="{https-url}/snom_820_phone.xml?model=snom821" />
 <file url="{https-url}/snom_820_fkeys.xml?model=snom821" />
 <file url="{https-url}/snom_web_lang.xml?model=snom821" />
 <file url="{https-url}/snom_gui_lang.xml?model=snom821" />
 <file url="{https-url}/snom_821_custom.xml" />
</setting-files>

 

 

 

 

Link to comment
Share on other sites

I assume you mean the relevant Snom XML from the drop down box?

 

I have added the line in so that the Snom320.xml looks like this;

<?xml version="1.0" encoding="utf-8"?>

<setting-files>

<file url="{http-url}/snom_3xx_fw.xml?model=snom320" />

<file url="{https-url}/snom_3xx_phone.xml?model=snom320" />

<file url="{https-url}/snom_3xx_fkeys.xml?model=snom320" />

<file url="{https-url}/snom_web_lang.xml?model=snom320" />

<file url="{https-url}/snom_gui_lang.xml?model=snom320" />

<file url="{https-url}/snom_320_custom.xml" />

</setting-files>

 

 

However i get an error when it requests the snom_320_custom.xml file;

[8] 2011/01/25 10:24:36: Received request for file snom_320_custom.xml

[8] 2011/01/25 10:24:36: Error finding snom_320_custom.xml, Send back 404 Not Found

 

 

I still have the snom_320_custom.xml in the tftp folder as required before, do i need to move it somewhere else?

 

Thanks

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...