Jump to content

server IP and auto provision


iActive
 Share

Recommended Posts

I am setting up provisioning for over the WAN and I was wondering if there was any way to override the IP address that the PBX thinks it should use in the provisioning links.

 

Example - our publix PBX is NAT'd behind a firewall. Instead of presenting Phone login requests with the public IP address of the PBX it is sending out the internal IP address and the external phones are not able to register.

 

<?xml version="1.0" encoding="utf-8" ?>

- <setting-files>

<file url="http://192.168.204.50:80/prov/snom_3xx_fw.xml?model=snom300" />

<file url="https://192.168.204.50:443/prov/snom_3xx_phone.xml?model=snom300" />

<file url="https://192.168.204.50:443/prov/snom_3xx_fkeys.xml?model=snom300" />

<file url="https://192.168.204.50:443/prov/snom_web_lang.xml?model=snom300" />

<file url="https://192.168.204.50:443/prov/snom_gui_lang.xml?model=snom300" />

<file url="https://192.168.204.50:443/tftp/snom_300_custom.xml" />

</setting-files>

 

 

Is there any way to change the IP address that is used here?

 

Greg

Link to comment
Share on other sites

You can do so by changing the templates.

Please -

  • Navigate to "Admin->Web Page Control->Templates".
  • Select snom_300.xml
  • Change the '{http-url}" to http://<public ip:port>/prov
  • Change the '{https-url}" to https://<public ip:port>/prov
  • Save the file
  • Reboot the phone

 

Note that you have replace the <public ip:port> with the actual public IP and port.

Link to comment
Share on other sites

Is there any way to change the IP address that is used here?

 

Well you routing tells the PBX to use the private IP address when talking to the public Internet. Check "route print" (Windows) if it uses the right interface when talking to the WAN. You might have to change the default route to use the public IP interface.

Link to comment
Share on other sites

well this issues was that I needed to upgrade because my version did not have the web page control tab. Now that I've upgraded I see the tab and I've made the change to snom_300.xml document but now according the logs I need to change the 300fs and 300fw files and apparently I need to load some configuration file else the phone will not be provisioned. Any advice or if you could point me to the correct documentation I can learn for myself.

Link to comment
Share on other sites

that's resolved

 

now..

 

When when the phone goes to <public ip>/provisioning/snom300.htm it produces this output

 

<?xml version="1.0" encoding="utf-8" ?>

- <setting-files>

<file url="<public ip>/prov/snom_3xx_fw.xml?model=snom300" />

<file url="<public ip>/prov/snom_3xx_phone.xml?model=snom300" />

<file url="<public ip>/prov/snom_300_fkeys.xml?model=snom300" />

<file url="<public ip>/prov/snom_web_lang.xml?model=snom300" />

<file url="<public ip>/prov/snom_gui_lang.xml?model=snom300" />

</setting-files>

 

when the phone connects to <public ip>//prov/snom_3xx_fw.xml?model=snom300 it produces this output

<?xml version="1.0" encoding="utf-8" ?>

- <phone-settings>

<firmware_status perm="RW"><public ip>/prov/snom_3xx_fs.xml?model=snom300</firmware_status>

</phone-settings>

 

and when the phone finally tries to go to <public ip>/prov/snom_3xx_fs.xml?model=snom300

 

We get the following output

 

File snom_3xx_fs.xml is empty

Please ask your system administrator to check the log file.

Link to comment
Share on other sites

and when the phone finally tries to go to <public ip>/prov/snom_3xx_fs.xml?model=snom300

 

We get the following output

 

File snom_3xx_fs.xml is empty

Please ask your system administrator to check the log file.

 

Did you try to load this file from the web browser? If that does not work, did you change anything in pnp.xml or did you change this file (either in the web interface or on the file system)? "It should work", I checked here.

Link to comment
Share on other sites

Did you try to load this file from the web browser? If that does not work, did you change anything in pnp.xml or did you change this file (either in the web interface or on the file system)? "It should work", I checked here.

 

It does not load from the web browser. I did not change anything this is a fresh install.

Link to comment
Share on other sites

So, if you login to the PBX web interface and type "http://<public IP>/prov/snom_3xx_fs.xml?model=snom300", it does not show anything on the web page?

 

It should show something like http://provisioning.snom.com/download/fw/snom300-8.4.18-SIP-f.bin

Can you please check what is set on "Admin->Settings->PnP: Firmware for snom 300" field?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...