Jump to content
Vodia PBX forum
YSJ3010

wrong time settings

Recommended Posts

below is the settings for the time for polycom phones

 

the problem is that the PBX doesn't reply anything {tz dst-start-dayp}

 

the work around is to enter tcpIpApp.sntp.daylightSavings.start.date="12"

 

please fix this

 

 

 

<SNTP tcpIpApp.sntp.resyncPeriod="86400" tcpIpApp.sntp.address="{tz ntp-adr}"

 

tcpIpApp.sntp.address.overrideDHCP="0" tcpIpApp.sntp.gmtOffset="{tz gmt-offset}"

tcpIpApp.sntp.gmtOffset.overrideDHCP="1" tcpIpApp.sntp.daylightSavings.enable="{tz

dst-enable 1}" tcpIpApp.sntp.daylightSavings.fixedDayEnable="{tz dst-fixed}"

tcpIpApp.sntp.daylightSavings.start.month="{tz dst-start-month}"

tcpIpApp.sntp.daylightSavings.start.date="{tz dst-start-dayp}"

tcpIpApp.sntp.daylightSavings.start.time="{tz dst-start-hour}"

tcpIpApp.sntp.daylightSavings.start.dayOfWeek="{tz dst-start-wday}"

tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth="{tz dst-start-last}"

tcpIpApp.sntp.daylightSavings.stop.month="{tz dst-stop-month}"

tcpIpApp.sntp.daylightSavings.stop.date="{tz dst-stop-dayp}"

tcpIpApp.sntp.daylightSavings.stop.time="{tz dst-stop-hour}"

tcpIpApp.sntp.daylightSavings.stop.dayOfWeek="{tz dst-stop-wday}"

tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth="{tz dst-stop-last}"/>

Share this post


Link to post
Share on other sites

Well in other time zones it does work. I guess it is because the "dst_start_day" (and "dst_stop_day") are missing:

<zone name="CAT">
 <description>Central African Time</description>
 <gmt_offset>7200</gmt_offset>
</zone>

You might want to try:

<zone name="CAT">
 <description>Central African Time</description>
 <gmt_offset>7200</gmt_offset>
 <dst_start_day>2</dst_start_day>
</zone>

For Polycom, the day gets multiplied by 7. If you want to use the raw input, use the name "dst-start-day" in the template.

Share this post


Link to post
Share on other sites

Hi

By polycom phones it needs to be entered like below i email polycom to confirm I will post when they get back to me

 

how can we setup what {tz dst-start-dayp} should be?

tcpIpApp.sntp.daylightSavings.enable="1"

tcpIpApp.sntp.daylightSavings.fixedDayEnable="0"

tcpIpApp.sntp.daylightSavings.start.month="3"

tcpIpApp.sntp.daylightSavings.start.date="12" --------------------{tz dst-start-dayp}

tcpIpApp.sntp.daylightSavings.start.time="2"

tcpIpApp.sntp.daylightSavings.start.dayOfWeek="1"

Thanks

Share this post


Link to post
Share on other sites

I got the reply from Polycom

it should be tcpIpApp.sntp.daylightSavings.start.date="8"

Pbxnsip please fix that {tz dst-start-dayp} should work on EST

Share this post


Link to post
Share on other sites

There maybe some tags not populated on the timezones.xml file for various time zones. Here is what you have to do to fix this issue -

  1. Navigate to Admin->Web Page Control->Templates page (version .3981 is ideal. If you are running older versions, this page is under Email tab)
  2. Select "timezones.xml" file
  3. Find the timezone your PBX/Domain is in. Ex: <zone name="EDT"> or <zone name="EST"> for eastern time zones.
  4. Please change the values in this block based on your need. Add if something is missing. Ex: Add <dst_start_day>2</dst_start_day>. Also, change value of <dst_start_day_of_week> if needed. The default here is 1.
  5. Save the file.
  6. Restart the PBX
  7. Restart the phone

Share this post


Link to post
Share on other sites

make sure your polycom_sip.cfg says tcpIpApp.sntp.daylightSavings.start.date="{tz dst-start-day}"

 

for some reason the my 3.4 was wrong.

Share this post


Link to post
Share on other sites

it was only a typo on the form

tcpIpApp.sntp.daylightSavings.start.date="{tz dst-start-day}"

 

and its not working

 

in the generated files its blank see below

 

tcpIpApp.sntp.daylightSavings.start.date=""

Share this post


Link to post
Share on other sites

Please find attached

 

in the EST you have <dst_start_week_of_month>2</dst_start_week_of_month>

 

 

well the polycom needs the day of the month not the 2nd week

 

 

tcpIpApp.sntp.daylightSavings.start.date=""

 

 

 

 

 

 

<?xml version="1.0" encoding="utf-8"?>

<timezones dict="timezones.xml">

<zone name="HST">

<description>Hawaii-Aleutian Standard Time</description>

<gmt_offset>-36000</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="AKDT">

<description>Alaska Time Zone</description>

<gmt_offset>-32400</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="AKST">

<description>Alaska Time Zone (No DST)</description>

<gmt_offset>-32400</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="PDT">

<description>Pacific Time Zone</description>

<gmt_offset>-28800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="PST">

<description>Pacific Time Zone (No DST)</description>

<gmt_offset>-28800</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="MDT">

<description>Mountain Time Zone</description>

<gmt_offset>-25200</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="MST">

<description>Mountain Time Zone (No DST)</description>

<gmt_offset>-25200</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="CDT">

<description>Central Time Zone</description>

<gmt_offset>-21600</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="CST2">

<description>Central Time Zone (No DST)</description>

<gmt_offset>-21600</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="EDT">

<description>Eastern Time Zone</description>

<gmt_offset>-18000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="EST">

<description>Eastern Time Zone (No DST)</description>

<gmt_offset>-18000</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="ADT">

<description>Atlantic Time Zone</description>

<gmt_offset>-14400</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="AST">

<description>Atlantic Time Zone (No DST)</description>

<gmt_offset>-14400</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="NDT">

<description>Newfoundland Time Zone</description>

<gmt_offset>-10800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

<zone name="NST">

<description>Newfoundland Time Zone (No DST)</description>

<gmt_offset>-10800</gmt_offset>

<ampm>12</ampm>

</zone>

<zone name="BST">

<description>British Standard Time</description>

<gmt_offset>0</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="CET">

<description>Central Europe Time</description>

<gmt_offset>3600</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+2">

<description>Eastern European Time</description>

<gmt_offset>7200</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="TUR">

<description>Turkey, Istanbul</description>

<gmt_offset>+7200</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>7</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>01:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>7</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>01:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+3">

<description>Russia, Moscow</description>

<gmt_offset>10800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+4">

<description>Russia, Samara</description>

<gmt_offset>14400</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+5">

<description>Russia, Ekaterinburg</description>

<gmt_offset>18000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+6">

<description>Russia, Novosibirsk</description>

<gmt_offset>21600</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+7">

<description>Russia, Krasnoyarsk</description>

<gmt_offset>25200</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+8">

<description>Russia, Irkutsk</description>

<gmt_offset>28800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="GMT+9">

<description>Russia, Yarkutsk</description>

<gmt_offset>32400</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>10</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="CST">

<description>China, Taiwan, Singapore</description>

<gmt_offset>28800</gmt_offset>

</zone>

<zone name="CAT">

<description>Central African Time</description>

<gmt_offset>7200</gmt_offset>

</zone>

<zone name="IST">

<description>Indian Standard Time</description>

<gmt_offset>19800</gmt_offset>

</zone>

<zone name="AUS1">

<description>Western Australia</description>

<gmt_offset>28800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>10</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>3</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>Last</dst_stop_week_of_month>

</zone>

<zone name="AUS2">

<description>South Australia</description>

<gmt_offset>37800</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>10</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>4</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

</zone>

<zone name="AUS3">

<description>Northern Territory</description>

<gmt_offset>34200</gmt_offset>

</zone>

<zone name="AUS4">

<description>Queensland</description>

<gmt_offset>36000</gmt_offset>

</zone>

<zone name="AUS5">

<description>New South Wales</description>

<gmt_offset>36000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>10</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>4</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

</zone>

<zone name="AUS6">

<description>Australian Capital Territory</description>

<gmt_offset>36000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>10</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>4</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

</zone>

<zone name="NZST">

<description>New Zealand Standard Time</description>

<gmt_offset>43200</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>9</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>4</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

</zone>

<zone name="CHAST">

<description>Chatham Standard Time</description>

<gmt_offset>45900</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_month>9</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>Last</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>4</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

</zone>

<zone name="GMT">

<description>Greenwich Mean Time</description>

<gmt_offset>0</gmt_offset>

</zone>

</timezones>

 

 

Share this post


Link to post
Share on other sites

I did not see <dst_start_day>2</dst_start_day> in the attached file. I thought that's what was suggested in the earlier posts.

Updated block for Eastern Time Zone (EDT) looks like below

 

<zone name="EDT">

<description>Eastern Time Zone</description>

<gmt_offset>-18000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_day>2</dst_start_day>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

Share this post


Link to post
Share on other sites

Can anyone help me?

 

I have a system running latest WIndows Build 4.2.1.4002 (Win32) but for some reason non of their polycom phones show the correct time, no matter what I do the phones cannot pick up the time they are constantly flashing some random date and time!

 

I have tried the following:

 

1) Updating Phone System to latest build.

2) Updating Polycom Phones to latest bootrom and firmware.

3) Rebooted system multiple times.

4) Reset timeserver multiple times

5) Followed steps below to make changes to EDT timezone.

 

The phones themselves have no access to the outside world so the DHCP server gives out the IP of the phone system for NTP and Time Server and until recently that worked fine.

 

Please advise if you have any idea what could be causing this.

 

 

 

 

 

I did not see <dst_start_day>2</dst_start_day> in the attached file. I thought that's what was suggested in the earlier posts.

Updated block for Eastern Time Zone (EDT) looks like below

 

<zone name="EDT">

<description>Eastern Time Zone</description>

<gmt_offset>-18000</gmt_offset>

<dst_offset>3600</dst_offset>

<dst_start_day_of_week>1</dst_start_day_of_week>

<dst_start_day>2</dst_start_day>

<dst_start_month>3</dst_start_month>

<dst_start_time>02:00</dst_start_time>

<dst_start_week_of_month>2</dst_start_week_of_month>

<dst_stop_day_of_week>1</dst_stop_day_of_week>

<dst_stop_month>11</dst_stop_month>

<dst_stop_time>02:00</dst_stop_time>

<dst_stop_week_of_month>1</dst_stop_week_of_month>

<ampm>12</ampm>

</zone>

Share this post


Link to post
Share on other sites

Are they just off by one hour or are they completely off? In the first case that would be a problem with the nitty gritty details of the daylight savings. In the latter case, muts be a problem telling the phones where the NTP server is and then also reaching it.

 

Also make sure that the NTP server has the right time...

Share this post


Link to post
Share on other sites

Are they just off by one hour or are they completely off? In the first case that would be a problem with the nitty gritty details of the daylight savings. In the latter case, muts be a problem telling the phones where the NTP server is and then also reaching it.

 

Also make sure that the NTP server has the right time...

 

As of right now the phones do not get the correct date or time at all, I believe the issue to be that they are not contacting the correct place for the time.

 

Option 66 gives out the PBX as the NTP server but for some reason the time is not being pulled correctly.

 

Please advise asap.

Share this post


Link to post
Share on other sites

When PBX generates the plug and play file, it uses ntp_host parameter from the pbx.xml file as the NTP server. This has a default value of ntp.pool.org. If you are doing PnP, then phone will receive this value.

 

So, you can either change this default value on the PBX to something else or change the ntp_server field under snom_3xx_phone.xml for snom phones or tcpIpApp.sntp.address field under polycom_sip.xml for polycom phones

Share this post


Link to post
Share on other sites

When PBX generates the plug and play file, it uses ntp_host parameter from the pbx.xml file as the NTP server. This has a default value of ntp.pool.org. If you are doing PnP, then phone will receive this value.

 

So, you can either change this default value on the PBX to something else or change the ntp_server field under snom_3xx_phone.xml for snom phones or tcpIpApp.sntp.address field under polycom_sip.xml for polycom phones

 

I do not see a line that says ntp_host but i do see this:

 

<SNTP tcpIpApp.sntp.resyncPeriod="86400" tcpIpApp.sntp.address="pool.ntp.org" tcpIpApp.sntp.address.overrideDHCP="0" tcpIpApp.sntp.gmtOffset="-18000" tcpIpApp.sntp.gmtOffset.overrideDHCP="1" tcpIpApp.sntp.daylightSavings.enable="1" tcpIpApp.sntp.daylightSavings.fixedDayEnable="0" tcpIpApp.sntp.daylightSavings.start.month="3" tcpIpApp.sntp.daylightSavings.start.date="" tcpIpApp.sntp.daylightSavings.start.time="2" tcpIpApp.sntp.daylightSavings.start.dayOfWeek="1" tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth="0" tcpIpApp.sntp.daylightSavings.stop.month="11" tcpIpApp.sntp.daylightSavings.stop.date="" tcpIpApp.sntp.daylightSavings.stop.time="2" tcpIpApp.sntp.daylightSavings.stop.dayOfWeek="1" tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth="0"/>

Share this post


Link to post
Share on other sites

I do not see a line that says ntp_host but i do see this:

 

Well, take a look at the pbx.xml file, there you should see the host. Anyway, you can as well edit the XML template for the phone and do the change there.

Share this post


Link to post
Share on other sites

I do not see a line that says ntp_host but i do see this:

 

<SNTP tcpIpApp.sntp.resyncPeriod="86400" tcpIpApp.sntp.address="pool.ntp.org" tcpIpApp.sntp.address.overrideDHCP="0" tcpIpApp.sntp.gmtOffset="-18000" tcpIpApp.sntp.gmtOffset.overrideDHCP="1" tcpIpApp.sntp.daylightSavings.enable="1" tcpIpApp.sntp.daylightSavings.fixedDayEnable="0" tcpIpApp.sntp.daylightSavings.start.month="3" tcpIpApp.sntp.daylightSavings.start.date="" tcpIpApp.sntp.daylightSavings.start.time="2" tcpIpApp.sntp.daylightSavings.start.dayOfWeek="1" tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth="0" tcpIpApp.sntp.daylightSavings.stop.month="11" tcpIpApp.sntp.daylightSavings.stop.date="" tcpIpApp.sntp.daylightSavings.stop.time="2" tcpIpApp.sntp.daylightSavings.stop.dayOfWeek="1" tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth="0"/>

 

Looks like the PBX correctly applied the tcpIpApp.sntp.address as "pool.ntp.org". Now, you will have to see how Polycom makes use of rest of the 'sntp' parameters.

Share this post


Link to post
Share on other sites

When PBX generates the plug and play file, it uses ntp_host parameter from the pbx.xml file as the NTP server. This has a default value of ntp.pool.org. If you are doing PnP, then phone will receive this value.

 

So, you can either change this default value on the PBX to something else or change the ntp_server field under snom_3xx_phone.xml for snom phones or tcpIpApp.sntp.address field under polycom_sip.xml for polycom phones

 

Hi,

 

I have tried this to no avail, I still cannot get the phones to pull the correct time.

 

The client is ready to kill as their phones have been flashing time for the past few months already.

 

PLEASE HELP>

Share this post


Link to post
Share on other sites

Since the config file seems to contain the correct parameters, Polycom should display the time properly. So, can you check with the Polycom folks to see why it is still flashing?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...