Jump to content

SNOM 300 - Directory button doesn't work


voipguy
 Share

Recommended Posts

PnP works fine for the SNOM 300 but the directory key (button 4) doesn't work.

 

In pbxnsip under Settings/PnP tab for the SNOM 300 button 4 it has this listed:

url {http-url snom}/adrbook.xml?user={id}&auth={webhash}

 

...then after the phone gets PnP'd I go into the phones web interface and it has this in button 4;

http:// pbxnsip server ip:80/snom/adrbook.xml?user=181&auth=bf0a(long hash code)bbb3

 

when you press the directory key nothing gets displayed.

 

 

 

In my SNOM 320 phones web interface it has this listed for the directory key;

http:// pbxnsip server ip:80/snom/adrbook.xml?auth=basic

 

so I manually put http:// pbxnsip server ip:80/snom/adrbook.xml?auth=basic in my SNOM 300 button 4 and now my directory key lists my directory info on my SNOM 300 - it works!

 

so then I took http:// pbxnsip server ip:80/snom/adrbook.xml?auth=basic and put it in pbxnsips Settings/PnP tab for button 4 and then rebooted my snom 300 so it would get provisioned again but now for button 4 it's empty and of course the directory key no longer works.

 

How can I get my directory key working on SNOM 300's without manually programming button 4 in each of the SNOM 300's web interface?

 

This is for a remote client setup - 5 phones.

 

Thanks

Link to comment
Share on other sites

Right now the way to get it working is to do the change manually. You can use the PBX web interface and change the provisioning template.

 

 

The rationale behind it was that the display is so small and the number of keys is so limited that we did not include the address book by default.

Link to comment
Share on other sites

Right now the way to get it working is to do the change manually. You can use the PBX web interface and change the provisioning template.

 

I tried that but couldn't get it to work.

 

But I did get it to work by replacing "url {http-url snom}/adrbook.xml?user={id}&auth={webhash}" which is under Settings/PnP tab in the Button 4 field with this "url {http-url snom}/adrbook.xml?user={id}&auth=basic"

 

Now the Directory button works on my SNOM 300's....looks like the problem is with "auth={webhash}" when it should be "auth=basic" I don't know but I do know it works now.

 

The rationale behind it was that the display is so small and the number of keys is so limited that we did not include the address book by default.

 

I understand but since the SNOM 300 comes out of the box with button 4 labeled as the Directory key I think pbxnsip should provision it as the Directory key and if the person wants to change it on there own then they can. As of right now nothing is provsioned in button 4 - I could see if pbxnsip provsioned it as a voice mail key or something else but it's just blank so it's still useless.

Link to comment
Share on other sites

Now the Directory button works on my SNOM 300's....looks like the problem is with "auth={webhash}" when it should be "auth=basic" I don't know but I do know it works now.

 

 

We changed it to auth=basic because the web hash was kind of static, especially when you change the password. basic authentication is better (digest would be even better, but that is just wishful thinking right now).

 

I understand but since the SNOM 300 comes out of the box with button 4 labeled as the Directory key I think pbxnsip should provision it as the Directory key and if the person wants to change it on there own then they can. As of right now nothing is provsioned in button 4 - I could see if pbxnsip provsioned it as a voice mail key or something else but it's just blank so it's still useless.

 

Yea blame marketing they wanted to give customers to have a reason for going for 320. The directory on snom 300 is by default local as far as I remember.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...