Jump to content

Trunk Re-Registration Problems


JohnnyG
 Share

Recommended Posts

We have a problem with our trunks often failing to automatically reregister following an internet connection interruption. I have to go in to the Trunks page and click "register" to get it working again. This happens about once every couple of months, but I can reproduce it very easily.

 

Our setup:

SnomeOne version 2011-4.2.0.3981 (Win64)

Trunk 1: Callcentric

Trunk 2: voip.ms

Firewall: Watchguard XTM23

Internet: Time Warner Business Class Cable

 

The Problem: (typical example)

Starting with both trunks registered, the log shows these entries once per minute for a long time...

[8] 2011/05/15 16:28:21: Trunk 1 (CallCentric) is associated with the following addresses: udp:204.11.192.38:5060

[8] 2011/05/15 16:28:22: Trunk 2 (voipms) is associated with the following addresses: udp:64.120.22.242:5060

 

I then unplug ethernet cable between firewall and cable modem to simulate internet outage and I get these log entries...

[5] 2011/05/15 16:30:13: Registration on trunk 1 (CallCentric) failed. Retry in 60 seconds

[2] 2011/05/15 16:30:13: Trunk status CallCentric (1) changed to "408 Request Timeout" (Registration failed, retry after 60 seconds)

 

Notice that there is no trunk status change for Trunk 2 - on the trunks page it shows the status as "200 OK (Refresh interval 60 seconds)". But there is no way it can be registered, there is no internet connection. The voip.ms web site shows the registration is indeed lost.

 

I then plug the cable back in to simulate restoration of the internet connection and I get these log entries...

[8] 2011/05/15 16:45:07: Trunk 1 (CallCentric) is associated with the following addresses: udp:204.11.192.39:5060

[2] 2011/05/15 16:45:08: Trunk status CallCentric (1) changed to "200 Ok" (Refresh interval 60 seconds)

[8] 2011/05/15 16:46:08: Trunk 1 (CallCentric) is associated with the following addresses: udp:204.11.192.39:5060

[8] 2011/05/15 16:52:08: Last message repeated 6 times

 

What happened to trunk 2???

Click "Register" on Trunk 2 and I get these log entries...

[8] 2011/05/15 16:54:47: Trunk 2 (voipms) is associated with the following addresses: udp:64.120.22.242:5060

[8] 2011/05/15 16:55:09: Trunk 1 (CallCentric) is associated with the following addresses: udp:204.11.192.34:5060

[8] 2011/05/15 16:55:47: Trunk 2 (voipms) is associated with the following addresses: udp:64.120.22.242:5060

 

Trunk 2 is now registered and working, but notice there is no trunk status change message - I suspect that is because it thinks it was never unregistered.

 

At this point you might suspect something is wrong with the configuration of Trunk 2 that is correct on Trunk 1. However, when I repeat this exercise sometimes Trunk 1 has the problem while Trunk 2 is fine. Sometimes both trunks work fine, sometimes both trunks fail. I've only done this test five times; twice Trunk 1 had the problem, one time Trunk 2 had the problem (log entries above), once both trunks had the problem, and once neither Trunk had a problem.

 

Any ideas on how to solve this problem would be greatly appreciated.

 

Thanks,

John G.

Link to comment
Share on other sites

  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

Hi, I have the same problem, but I cannot reproduce it like you. After 2-3 weeks the reregistration of all of my trunks (I have 3) fails. To fix it I have to reregister the trunks in the web interface.

 

Hope somone can help or give some adivce.

 

Thanks

 

Jörg

Link to comment
Share on other sites

We are looking into a problem that has a similar issue, i.e. every 2-3 weeks trunk page shows "200 OK", where as the trunk provider does not have the registrations. We are checking to see if this is the provider issue, DNS issue or something else. We will let you know when we have an update.

Link to comment
Share on other sites

I tried a similar test (2 trunks, iptables rule to drop all packets) and both my channels turned to "408 Request Timeout" and then back to "200 Ok". There must be something specific happening in your case. Can you post the log with SIP debug here?

I followed the instructions in the manual and set the log like this:

Log Level: 7

Log general events: Yes

Log SIP events: Yes

Log trunk events: Yes

Log other messages (under SIP): Yes

All other events set to No.

 

System up and working fine, then unplug internet cable between firewall and cable modem for 5 minutes. The following events get logged.

 

[4] 2011/05/16 18:49:12: Could not find packet with number 338

[4] 2011/05/16 18:49:14: Could not find packet with number 339

 

Neither trunk goes to "408 Timeout", both continue to say "200 OK" for the entire duration.

 

After 5 minutes I plugged the cable back in and waited another 5 minutes. Nothing appears in the log. Trunks still say "200 OK", web sites for both trunks say "Not Registered".

 

Click "Register" for each trunk; both change to "Registered" at web sites, nothing appears in log.

 

Do you need me to log any other information or perform more trials?

 

Thanks,

John

Link to comment
Share on other sites

You should also set the following, to be sure we catch all SIP messages:

 

Log REGISTER: Yes

Log SUBSCRIBE/NOTIFY: Yes

Log call messages: Yes

Log other messages: Yes

I performed the procdure with these items enabled. Once again both trunks reported "200 OK" for the entire duration. The log file is attached.

 

Procedure:

1. Turned off all phones so extension registrations would not clutter up the log.

2. Cleared the log file and waited for each trunk to show registration messages.

3. Unplugged ethernet cable between firewall and cable modem (time: 17:38)

4. Waited 5 minutes then plugged cable back in (time: 17:43)

5. Waited 5 minutes for trunks to register - they did not (according to trunk provider web site). Clicked "Register" for each trunk (time: 17:48)

 

While I'm no SIP expert, I didn't see any useful new information other than the "Could not find packet with number #" already reported. The trunks simply seem to stop trying to register until I manually intervene.

 

Link to comment
Share on other sites

The core problem is that the PBX does the DNS resolving every time that it sends a REGISTER. That was quite a stress test for the whole subsystem, especially when DNS records are not present (especially when DNS NAPTR and SRV records are not available). In other words, the problem was that when there was a problem with the DNS problem, the trunk would easily loose the registration as well.

 

We made a change in this area, and if you like, please send a private message to pbx_support and indicate what OS you need. We already wanted to release version, however there are some non-critical fixed holding us back from a new release right now.

Link to comment
Share on other sites

  • 2 weeks later...

I am sorry to report that I have requested and installed the latest build, 2011-4.2.1.4010 (Win64), and the problem is not fixed. I interrupted the network for 10 minutes and both trunks status displayed "200 OK" the whole time, then after restoring the network and waiting 10 minutes the voip provider web site still showed no registration. I had to manually click "REGISTER" for each trunk before they would register.

Link to comment
Share on other sites

Yes, but the difference is that now the trunk does change the status to '408 Timeout...'. You can setup your system to send the administrator an email when this happens.

Ours doesn't. It continues to say "200 OK" indefinately with the network cable unplugged from the internet router. I tried it just now unplugging the network cable from the back of the computer running SnomOne and I have the same problem - it never goes into timeout status. It's as if it completely stops trying to register the trunks.

 

I do have our SnomOne setup to send me email when a trunk status changes - but it doesn't help much because this isn't detected as a trunk status change.

Link to comment
Share on other sites

Can you please copy paste the Admin->Status page?

 

 

System Status Overview:

 

Please use the information shown on this web page when you request help from the support team.

 

Version: 2011-4.2.1.4010 (Win64)

 

Created on: Apr 19 2011 11:58:15

 

License Status: snom ONE free

 

License Duration: Permanent

 

Additional license information: Extensions: 4/10 Accounts: 15/30 Upgrade: 01 01 2013

 

Working Directory: C:\Program Files\snom\snomONE

 

MAC Addresses: 204153594EFF B8AC6F907B43 EE2820524153

 

Calls: 1/0 (CDR: 38/24/41) 0/0 Calls

 

SIP packet statistics: Tx: 1547 Rx: 1859

 

Emails: Successful sent: 2 Unsuccessful attempts: 0

 

Uptime: 2011/6/15 16:32:24 (uptime: 0 days 02:38:59) (60MB/4086MB 26% 24710720-0) WAV cache: 2

 

Number of HTTP sessions: Sessions: PAC=0, HTTP=1; Threads: SIP=0, HTTP=5

Link to comment
Share on other sites

Hi

we got the same issue, here is our system

 

Version: 2011-4.2.0.3981 (Linux)

Created on: Jan 27 2011 12:03:42

Stato licenza: snom ONE free

Durata licenza: Permanent

Informazioni di licenza aggiuntive: Extensions: 6/10 Accounts: 18/30 Upgrade: 01 01 2013

Directory attiva: /usr/local/snomONE

Indirizzi MAC: 000FEACD601C

Chiamate: 33/39 (CDR: 76/33/69) 0/0 Calls

Statistiche pacchetto SIP: Tx: 142999 Rx: 62704

Email: Inviato correttamente: 52 Tentativi falliti: 0

Spazio disponibile file di sistema: 92%

Uptime: 2011/6/17 10:43:17 (uptime: 7 days 17:46:09) (6999 8100160-0) WAV cache: 2

Numero di sessioni HTTP: Sessions: PAC=0, HTTP=1; Threads: SIP=0, HTTP=1

 

 

Where can I find the patch/upgrade?

Thank you

Link to comment
Share on other sites

Basically you need to link /usr/local/snomONE/snomONE-ctrl to the new executable

 

First, download the fix. Then copy it in the snom ONE root directory:

cp pbxctrl-centos5-2011-4.2.1.4018 /usr/local/snomONE/

 

Stop snom ONE:

/etc/init.d/snomONE stop

 

Make the fix executable:

chmod +x /usr/local/snomONE/pbxctrl-centos5-2011-4.2.1.4018

 

Link snomONE-ctrl to the new executable:

ln -fs /usr/local/snomONE/pbxctrl-centos5-2011-4.2.1.4018 /usr/local/snomONE/snomONE-ctrl

 

Start snom ONE:

/etc/init.d/snomONE start

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...