Jump to content

snom 320 - Call forward on no answer problem


Recommended Posts

Hi,

 

A customer of ours is using version 2011-4.2.1.4013 (Win64).

 

Now they wanted us to set call forwarding on no answer and when we put any number in this field incoming calls to the extension are not working at all any more.

 

Also on the extension's snom 320 display it says "Call forwarding" (or something similar, we use Swedish display language). When we remove the number from the Call forward on no answer field, the snom 320 display shows as normal again.

 

We have used original PnP parameters to configure the phones and only added some lines to get Swedish language etc.

 

Thanks and regards,

 

Jim

Link to post
Share on other sites

So when you set the CFNA from the web interface, does it work as expected?

 

The phones are using some CSTA stuff to set the parameters on the PBX. Maybe there is something buggy in the interface btw the phone and the PBX.

Link to post
Share on other sites

OK, I now tested to make the changes via the phone web interface and took a closer look at it.

 

It works as expected when we change in the web interface. Reason - we have chosen "Default value" as "Call forward no answer timeout:". We then expected snom ONE to take the value we have chosen for "Call forward no answer timeout:" for the Domain. But when we do this, the corresponding field in the phone is left empty. I wish it would be possible to set this at the domain level, it would save time.

 

So the solution now is to manually set the timeout time for each extension.

 

Another question regarding this:

The phone display now shows text "CFwd" instead of the usual extension number + user name. All users here find this wrong since they are used to see this text only when then have enabled direct call forwarding of all calls. Should it not be possible to get call forwarding after no answer timeout together with "normal" phone display text? I mean - many organizations do not want their customers to reach a voice mail box but rather let the calls go to a hunt group if a person do not answer.

 

Perhaps there is another solution and we can achieve this without enabling Call forward on no answer?

 

Regards,

 

Jim

Link to post
Share on other sites

I made a quick test here. From the phone, I could only set the call forward for all calls. Then when changing the call forward from the web interface of the PBX to call forward after timeout, the display on the phone flickers a little bit and still shows "CFwd: 45", which is not 100 % correct (because this is not call forward all, just call forward after timeout). The PBX sends:

 

<?xml version="1.0" encoding="UTF-8"?>
<ForwardingEvent 
xmlns="http://www.ecma-international.org/standards/ecma-323/csta/ed3">
<device>49@pbx.company.com</device>
<forwardingType>forwardNoAns</forwardingType>
<forwardStatus>true</forwardStatus>
<forwardTo>45</forwardTo>
<ringCount>2</ringCount>
</ForwardingEvent>

 

So it seems to me like the phone has a problem showing the exact forward type. It is probably just a hint that calls might be forwarded, without being specific about the event.

Link to post
Share on other sites

Please try it using "Default value" as "Call forward no answer timeout:". This is not working as expected for us.

 

Now when I read my previous post I see that we have two feature requests here:

 

  1. The ability to set default value for call forward no answer timeout at domain level (I think it is supposed to work but it does not)
  2. Ability to use Call forward on no answer for extension without changing idle screen of phone (in my opinion this is misleading)

 

Just a thought:

Why do you involve the phone in this setting in the first place? IMHO, this setting is purely a PBX thing. I mean, when you set call forward to mailbox after x seconds this does not show on the phone or does it?

Link to post
Share on other sites

Please try it using "Default value" as "Call forward no answer timeout:". This is not working as expected for us.

 

This looks like an issue on the PBX. PBX is not sending the proper ringCount value. We will double check the code and fix it it there is a real problem.

Link to post
Share on other sites

This looks like an issue on the PBX. PBX is not sending the proper ringCount value. We will double check the code and fix it it there is a real problem.

 

Thanks!

 

And what do you think about the other issue - phone displaying "CFwd" when call forwarding on no answer is configured? Why do you involve the phone in this, should this not be a pbx setting?

Link to post
Share on other sites

The ability to set default value for call forward no answer timeout at domain level (I think it is supposed to work but it does not)

The setting is already there, we will fix the bug.

Ability to use Call forward on no answer for extension without changing idle screen of phone (in my opinion this is misleading)

We always try to sync the phone with the latest information so that if someone looks at the phone screen they would know why the phone is not ringing as long as they are expecting them to ring. IMHO, this is useful.

Link to post
Share on other sites

We always try to sync the phone with the latest information so that if someone looks at the phone screen they would know why the phone is not ringing as long as they are expecting them to ring. IMHO, this is useful.

 

I see your point but disagree. The customers that have seen this all say "Please bring my old screen text back". We use Swedish language on the phones and the text shown is "Vidarekoppling". Maybe the amount of seconds is also displayed but we cannot see this on the snom 320 display. One gets the impression that Call forward unconditionally is set, the text is similar.

 

We have only begun to sell snom ONE (we were working with 3CX before) and I am afraid that this display issue will be something that the customers dislike. I myself find it annoying to say the least. So please consider our feature request to be able to set Call forward on no answer without changing the phone display.

 

Regards,

 

Jim

Link to post
Share on other sites

Maybe the solution is to change the translation to "Vid" or something like that very short!

 

Hello again,

 

Yes, a shorter word in the Swedish translation would at least make it possible to read. But why show this information at all? IMHO this has no value for the user, on the contrary it is misleading.

 

Users are used to see the call forwarding text only when they have enabled direct call forwarding of all calls. I have never seen a phone of any brand that displays the text "Call forwarding" when this is not the case.

 

OK - this far we have only feedback on this from one customer (five users) but as I wrote earlier, I am convinced that we will hear the same from every new customer that do not want to use voice mailboxes.

 

Thanks for looking into this and please take our request into consideration for future releases (for more sales and happy customers. :) ).

 

Jim

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...