Jump to content

Call Transfer when no call-through


stormwind81
 Share

Recommended Posts

Hi Snom,

 

 

A very important think is bothering me.

We got Snom One a Snom 870 and a M9 Station.

 

Now incoming calls are forwarded to the ext. 11.

But we want that callers can call the 012124123 - 11 to get to the ext. 11 or 012124123 - 12 to get to ext. 12

So i erase "Send call to extension:"

But now when people call "012124123" without a call-through, the call doesnt get somewhere.

How can i make the call gets to extension 11 when no other extensions are found ?

 

with regards

Chris

Link to comment
Share on other sites

Is "012124123" DID associated with extension 11? if not check this article.

 

http://wiki.snomone.com/index.php?title=Extension_Accounts/de#Creating_a_Few_New_Extensions

 

Once that's DID is associated with the extension check the link below.

 

Please check the wiki below.

 

http://wiki.snomone.com/index.php?title=Inbounds_Calls#How_the_System_Routes_a_Call_to_the_Proper_Extension

Link to comment
Share on other sites

Is "012124123" DID associated with extension 11? if not check this article.

 

http://wiki.snomone.com/index.php?title=Extension_Accounts/de#Creating_a_Few_New_Extensions

 

Once that's DID is associated with the extension check the link below.

 

Please check the wiki below.

 

http://wiki.snomone.com/index.php?title=Inbounds_Calls#How_the_System_Routes_a_Call_to_the_Proper_Extension

 

Hallo,

 

Thx for the reply. I have read The wiki article before i postet here but i dont understand it. I do not understand what a DID Number is and how to check if the extension is asssociated with it.

 

What do i need to do to reach the 2 extensions with the call-trough number and when dialing the zero i get transfered to extension 12?

 

Do i write in the "send calls to" !([0-9]{2}$)!12! ????

 

And in the Account number i write: "11 04121234511" or "12 04121234512" ????

 

Am i right?

 

Hmm ive tried now serveral minutes and stil cant get any solution that works.

if i dial 4121234511 it works, but if i dial only 41212345 i get no connection.

Also if i try the 412123450 is wrosk. But not with only 41212345, so i tihnk somehow the dafeult to funktion doesnt

work. why?

 

with regards

Link to comment
Share on other sites

The following expression in "send calls to extension" field sends the calls to based on the last 2 digits of the number in the "To" field of the INVITE messages. If there is no match it will send the call to account 100 (this account can be an AA/IVR/etc)

 

!([0-9]{2}$)!\1!t!100!

 

Or

 

You may want to strip the main number of the PBX and use the remaining digits to identify the extension. If the extension is not found, you send it to the auto attendant. This example assumes that the number starts with 7 digits (e.g. 0228123) and that the auto attendant is located at 100: "![0-9]{7}([0-9]*)!\1!t!100"

 

See which one suites your need (FYI, these examples do not require you to have DID assigned to the extensions, but there is no harm if you do it).

Link to comment
Share on other sites

The following expression in "send calls to extension" field sends the calls to based on the last 2 digits of the number in the "To" field of the INVITE messages. If there is no match it will send the call to account 100 (this account can be an AA/IVR/etc)

 

!([0-9]{2}$)!\1!t!100!

 

Or

 

You may want to strip the main number of the PBX and use the remaining digits to identify the extension. If the extension is not found, you send it to the auto attendant. This example assumes that the number starts with 7 digits (e.g. 0228123) and that the auto attendant is located at 100: "![0-9]{7}([0-9]*)!\1!t!100"

 

See which one suites your need (FYI, these examples do not require you to have DID assigned to the extensions, but there is no harm if you do it).

 

Hallo,

 

!([0-9]{2}$)!\1!t!100!

doesnt work for me. I still cant call my normal number without a call-through. The 11 and 12 works.

Im getting a little bit confusing.

 

I tried the second command. Neither let me call my number 04212345.

The Number is 9 digits long.

When i call with call-through its 11 digits.

my default extension when no DID is found should be 12. but it doenst work they way its explained in wiki.

 

The Log Files says:

 

Domain trunk Patton Gateway@pbx.company.com could not identify user for anonymous

Link to comment
Share on other sites

Can you try !([0-9]{2}$)!\1!u!100! instead of !([0-9]{2}$)!\1!t!100! ?

 

Hi,

I had no other choice to configure the Patton to redirect the headnumber to an Attendant. Cant test now if the new post will work. However the commands before havent worked. I tried over 20 different ways.

Also the snom wiki in some places says to write the command without an ! and in some places it begins with !. Maybe you should fix that soon.

 

I lt u know if i have the time to change the patton config and test your new post with !u!.

Link to comment
Share on other sites

Hi,

I had no other choice to configure the Patton to redirect the headnumber to an Attendant. Cant test now if the new post will work. However the commands before havent worked. I tried over 20 different ways.

Which version of the PBX software are you using? I am surprised that you are having trouble having a working pattern. Since the pattern matching strictly works on the number that is received in the INVITE (either request-uri or the to field), it is worth checking what is coming in to the PBX. Other factor that would influence the pattern matching is the country code and the area code under the domain settings.

 

Also the snom wiki in some places says to write the command without an ! and in some places it begins with !. Maybe you should fix that soon.

Always start with !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...