Jump to content

Calling card setup issue


Kelly Martin
 Share

Recommended Posts

Hi there

 

I am setting up a Calling Card on our Snom One server. I am wanting to call into the PBX server and activate a service flag in this case ext 543. I have never used this feature before and this is what I have done:

 

- Set up a calling card ext 400.

- Have set up a service DDI# pointing to the calling card ext.

- Created a service flag 543. Set to manual.

- Pointed the DDI# to the calling card ext.

 

Called the DDI# and it asks for the ext#, then access code please enter the destination number terminated by the # key.

 

When I put in the destination number and terminate it with the # key I get the following message.

 

"We are sorry. But you are not allowed to make this call"

 

I think I missed something but don't know what. Tried another test trunk and same results.

Deleted calling card and then set it back up again with the same results.

Works fine internally. When done externally. No go.

 

Any suggestions would be appreciated.

 

Snom One Ver:

 

Version: 4.3.0.5002 (Win64)

 

 

 

Thanks

 

Kelly

Link to comment
Share on other sites

Also, just to add a note to Kelly's config below the service flag has a wild card for "Extensions that may change status" And the calling card is allowed to "Allow calling accounts on the PBX" And it still does not work externally.

 

Hi there

 

I am setting up a Calling Card on our Snom One server. I am wanting to call into the PBX server and activate a service flag in this case ext 543. I have never used this feature before and this is what I have done:

 

- Set up a calling card ext 400.

- Have set up a service DDI# pointing to the calling card ext.

- Created a service flag 543. Set to manual.

- Pointed the DDI# to the calling card ext.

 

Called the DDI# and it asks for the ext#, then access code please enter the destination number terminated by the # key.

 

When I put in the destination number and terminate it with the # key I get the following message.

 

"We are sorry. But you are not allowed to make this call"

 

I think I missed something but don't know what. Tried another test trunk and same results.

Deleted calling card and then set it back up again with the same results.

Works fine internally. When done externally. No go.

 

Any suggestions would be appreciated.

 

Snom One Ver:

 

Version: 4.3.0.5002 (Win64)

 

 

 

Thanks

 

Kelly

Link to comment
Share on other sites

Is you dial plan set up? Are you able to make outbound calls? Make sure that the rate table is set in the trunk section and add some virtual money in the registration extension section it will say "Credit for outbound calls:" Make sure these fields are populated.

 

 

Check the manual for some more direction.

http://downloads.snom.net/snomONE/docs/snomONE_online_book.pdf

 

Chapter 15 Page 284

Link to comment
Share on other sites

You can call into the system and dial the service flag account or append a DID, only if it's set to manual mode then you can activate and deactivate that way. If it's set to "Day/night mode you cannot change the status since it's in auto mode. You have to also set up "Extensions that may change status" this is only used on manual mode.

Link to comment
Share on other sites

What I did to get this to work which is similiar to a calling card was I called into the main AA from my cell phone and the Personal Virtual Assistant kicked in since it recongnized my cell phone and the PVA is turned on in the domain settings. I then pressed 4 to get to the AA and then dialed the manual service flag number and it worked (heard the confirmation tone) since my extension that the cell phone is bound to has this permission. Would that do the trick?

Link to comment
Share on other sites

What I did to get this to work which is similiar to a calling card was I called into the main AA from my cell phone and the Personal Virtual Assistant kicked in since it recongnized my cell phone and the PVA is turned on in the domain settings. I then pressed 4 to get to the AA and then dialed the manual service flag number and it worked (heard the confirmation tone) since my extension that the cell phone is bound to has this permission. Would that do the trick?

 

Sounds good, but it will not work for what we need. We need to be able to call in from any phone, any number, anywhere in the world to turn service flags off and on. So using PVA will limit how we could use this.

Link to comment
Share on other sites

Did you ever try turning "Allow calling accounts on the PBX" on? A service flag is nothing than a account on the PBX...

 

Yes, as I motioned above I have. I can call in, enter my ext number and password, ring external numbers and internal numbers. just NOT service flags. It say I am not allowed to make this call. I have put wild cards in the service flags, I have manually put the ext numbers of the users allowed to change the status.. nothing. Works fine internally, just not via the calling card.

 

We know calling card works as I (our customer) can call any thing once they call in.

We know the service flags work and they can be set internally.

 

So something is not right.

Link to comment
Share on other sites

The problem is that only extensions are allowed to change the state of the service flag. It is not a problem with the calling card, this is a problem with the service flag. You can verify this by calling the calling card account from an extension and then change the service flag.

 

I believe the only way to overcome is to allow a magic symbol "*" or even better "**" to allow that everyone is allowed to change the state.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...