Jump to content

Auto provisioning with Polycom


YMSL
 Share

Recommended Posts

I am trying to auto provision Polycom IP6000 with all proper settings

 

Mac ID OK

PNP OK

Network OK

 

Polycom auto provisioning is orking fine internally as long as SIP IP Replacement List and IP Routing List are empty.

 

In this situation, devices on the other side of NAT (outside of the local domain) are not providing audio.

To get device working fine outside internal network, SIP IP Replacement List and IP Routing List need to be set.

 

In that case, Polycom auto provisioning is not longer working...

 

 

It look like it is one or the other...

 

what am I missing?

 

SIP IP Replacement List: 10.0.1.200/24.202.225.XXX

IP Routing List: 10.0.1.1/255.255.255.0/10.0.1.200/0.0.0.0/0.0.0.0/24.202.225.XXX

 

PBXnSIP Version: 4.3.0.5021 (FreeBSD) - error here, it is running on OSX machine and it say's FreeBSD...

 

If SNOM can trade my polycom IP6000 (just received and NEW) for a MeetingPoint. I am more then willing to trade it :-)

 

 

Many thanks for your help

Link to comment
Share on other sites

I don't think snom ever added the PnP support for IP6000.

 

Regarding the "freeBSD" on the Mac OS build, that can be ignored. It was just a wrong text. It will not impact the functionality.

 

 

Many thanks for your reply,

 

PBXnSIP, now SNOM, did make the PnP for Polycom. Keven Moros even recommend Polycome for conference phone. That before PNXnSIP was acquired by SNOM.

PNP are available but their is certainly a bug their.

 

the licence we are using is (C:\Program Files\pbxnsip\PBX)

 

Please advise.

 

 

 

In regards of FreeBSD... I am very sorry, but it look something like no details to the little elements are in place. To me it look like if this is their, who know what at other places that we do not know... Sorry to be so attentive to details.

 

Many thanks again

Link to comment
Share on other sites

Many thanks for your reply,

 

PBXnSIP, now SNOM, did make the PnP for Polycom. Keven Moros even recommend Polycome for conference phone. That before PNXnSIP was acquired by SNOM.

PNP are available but their is certainly a bug their.

 

the licence we are using is (C:\Program Files\pbxnsip\PBX)

 

Please advise.

 

 

 

In regards of FreeBSD... I am very sorry, but it look something like no details to the little elements are in place. To me it look like if this is their, who know what at other places that we do not know... Sorry to be so attentive to details.

 

Many thanks again

post-2011-0-95914500-1323737529_thumb.png

Link to comment
Share on other sites

Probably you did not understand the post. The PnP is per phone model (not per phone vendor). We did PnP with some older Polycom phones only. If the newer Polycom's use the same mechanism, they might work too. If you know Polycom boot up process completely, then you can make it work by customizing the pnp.xml and couple of polycom config files under "Web Page Control".

 

I remember Mr. Nate Stuyvesant (not sure that was his forum name) was a Polycom expert.

 

On the other hand, you can still manually register any SIP phones with the PBX.

Link to comment
Share on other sites

  • 8 months later...

Im running into this same issue

 

Just to confirm - There is no PnP support for the Polycom sound point IP 6000? Even with the pbxnsip license?

 

I have programmed the 6000 with the SIP credentials and its still looking for the BootROM for the 6000.

 

In my pcap the phone requests "3111-15600-001.bootrom.ld" (which IS located in /usr/local/snomONE/tftp)

Server kicks back a '302 File moved temporarly"

Then the phone asks for 'login.htm' over and over again, getting the same 302 error form the server (During which the phones display is stuck on "Updating initial configuration").

 

If there is no PnP support, does anyone know where to find instructions for configuring this phone manually to connect? I thought the SIP server, un, and passwd were enough. Evidentially not.

 

Thanks

 

Sudo

 

PS - are there any other Polycom conference phones that are supported?

Link to comment
Share on other sites

Hmm. When the HTTP protocol is used, the PBX web server looks at the user-agent type in the request if there is no session established--if it is something "well known" it looks for files in the tftp directory (and PnP files). It seems like the IP 6000 sends something different from the other Polycom phones.

Workaround is to use TFTP, where this mechanism is not neccessary and all phones are grabbed out of the tftp folder. Otherwise if you can tell us what HTTP request the phone sends, we can check if we can change/add that in the default configuration.

Link to comment
Share on other sites

The HTTP request is as follows:

 

GET /3111-15600-001.bootrom.ld HTTP/1.1\\r\n

HOST: pbx.domain.com\r\n

Accept: */*\r\n

User-Agent: FileTransport PolycomSoundStationIP-SSIP_6000-UA/4.2.1.0275\r\n

\r\n

[Full request URI: http://pbx.domain.com/3111-15600-001.bootrom.ld]

 

 

Had a thought that it may be because I have an earlier firmware version that the phone did not like. So I downloaded 3111-15600-001.bootrom.ld ver 4.0.1 and replaced it in the /tftp directory, but no dice. Still sending the same requests...not getting anywhere.

 

Thanks

Link to comment
Share on other sites

Bingo. Check out your pnp.xml file from the web interface and add a line that matches the PolycomSoundStationIP string (it is PolycomSoundPointIP there). We'll also change it in the code, so that future version will have this fix automatically.

 

 

Awesome this worked - Except for one thing (Story of my life)

 

The phone loaded the bootrom and registers with the pbx, but it boots up with the following error:

 

"http://IP.ADD.OF.PBX:80/prov/poly..." (The small display screen does not show the full url nor give me the option of scrolling over)

 

Looking at a pcap I see the phone requesting a 'prov/polycom_phone.cfg' and a 'prov/polycom_sip.cfg', but both of these requests are met with a 'Continuation or non HTTP Traffic" which tells me that the server is responding to the request with the needed file(s).

 

The phone is registered and I can call out/in and internal extensions, but there is a "Caution" Icon in the top right of the display (a triangle with an ! inside.)

 

I greatly appreciate your previous advice! Any suggestions with this error I'm getting?

 

Sudo

Link to comment
Share on other sites

Back to the php.xml template. I have modified the one line as follows:

 

<http>

<ua vendor="Polycom">Polycom-FileManager/.*</ua>

<ua vendor="Polycom">FileTransport PolycomSoundStationIP-.*</ua>

<ua vendor="snom">snom-m3-SIP/.*</ua>

</http>

 

Now I need to get it to work for both models (SoundStation IP6000 and SoundPoint IP331). I have tried adding an additional line as you suggested:

 

<http>

<ua vendor="Polycom">Polycom-FileManager/.*</ua>

<ua vendor="Polycom">FileTransport PolycomSoundStationIP-.*</ua>

<ua vendor="Polycom">FileTransport PolycomSoundPointIP-.*</ua>

<ua vendor="snom">snom-m3-SIP/.*</ua>

</http>

 

BUT - The system did not let me save the change. Its weird actually. It created a blank 'template' with no name and no content - Keeping the original php.xml without the new line.

 

How do we make the change stick, and is there any documentation or dll.xml so we can know what is allowed by the system?

 

Thanks again

 

Sudo

Link to comment
Share on other sites

You need to cd to the working directory of the PBX. If you are not sure, you can search the PBX process with ps -C pbxctrl or ps auxww|grep pbxctrl, then you will see in the argument what the working directory is (or cd /proc/<pid>/cwd). Then in that directory you'll either already have a html directory or you make it with mkdir html. Then cd html, and there you have to copy the pnp.xml file, e.g. cat >pnp.xml (then copy & paste the pbx.xml from the web interface into the terminal window and press ctrl-D). After this, you need to restart the PBX as it does not re-read the file system every time that it provisons a phone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...