Jump to content

Beta Corona Austrinids... outbound call problem


Porter
 Share

Recommended Posts

Hi everyone!

 

I have been running 4.3.0.5020 with excellent results but recently received a new Snom 760 to add to our system and noticed that PnP is not supported on these new 7xx models until v4.5.

 

Upgrade to 4.5.0.1030 goes smoothly (Debian version) and the system works without problems for both internal calling and inbound calls, but outbound calling results in an error 400 (Bad Request).

 

I took a brief look at the logs, it seems that the SIP invite being sent is different.

 

On 4.3 it is in the form <sip:[destination]@[trunk-ip];user=phone> on trunk [trunkname]

On 4.5 it is in the form <sip:[destination]@[pbx-servername];user=phone> on trunk [trunkname]

 

I neglected to get a proper copy of the log since I reverted to 4.3 quickly, but that was the primary difference that I noticed. I can get more detailed logs if needed, of course... but I wondered if anyone here knows what may have changed in the 4.5 builds to cause this difference? Is the default dial plan behavior different, in a way that needs to be accounted for?

 

Up to this point we have been passing everything out to the trunk since it's a very simple configuration, the dial plan on 4.3 is just a * but has been working fine, internal calls have been handled by the default logic and outbound called-number parsing handled by our provider. The trunks themselves seem to work fine, since we get inbound calls without issue, it seems at first glance to be a difference in the outbound invite syntax.

 

Any help or suggestions would be greatly appreciated, I'm hoping that someone here might have run into this already and discovered the solution.

 

Thanks!

 

Jason Porter

Link to comment
Share on other sites

Hi everyone!

 

I have been running 4.3.0.5020 with excellent results but recently received a new Snom 760 to add to our system and noticed that PnP is not supported on these new 7xx models until v4.5.

 

Upgrade to 4.5.0.1030 goes smoothly (Debian version) and the system works without problems for both internal calling and inbound calls, but outbound calling results in an error 400 (Bad Request).

 

I took a brief look at the logs, it seems that the SIP invite being sent is different.

 

On 4.3 it is in the form <sip:[destination]@[trunk-ip];user=phone> on trunk [trunkname]

On 4.5 it is in the form <sip:[destination]@[pbx-servername];user=phone> on trunk [trunkname]

 

I neglected to get a proper copy of the log since I reverted to 4.3 quickly, but that was the primary difference that I noticed. I can get more detailed logs if needed, of course... but I wondered if anyone here knows what may have changed in the 4.5 builds to cause this difference? Is the default dial plan behavior different, in a way that needs to be accounted for?

 

Up to this point we have been passing everything out to the trunk since it's a very simple configuration, the dial plan on 4.3 is just a * but has been working fine, internal calls have been handled by the default logic and outbound called-number parsing handled by our provider. The trunks themselves seem to work fine, since we get inbound calls without issue, it seems at first glance to be a difference in the outbound invite syntax.

 

Any help or suggestions would be greatly appreciated, I'm hoping that someone here might have run into this already and discovered the solution.

 

Thanks!

 

Jason Porter

 

 

On the Trunk choose custom headers.

Link to comment
Share on other sites

Yes, use the custom headers.

I am assuming you are talking about the "To" or the "Request URI" header.

 

You can use something like under "Trunk->Remote Party/Privacy Indication: Custom Header: To: Other" <sip:{to-user}@{trunk-host};user=phone>

 

http://wiki.snomone.com/index.php?title=Trunk_Custom_Headers page explains different possibilities with some example data to guide you.

Link to comment
Share on other sites

Yes, use the custom headers.

I am assuming you are talking about the "To" or the "Request URI" header.

 

You can use something like under "Trunk->Remote Party/Privacy Indication: Custom Header: To: Other" <sip:{to-user}@{trunk-host};user=phone>

 

http://wiki.snomone.com/index.php?title=Trunk_Custom_Headers page explains different possibilities with some example data to guide you.

 

Great, thanks for your help. Do you think it's the header syntax being different that is likely the culprit, or is there some other change in 4.5 that may have caused the problem? I'm hoping I'm not the first to have run into this.

Link to comment
Share on other sites

You not the only one :( .

 

So far it was very difficult to inter-work with the slew of SIP trunk providers out there (everyone had their own interpretation of SIP headers).

So, in v4.5, we tried to make the trunk headers as flexible as possible to take care of this issue. But unfortunately everything may not be 100% backward compatible.

Link to comment
Share on other sites

You not the only one :( .

 

So far it was very difficult to inter-work with the slew of SIP trunk providers out there (everyone had their own interpretation of SIP headers).

So, in v4.5, we tried to make the trunk headers as flexible as possible to take care of this issue. But unfortunately everything may not be 100% backward compatible.

It would have been nice to leave the standard non custom headers the same as it was in earlier versions, as most of us never needed to do any custom settings. The custom is very nice however more complicated if you have a standard config.

Link to comment
Share on other sites

You not the only one :( .

 

So far it was very difficult to inter-work with the slew of SIP trunk providers out there (everyone had their own interpretation of SIP headers).

So, in v4.5, we tried to make the trunk headers as flexible as possible to take care of this issue. But unfortunately everything may not be 100% backward compatible.

That's great info, thanks for your help!

 

I can noodle through it myself of course, but for the benefit of the community would it be possible for Snom to provide a suggested Custom Header syntax that mimics the previous "default" header behavior? I can imagine that it would be helpful to many people who may experience breakage when attempting to upgrade.

 

Thanks again!

Link to comment
Share on other sites

That's great info, thanks for your help!

 

I can noodle through it myself of course, but for the benefit of the community would it be possible for Snom to provide a suggested Custom Header syntax that mimics the previous "default" header behavior? I can imagine that it would be helpful to many people who may experience breakage when attempting to upgrade.

 

Thanks again!

I have the same problem and i lost 2 hours finding the right header for OVH , it's true that a previous "default" header behavior would be usefull for the people who upgrade 4.3 to 4.5

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...