Jump to content

Beta Corona Austrinids - Outgoing Caller ID lost?


Jack Russell Racing
 Share

Recommended Posts

The outbound trunk calls needs to be checked again after the upgrade. We did some changes to the trunk headers to make it more flexible. But the flexibility costed these type of issues.

 

http://wiki.snomone.com/index.php?title=Trunk_Custom_Headers has some details regarding that. The easiest way to fix the caller-id issue is to see what was being sent on the outbound INVITE before the upgrade and then match it accordingly on the new version.

Link to comment
Share on other sites

We ran into the same issue. Actually after the upgrade we couldn't make outgoing calls at all. After about 20 mins of playing with it we figured it out. We're using custom headers, which is a pretty cool feature because it allows you to set the caller-id to whatever want. The settings will need to be modified to match your SIP provider's requirements - since we are our own sip provider it was pretty easy. The problem more than likely lies in the Remote-Party-ID: portion. We set ours to "Based on incoming call" that way when a call comes in and the system reroutes it to a cell phone, we get the caller id of the incoming call rather than our office number. That way you can determine if you want to accept the call or not... uh I mean if you don't answer it in time, you can call them back :D.

 

Hope that helps!

Brian

Link to comment
Share on other sites

We ran into the same issue. Actually after the upgrade we couldn't make outgoing calls at all. After about 20 mins of playing with it we figured it out. We're using custom headers, which is a pretty cool feature because it allows you to set the caller-id to whatever want. The settings will need to be modified to match your SIP provider's requirements - since we are our own sip provider it was pretty easy. The problem more than likely lies in the Remote-Party-ID: portion. We set ours to "Based on incoming call" that way when a call comes in and the system reroutes it to a cell phone, we get the caller id of the incoming call rather than our office number. That way you can determine if you want to accept the call or not... uh I mean if you don't answer it in time, you can call them back :D.

 

Hope that helps!

Brian

 

 

Uggg... I've tried a bunch of different variations, but cannot seem to find the magic bullet. Our incoming caller ID's are fine.... it is simply out going ID that shows on destination (people we're calling out to) as "Unkown". We're on Vonage, if that might help anyone point us in the proper direction.

Link to comment
Share on other sites

A follow-up post, with a big THANK YOU to "pbx support" here...

 

Using Vonage as a SIP provider, the settings that worked are (in Trunks->Number/Call Identification):

 

Prefix: empty

Trunk ANI: xxxxxxxxxxx (where xxxxxx is our 10-digit Vonage telephone number)

Remote Party/Privacy Indication: Custom Headers

Request-URI: Let the system decide

From: Based on incoming call

To: Let the system decide

P-Asserted-Identity: Other "xxxxxxxxxxx" <sip:xxxxxxxxxxx@{trunk-registrar}> (where xxxxxxx is our 10 digit Vonage number)

P-Preferred-Identity: Don't use header

Remote-Part-ID: Don't use header

P-Charging-Vector: Don't use header

Privacy Indication: Don't use header

 

:) All works great now.

Link to comment
Share on other sites

  • 1 month later...

A follow-up post, with a big THANK YOU to "pbx support" here...

 

Using Vonage as a SIP provider, the settings that worked are (in Trunks->Number/Call Identification):

 

Prefix: empty

Trunk ANI: xxxxxxxxxxx (where xxxxxx is our 10-digit Vonage telephone number)

Remote Party/Privacy Indication: Custom Headers

Request-URI: Let the system decide

From: Based on incoming call

To: Let the system decide

P-Asserted-Identity: Other "xxxxxxxxxxx" <sip:xxxxxxxxxxx@{trunk-registrar}> (where xxxxxxx is our 10 digit Vonage number)

P-Preferred-Identity: Don't use header

Remote-Part-ID: Don't use header

P-Charging-Vector: Don't use header

Privacy Indication: Don't use header

 

:) All works great now.

 

Hey, thanks for the tip!

I started to go mad after the update i did yesterday, but with these tweaks I also managed to get it to work with a local Hungarian voip trunk provider. :)

 

Regards,

 

Bela

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...