Jump to content

Sangoma FXO problem


Dunwood
 Share

Recommended Posts

I am just going through the process of setting up a new SnomONE and it seems to be working OK with SIP trunks. When I use the analogue phone line however (Sangoma A200 with an FXO module) things go a bit wrong. For the first 15-30 seconds (it varies from call to call) the remote party can't hear anything. the Local party can hear just fine, every single "Hello?", and "Are you there?" that comes from the other end is crystal clear.

 

I have spoken with Sangoma about this issue and having looked at logs and configs they say everything is fine at their end at that the fault must be with the SnomONE software.

 

Any idea how I can fix this?

Link to comment
Share on other sites

Can you navigate to the trunk section and set the "Ringback(Support early media)" set to Message 180 rather then media also I belive sangoma has a setting for this as well.

That seems to have fixed it for outgoing calls, will I need to change to config in NetBorder for it to fix the incoming calls? Is that how this works or is the fixed outgoing just a coincidence?

 

I don't suppose you know what the Sangoma setting is do you? You are a little faster than them on support queries :)

Link to comment
Share on other sites

Can you navigate to the trunk section and set the "Ringback(Support early media)" set to Message 180 rather then media also I belive sangoma has a setting for this as well.

I have just had the following reply from Sangoma...

The 180's will only get you around not hearing ringing. When one side sends a 180 it means "generate ringing NOW until I tell you otherwise". So you would hear ringing since SNOM is generating it locally, but once the call is connected then you will be back at the issue you have now with no media. So this is not a good idea to apply this as it will not resolve the issue.

 

At this point here you will need to contact SNOM to look into this and have a look over everything. You can do a wireshark on Windows but since Microsoft has hidden their loop back interface from wireshark you have to do a trick to get working. Needless to say the trick doesn't always work so well and isn't the best idea unless required. So please talk with SNOM and they will help you debug this further on their end. If they have any questions for us let us know and we'll go from there.

 

Your Support Team

Is there anything else you can suggest?

Link to comment
Share on other sites

  • 1 month later...

Chances are its NAT related and its taking longer then normal to set up the RTP as one side is using the loopback interface the other is been sent to the NIC

 

In the snom ONE Web interface, click on Admin -> Server Console -> Sangoma -> NetBorder Express Gateway -> Configuration -> Advanced -> look for the "netborder.net.primaryIPAddress" parameter.

- change it to 127.0.0.1

 

After this change click on "Apply" and then on "Status and Controls" -> "Restart Gateway"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...