Jump to content

lower pbxnsip registration timeout value to remote gateway


clarity
 Share

Recommended Posts

I see that you have the very cool keepalive feature... however the re-register interval is set at 1 hour and I've not found were to lower that.

I need the far end to realize that registration is lost pretty quickly if the network goes down at the client side.

As is now the remote system thinks I'm still there and I have to rely on the timers for the next route decision (at far end not pbxnsip) to occur...

 

If I can lower that timer to 2 minutes instead of an hour, this will satisfy our requirement on that matter.

 

Thanks!!!

 

Steve

Link to comment
Share on other sites

In the admin settings for the PBX, there are four settings: "Minimum Registration Time", "Maximum Registration Time", "UDP NAT Refresh", "TCP/TLS NAT Refresh" (see also http://wiki.pbxnsip.com/index.php/Overall_...gs#Performance). You can lower the Maximum Registration Time, IMHO it is no problem to choose duration of one minute. The CPU load generated by a few hundered extensions refreshing their registration every minute is no problem.

Link to comment
Share on other sites

In the admin settings for the PBX, there are four settings: "Minimum Registration Time", "Maximum Registration Time", "UDP NAT Refresh", "TCP/TLS NAT Refresh" (see also http://wiki.pbxnsip.com/index.php/Overall_...gs#Performance). You can lower the Maximum Registration Time, IMHO it is no problem to choose duration of one minute. The CPU load generated by a few hundered extensions refreshing their registration every minute is no problem.

 

Thanks, gave that a try also tried some of that before posting here :-)

 

Also have a ticket open on this but will post here as well for sharing.

---------------

I have tweaked the min and max registration times.

 

Also this problem is pertaining to how often I'd like a sip trunk to re-register and

not phones (just to make sure I'm clear in what we are dealing with.

I realize some/all the settings may interract

 

It looks like this may have caused a re-register or keepalive change, however our

softswitch is still somehow seeing the registration interval as 3600 seconds and not

120.

 

When I say this I mean my switch sees and stores 3600 seconds as how long it expects a registration to live...

The settings you mento do seem to cause the registration process to follow... I'm seeing registrations every two minutes now

but I do not see the registration TTL (time to live) reflecting that increase.

If I change registration interval on a typical phone that is registered to our system I see the TTL value as seen/displayed on our switch

change along with it.

 

With pbxnsip it stays set to 3600 regardless of how often pbxnsip is re-registering with us.

 

 

I don't know if that is due to an initial negotiation of 3600 and then in changes on

the backend (pbxnsip) to re-register at minregistration time.... or what...

 

But my softswitch still displays that you are set for a TTL at 3600 seconds...

 

On a typical SIP phone if I register with our switch...

that field gets updated on our switch to match...

with pbxnsip registering..... it has not changed from 3600

seconds no matter what I have tried in settings.

 

I have presented this problem to our switch vendor as well just incase it some some

type of interrop issue.

 

Bottom line of what I need is for our switch to expect re-registration every 120

seconds so that if the pbx disappears and goes off internet we will be aware of it

right away and not have to wait an hour...

 

I am using very short call timers for route advance to get

around this for now but its a dirty solution and causes

10 seconds of extra delay before the route advances....

 

If I see the registration as bad, it will advance right away.

 

Thanks!

 

Steve

 

 

:::::Note to switch vendor.

PBX is claiming they are re-registering every 120 seconds persettings but our switch is showing a TTL of 3600

I see Last update field updating every 2 minutes as expected however TTl: stays at

3600

 

Problem is if they disappear... switch still thinks they are there due to that

TTL:3600

 

I'm expecting/desiring that to timeout quickly (120) so that switch quickly route advances if that

gateway is not available.

 

If that internet connection goes down, we still try them as if they were registered.

 

What do I need to do (or get the pbx to do so that this TTL shows up as the

lower value that they are actually re-registering at?

 

Steve

Link to comment
Share on other sites

I think what we are really after here is a means to set the sip expiry value to 120 instead of 3600....

 

In most endpoints/phones that I work with when I set the re-registration period this is also set simultaneously on that device...

 

I need to get pbxnsip to do this... I need to be able to set the expiry to less than 3600 (120 or 60 in this case).

 

Updating ticket with actual sip header info:

 

Steve

Link to comment
Share on other sites

Also this problem is pertaining to how often I'd like a sip trunk to re-register and

not phones (just to make sure I'm clear in what we are dealing with.

 

There is a setting "Keepalive Time" in the trunk. If you set that to 120 seconds, the PBX will ignore the time sent from the switch and reregister after the value that you set there.

 

What the trunk is proposing as keep-alive time can always be overwritten by the switch. Some switches send one hour and keep the connection alive by sending keep-alive packets. That mechanism is not very stable - many firewalls do not treat traffic coming from the outside as keep-alive traffic.

Link to comment
Share on other sites

What the trunk is proposing as keep-alive time can always be overwritten by the switch.

 

Not very easily in this case... the switch is expecting that I will send it the ttl expire value that I want in the registration requests.

Every other sip endpoint I have used allows me to change this.

And I've not had a problem setting it one any other equipment yet.

 

Is there some way I can change this in pbxnsip a config file maybe?

 

Thanks!

Steve

Link to comment
Share on other sites

Is there some way I can change this in pbxnsip a config file maybe?

 

Well, there is no need to do that... If the PBX proposes 3600 seconds, the switch accepts that and then the PBX re-registers after 60 seconds (and again proposes 3600 seconds), the switch will accept the new registration as well and everything is fine! That is quite common practice... At least so far there was never a need to have a setting for the proposed expiry!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...