Jump to content
Vodia PBX forum
Smuu

Ein-/Aus-Schalter mit falschen Feedback

Recommended Posts

Ich habe für das de-/aktivieren einer Rufweiterleitung zum Handy auf der snomONE extra jedem Mitarbeiter einen Ein-/Aus-Schalter "spendiert".

Als Rückmeldung habe ich "Service aktiviert/deaktiviert abspielen" ausgewählt.

Leider sind die Ansagen vertauscht. Wenn der Service aktiviert wurde sagt mir die Lautsprecherstimme "Dienst deaktiviert" beim deaktivieren ist es genau umgekehrt.

Die Rückmeldung per Gong habe ich auch ausprobiert und auch wenn es da weniger eindeutig ist, habe ich trotzdem das Gefühl, die Töne gehören anders herum zugeordnet.

Wo kann man diese Einstellung umdrehen? Also wo genau ist hinterlegt, bei welcher Funktion welcher Sound abgespielt wird?

 

Nur der Vollständigkeit halber: Version: 2011-4.3.0.5021 (Linux)

Share this post


Link to post
Share on other sites

Es ist in der Tat verwirrend. "Ein" bedeutet dass die Umleitung "ein"geschaltet wurde.

 

Wen es stört, kann auf jeden Fall die Files tauschen.

Share this post


Link to post
Share on other sites

Danke für die Zustimmung.

Ich hätte mich allerdings noch mehr gefreut über einen Hinweis, wo genau die Soundfiles eingebunden sind. Also welche Stelle ich bearbeiten muss, um das System meinen Wünschen entsprechend zu gestalten.

Share this post


Link to post
Share on other sites

Die in Frage kommenden Files sind audio_moh/bi_gong1.wav, audio_moh/bi_gong2.wav, audio_xx/bi_night_on.wav, audio_xx/bi_night_off.wav, audio_xx/bi_active.wav und audio_xx/bi_inactive.wav.

Share this post


Link to post
Share on other sites

Vielen Dank *bow*

 

Hab die Dateien bi_active.wav und bi_inactive.wav einfach ineinander umbenannt und jetzt passt alles.

Super! *thumbs up*

Share this post


Link to post
Share on other sites

Habe gerade festgestellt, dass das eigentliche Problem eine Stufe tiefer liegt.

Ich habe den Schalter gerade deaktiviert und auch getestet, ob der Zustand stimmt.

Dann habe ich mir die Kontenübersicht auf der snomONE angesehen und festgestellt, das der Schalter trotzdem auf "Set" steht.

Wenn ich nun aber die Detailansicht des Schalters auswähle steht dort unter Aktueller Zustand: Gelöscht

Hier scheint es eine Miskrepanz zwischen dem tatsächlichen Schalterzustand und der Interpretation durch die Anlage zu geben, was dann wohl auch zur Auswahl des falschen Soundfiles geführt hat.

 

Könnt ihr dazu einen Kommentar abgeben?

Share this post


Link to post
Share on other sites

Hmm. Klingt für mich eher nach einem Problem mit dem Webinterface. Ich würde ich da erst mal auf das Filesystem verlassen, im XML-text steht der Zustand von dem die PBX intern ausgeht (srvflags Verzeichnis).

Share this post


Link to post
Share on other sites

Das xml-File lügt!! :lol:

Nein, ernsthaft, im xml-File steht folgendes:

<?xml version="1.0" encoding="utf-8"?>
<row><allow_ext>*</allow_ext><display>Florian Umleitung</display><mode>manual</mode><sound>service</sound><state>false</state></row>

Aber der Anruf wurde gerade eben an mein Handy weitergeleitet.

Genau dafür ist der Schalter da.

Wenn im File statt dessen true steht, dann findet keine Weiterleitung statt.

Ein (also true) heißt also nicht (wie ich ursprünglich vermutet habe) die Weiterleitung ist EIN-geschaltet sondern mit dem setzen des Schalters wird die Weiterleitung AUS-geschaltet.

Die Logik kann ich akzeptieren, aber die Soundfiles passen dann eben nicht.

Share this post


Link to post
Share on other sites

Wie man jetzt true und false übersetzt kann man debattieren... WIchtig ist halt dass im XML File der richtige Zustand ist. Wenn das Webinterface den Wert manchmal falsch wiedergibt, wissen wir wo wir schrauben müssen.

Share this post


Link to post
Share on other sites

Wie man jetzt true und false übersetzt kann man debattieren... WIchtig ist halt dass im XML File der richtige Zustand ist.

 

Jain, debattieren will ich ja garnicht, aber um fest zu stellen, ob der Schalter richtig gesetzt ist, muss ich ja wissen, was sich der/die Entwickler dabei gedacht hat.

 

Ich beschreibs nochmal ganz ausführlich, um den Interpretationsspielraum einzudämmen:

Ein Konto auf der snomONE mit einem Ein-/Aus-Schalter als Service-Flag für die Rufumleitung zum Handy.

Im XML steht <state> auf false, in der Kontenübersicht steht der Status auf Clear, in der Detailansicht des Schalters steht der Zustand auf "Gesetzt" und Anrufe auf dem Konto werden an das Handy weitergeleitet.

Anders herum:

Im XML steht <state> auf true, in der Kontenübersicht steht der Status auf Set, in der Detailansicht des Schalters steht der Zustand auf "Gelöscht" und Anrufe auf dem Konto werden an das Handy nicht weitergeleitet.

 

Mit meinem letzten Post wollte ich nur sagen, dass ich das Verhalten merkwürdig finde, es aber akzeptieren würde, wenn es von euch so gewollt wäre.

Ich habe die Soundfiles so angepasst, dass sie zu diesem Verhalten passen. Also kann ich damit leben, wie es jetzt ist.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...