Jump to content

I am not getting calls on Aatra 480i


Recommended Posts

Hi everybody,


I am growing really desperate now. I registered on Aastra forum for help but they are taking their sweet time to approve so i can post something.


Anyway, I am salesman, running my own company and whole day I sit by the phone and computer and answer incoming calls and e-mails. I am using 2 x 480i phones here in this office and one in Florida when I go there. For provider I am using voip.ms and after years of struggling with trixbox and FreePBX and what not I was fairly happy for maybe year and half with voip.ms service. When you call my number voice mail answers and customer can select ext 1 (sales) and ext 2 (accounting).


We are located in Oakville, ON. So 2 months ago I replaced Cogeco Internet service (10/1) with Bell Fibe (15/10). After that I noticed that I am not receiving all the calls there should ring my phone. It is very hard to say when things went awry but result is that somebody calls, dials 1 to get sales line, nothing happens at my end, caller usually hungs up frustrated without leaving a voice mail. I know that I am missing a calls because if person holds on for more than 10-15 seconds voip.ms server sends an e-mail with caller ID data, time how long call lasted and voice mail message (if any). Sometimes, very rarely I hear only very short ring and display shows shortly caller ID, I pickup the phone immediately but there is no connection. So basically:


> phone is not ringing and callers think that there is nobody here to answer. I am actually here from 8:00 till 19:00 every day except weekends

> sometimes it rings, I pickup the line, start talking and it cuts me off after first few seconds

> me calling out is not a problem, only incoming calls are problem


* I tried to fix this problem by chatting with voip.ms support. They suggested to remove everything from SIP settings and entering same data into LINE 1 settings. I did and have same results, dropped calls.

* I have 2 independent DSL Internet feeds here and I switched phone to other one with no improvements.

* One person suggested to change registration times from 15 to 120 or 180. I did, experienced often red light comes on the phone but no change in dropped calls frequency.


I can't continue like this. Business is suffering. Not answering phone calls is quick way to go under. Please help if somebody has idea what is going on


Thank you, regards,


Link to comment
Share on other sites

I think you need to use the "divide and conquer" strategy here. Meaning trying to narrow down the problem. Essentially you have to make sure that the phone can talk to the PBX and that the PBX can talk to the provider. Your enemies: NAT and firewalls, and maybe even bandwidth.


To make sure that the phone properly connects to the PBX, try calling the mailbox on the PBX a couple of times, and stay connected at least for a minute. Try calling another mailbox and leave a message, then (e.g. using the PIN) and listen to the message. Make sure that it is the same of what you actually said.


Then when that is working, try calling your cell phone a few times. If you have random problems, you probably have a problem with the bandwidth. If it never works inbound or outbound, you probably have a problem with the SIP connection.


Some more tips are on http://kiwi.pbxnsip.com/index.php/One-way_Audio and http://kiwi.pbxnsip.com/index.php/Troubleshooting_SIP_Trunk_Problems.


You also might consider just using a hosted service. There are several providers offering hosted services based on snom ONE, please send me a private message to get contact data.

Link to comment
Share on other sites

snom ONE, thank you for input. I am using hosted PBX, that is voip.ms service. We are using their Toronto servers, we are in oakville, 60km away (if it matters at all).

I will try what you suggested, must add that I almost never have problems calling out and be on line for longer time. Inbound calls are not getting through part doesn't work.

Bandwidth should not be a problem, have 15/10 feed.

Link to comment
Share on other sites

You are wrong about that one. I asked every caller that I manage to call back and get response from says same thing. Call progresses normally, caller presses 1 to get sales line, there is a music on hold for duration of about 25 seconds while my phone suppose to ring and after that voice says that "sales is busy, leave the message". What they do, hang up! I would say that 1 person out of 15-20 that call in will want to leave the message.


If caller is on-line long enough I get e-mail with caller ID. I call immediately back.


As for forwarding to accounting line, I didn't think of that. Thank you. I will try to program it tomorrow, maybe I will know how.

Link to comment
Share on other sites

Ops must have overlooked the name... Anyway if it is hosted you can exclude problems on the trunk side.


If you use Aastra is then you must have set it up manually I guess. The main problem will be that the SIP traffic is probably done using UDP, and that is causing problems with firewalls. What firewall or router are you using? Do you see anything there with SIP/ALG in it? Turn it off when you see anything there, this is only causing trouble.


If you just have two phones, why don't you buy two snom phones? rolleyes.gif There you can use automatic provisioning and encrypted traffic, so that your firewall will not be able to intercept and modify the traffic between the phone and the PBX.

Link to comment
Share on other sites

Yes, I apologize for error in post's name. Tried to fix it but I can't, only Ops can do it, please do, looks bad.


Here are my settings;


Advanced SIP Settings

Explicit MWI Subscription Enabled

Explicit MWI Timeout

Send MAC Address in REGISTER Message Enabled

Send Line Number in REGISTER Message Enabled

Session Timer

T1 Timer =0

T2 Timer =0

Transaction Timer = 4000

Transport Protocol = UDP

Registration Failed Retry Timer = 1800

Registration Timeout Retry Timer = 120

Registration Renewal Timer = 30

BLF Subscription Period =3600


RTP Settings

RTP Port = 3000

Basic Codecs (G.711 u-Law, G.711 a-Law, G.729) Enabled

Force RFC2833 Out-of-Band DTMF Enabled

Customized Codec Preference List

DTMF Method

Silence Suppression Enabled


Basic SIP Network Settings

Proxy Server =

Proxy Port = 5060

Backup Proxy Server =

Backup Proxy Port = 5060

Outbound Proxy Server

Outbound Proxy Port

Registrar Server =

Registrar Port = 5060

Backup Registrar Server

Backup Registrar Port

Registration Period = 300


Zeros where there is nothing.


Router is Bell Fibe multifunctional router for Internet, TV, phone. It is made by Sagemcom USA. I can check model downstairs if needed. I don't see anything like SIP ALG or something. Only settings available are:








Under port forwarding I have some settings:

UDP: 5060 to

UDP: 10001-20000 to


Nothing else. I guess Bell is not allowing much flexibility with router settings

Link to comment
Share on other sites

It didn't. I lost a call 20 minutes ago.

Only way i discovered it was to log into voip.ms activity screen and there is a call I never received! Now I will apply different tacics recommended by other person. After ringing timeout I programmed system to forward call to accounting phone. We'll see will that work

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...