Jump to content

Upgrading to v5 from v4.5 on SoHo


Pablo
 Share

Recommended Posts

sorry, i should have said the wget did download the file which is now in the snomone director

 

I realize it's an obvious ?, but are you logged in as root? Also, have you tried to simply create the directory /usr/lib; so that you can move the libstdc++.so.6 file into it?

RE: not being able to access the admin page, I wonder if you might not have a problem in the routing table?

Link to comment
Share on other sites

Things are a little clearer now, I've found a Windows GUI interface and can see the full driectory structure now. I was using windows explorer and it was onlt showing me three folders.

 

So i do have a /use/lib folder, but when i try: mv libstdc++.so.6 /usr/lib

 

comes up with an error saying - mv: cannot stat `libstdc++.so.6': No such file or directory[/b][/b] so I assume this means there is no libstdc++.so.6 in the snomone directroy to move into the /usr/lib.

 

when i look in the /use/lib folder there is a shortcut called libstdc++.so.6 (19kb) but it is has a red arrow in the corner - here is a file listing:

Link to comment
Share on other sites

snomONE folder

 

libstdc++.so.6.0.13 874,176 20/11/2012 19:... rw‐r‐‐r‐‐ root

mutex.txt 23,856,579 12/04/2013 17:... rw‐r‐‐r‐‐ root

pbx ‐ Copy.xml 9,171 04/05/2012 14:... rwxr‐‐r‐‐ root

pbx.xml 9,858 15/04/2013 11:... rw‐r‐‐r‐‐ root

pbxctrl 13,125,084 20/11/2012 14:... rwxr‐xr‐x root

pbxctrl.new 13,125,052 17/04/2013 21:... rwxr‐xr‐x root

pbxctrl‐old 11,762,556 16/04/2013 19:... rwxr‐xr‐x root

pbxctrl‐sheeva‐2011‐4.3.0.5021 11,306,544 01/12/2011 19:... rwxr‐xr‐x root

pbxctrl‐sheeva‐4.5.0.1090 12,723,212 06/08/2012 13:... rwxr‐xr‐x root

snomONE‐ctrl 30 05/12/2011 20:... rwxrwxrwx root

Link to comment
Share on other sites

  • 2 years later...

My version now is 5.1.3 mini release. I use the same procedure to manual upgrade to 5.2.6 ... I tried to use ALL 3 version: mini , mini2 , and mini3 , which one have I to use ? Is normal that the dimensions of old file is 10 mbps and new file is 6-7 mbps? Thanks.

 

You probably have to change/fix the installation, to that the PBX executable uses the name pbxctrl (please read this thread again).

Link to comment
Share on other sites

ok. the web page now is upgraded to 5.2.6 , but probably the old configuration was lost , is impossible to enter whit old login , and the language is greek !! .... any suggestion too set default value and correct page visualization?

Link to comment
Share on other sites

  • 6 months later...

Hello,

 

I upgraded my SnomOne SoHo from 4.5 to 5.3.2 using the CLI install-debian.sh script.

 

I now have a issue to install my license code.

 

I insert the code in reg_license.htm web interface page and press the submit button but nothing happens.

 

The SnomOne is correctly connected to the internet.

 

After submitting I can see with netstat a connection being estalished but it is closed after few seconds:

68.178.130.101:443 ESTABLISHED 2177/pbxctrl

Any suggestions ?
Thank you.
P.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...