Jump to content
Vodia PBX forum
speedlnx

distinctive ringtones

Recommended Posts

Hello, anyone has been able to configure snomone to have different ringtones between external (hunt group routed) calls and internal calls? I've a test machine with 1 hunt group with 2 phone (snom 300 ver8.7.3.15) and 1 sip provider.

I've experience with snom300 and asterisk and i'm able to set different ringtones playing with the alert-info message and the phone admin page but no luck with snomone!!!

I've tried with the option in the hunt group configuration without luck. I've also follow the instruction to modify the ringtones.xml but i'm only able to set a personalized ringtone for the phone using the phone admin page and not from the snomone.

Share this post


Link to post
Share on other sites

I assume you already set the hunt group ring melody. Are you using plug and play with the 300? Then everything should be automatic.

 

Yes I have. I have my phones in auto provisioning mode.

post-24978-0-81031300-1355268790_thumb.png

Share this post


Link to post
Share on other sites

My Italian is pretty basic, but I would assume that you have selected something in "Tono di chiamata" like Custom 1. Did you modify the ringtones.xml file? The tones there are pretty much hardwired in the phone. Try to select the "Custom 1" tone, then it should ring differently.

Share this post


Link to post
Share on other sites

My Italian is pretty basic, but I would assume that you have selected something in "Tono di chiamata" like Custom 1. Did you modify the ringtones.xml file? The tones there are pretty much hardwired in the phone. Try to select the "Custom 1" tone, then it should ring differently.

 

I've tied both with my custom sound and with the original custom 1 sound but nothing seems to work and the phone ring always the same! :(

Share this post


Link to post
Share on other sites

I've tied both with my custom sound and with the original custom 1 sound but nothing seems to work and the phone ring always the same! :(

 

Ok, i do the following and all now seems ok (i'm on debian):

 

1) uninstall snomone (dpkg --purge snomone)

2) remove snomone directory (rm -fr /usr/local/snomONE)

3) reinstall last version with dpkg

4) reset of snom300 and shutdown (*,vol up,*, vol down, #)

5) modified the default group 72 to use "external" ringer

6) modified with the webpage took the pnp -> ringtones.xml to use a custom ringer for external instead of the predefinited one

7) power up the snom300 and now everything works fine :)

Share this post


Link to post
Share on other sites

Whow a factory reset of snom ONE! But that sounds like you have some customization in the html folder or in the webpages folder. Next time, try to remove those directories only and restart the service...

Share this post


Link to post
Share on other sites

Whow a factory reset of snom ONE! But that sounds like you have some customization in the html folder or in the webpages folder. Next time, try to remove those directories only and restart the service...

 

It was my first attempt... I've removed the html directory and the ringtones.xml file and restart the pbx. No luck...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...