Jump to content

Issues with call audio/sip


sudo
 Share

Recommended Posts

Ive got the newest version of snomone (v. 5.0.9) with three extensions registered.

 

My problem is that when I call out, my side does not ring, but the other side does. Then when the call is answered there is no audio from either side.

 

I can call in and it rings on both sides, but no audio when answered.

 

I did a pcap and there are RTP streams. I could even decode the .pcap and hear the audio that was not present during the call.

 

The call flow looks good and rtp is streaming both ways.

 

Ive attached a pic of the call flow.

 

Thanks

 

Sudo

Link to comment
Share on other sites

My first question is: Is there a firewall involved?

 

If the PCAP was done on the PBX host and you can hear the stream, you can rule out problems with the firewall. Then the question is how the phone is connected. Did you use PnP? At least TLS or TCP transport layer (not UDP)? Try a setup where the phone is in the LAN to make sure that there is no problem between the phone and the PBX:

Link to comment
Share on other sites

My first question is: Is there a firewall involved?

 

If the PCAP was done on the PBX host and you can hear the stream, you can rule out problems with the firewall. Then the question is how the phone is connected. Did you use PnP? At least TLS or TCP transport layer (not UDP)? Try a setup where the phone is in the LAN to make sure that there is no problem between the phone and the PBX:

 

The pcap was taken from the pbx server. The phones were two x-lite soft phones and a snom360 (Connected via PnP). The firewall is set to allow all traffic, tcp or udp.

 

Its strange that the pcap would record the audio coming in from the soft phones, but we could not hear the audio while on the call. Got to love VoIP ;)

Link to comment
Share on other sites

RESOLVED:

 

The issue was that the WebUI listed the RTP port range. I checked iptables and it did not have a rule to open these ports.

 

I manually added the rule and now im getting 2 way audio. This appears to be an issue with the WebUI not updating iptables.

Link to comment
Share on other sites

This appears to be an issue with the WebUI not updating iptables.

 

The PBX web UI definitively does not update iptables. While I agree that could make installations easier something tells me that processes should not mess with firewall settings, at least unless this is a consumer product. The CentOS script has at least some words at the end which seem to be widely ignored, they say something like:

 

 


# iptables
#

echo 'IMPORTANT:'
echo 'You might have to edit your firewall settings. Consider'
echo '"service iptables stop" and "chkconfig iptables off" to'
echo 'see if you need to edit the iptables configuration to use'
echo 'the PBX service'

 

Anyway, glad the issue was resolved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...