Jump to content
Vodia PBX forum
sudo

Agent Group LED not lighting up

Recommended Posts

Im running ver 5.0.10.

 

On http://wiki.snomone.com/index.php?title=Extension_Button_List under the "Agent login/logout:" section it states, "Once this button has been configured, the LED will light when the agent is logged in."

 

I am having both issues with this. I have two phones that will not illuminate the LED upon login, and I have two phones that will not turn off the LED upon logout.

 

These are all snom phones that have been PnP'd to the system (Bind to MAC).

 

I think I remember something about the NOTIFY request for MWI. Is it the same for this Q status led? A pcap shows no sip NOTIFY requests, but I do see a CLASSIC-STUN (protocol) Binding request coming from the phone, nothing back from the server to these requests. At least not with the same protocol.

 

One interesting note. Button 3 is configured for the agent login/log out. When you press this button, it dials the starcode and tells you that "you are now logged in". During this process, the LED for button 4 lights up. Once the message finishes playing, the LED turns off. Same for log out. When the message is playing, button 4's LED is lit, once the message has finished the LED turns off.

 

The star code's are the same for agent login, log out per snom (*64)

 

Any suggestions on fixing this button/led issue.

Share this post


Link to post
Share on other sites

The button features generally require that you use TLS transport layer. This is because UDP messages can easily get lost and also because UDP messages have a lot of problems with fragmentation. Maybe that's the problem?

Share this post


Link to post
Share on other sites

The button features generally require that you use TLS transport layer. This is because UDP messages can easily get lost and also because UDP messages have a lot of problems with fragmentation. Maybe that's the problem?

 

 

Where is this setting? Im running ver 5.0.10 and im not seeing it in the PnP section as denoted here http://wiki.snomone.com/index.php?title=How_to_deactivate_TLS

Share this post


Link to post
Share on other sites

The button features generally require that you use TLS transport layer. This is because UDP messages can easily get lost and also because UDP messages have a lot of problems with fragmentation. Maybe that's the problem?

 

This is using TLS on port 5061. Any other suggestions?

Share this post


Link to post
Share on other sites

We had reports that changing from TLS to TCP dramatically increased the stability of installations. We are also scratching our heads why. It is easy to blame US NSA and the British Intelligence for this, but no serious explanation. We need to keep watching this topic.

Share this post


Link to post
Share on other sites

We had reports that changing from TLS to TCP dramatically increased the stability of installations. We are also scratching our heads why. It is easy to blame US NSA and the British Intelligence for this, but no serious explanation. We need to keep watching this topic.

 

:lol: Haha - Can that be our 'Get out of jail free" card? Just tell the customer that big brother is messing up their encrypted sip traffic. ;)

Share this post


Link to post
Share on other sites

We have tested this on 1 of our users domain, that had the same issue and it worked fine for us remotely, maybe remove the phone and bring to a different ISP provider "Location" and see how it behaves.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...