Jump to content
cdominicy

email not sending from snomONE

Recommended Posts

Since our upgrade and transfer from snomONE Soho v4.5 to a Windows based snomONE v5.0.10a, the email are not being sent anymore.

after looking at the logs it seemed to be related to the SSL certificate on our Exchange 2007, but turning off TLS didn't help.

nor installing a proper Godaddy SSL certificate for our mail server : mail.newton.gi

Here is the logfile with level 9 for email events below

Note that I can send an email from command prompt with telnet mail.newton.gi 25, hello newton.gi, mail from: pbx@newton.gi, rcpt to: admin@newton.gi, data, subject: test .

 

Can anyone help?

 

[8] 2013/06/14 17:35:47: SMTP: Connect to 192.168.1.2:25

[8] 2013/06/14 17:35:47: SMTP: Received 220 ISAAC.newton.local Microsoft ESMTP MAIL Service ready at Fri, 14 Jun 2013 17:35:19 +0200

[8] 2013/06/14 17:35:47: SMTP: Received 250-ISAAC.newton.local Hello [192.168.1.5]

250-SIZE

250-PIPELINING

250-DSN

250-ENHANCEDSTATUSCODES

250-STARTTLS

250-X-ANONYMOUSTLS

250-AUTH NTLM

250-X-EXPS GSSAPI NTLM

250-8BITMIME

250-BINARYMIME

250-CHUNKING

250-XEXCH50

250 XRDST

[8] 2013/06/14 17:35:47: SMTP: Received 220 2.0.0 SMTP server ready

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: send_client_hello(030151bb3853e5140004000400050100001700000013001100000e6d61696c2e6e6577746f6e2e6769)

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: process_server_hello(030151bb3837c20003d3f7634999a4329044d404e8c75b425c247d748033631b5ac97e8ef000500)

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: [ca1d0000] process_certificate(00063082052ea003020102020a1a83 and loads more, lines in fact, removed)

[5] 2013/06/14 17:35:47: Certificate for mail.newton.gi could not be verified against

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: [ca1d0000] send_alert(022e)

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: [ca1d0000] process_server_hello_done()

[9] 2013/06/14 17:35:47: SMTP mail.newton.gi: [ca1d0000] send_alert(0230)

[5] 2013/06/14 17:35:47: SMTP: Connection to 192.168.1.2:25 failed

Share this post


Link to post
Share on other sites

You have to either add the root CA that is being used by mail.networn.gi to the list of trusted Root CA or just disable the certificate check in the mail settings of the PBX ("Check server certs for emails").

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...