Jump to content
Vodia PBX forum
lintes

Problems with installer and connection

Recommended Posts

HI there,

I'm running on a 10.7.5 with a fresh install and basically nothing installed.

 

First of all I had some problems in installing the suggested version: http://snomone.com/downloads/snomONE/macos/snomone-5.0.8-installer.mpkg.zip

the console said:

25/06/13 17:14:21,870 Installer: -[__NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: packages)

 

It seems to go well but no any interface is starting.

So I tried to change the version and luckily I've found http://snomone.com/downloads/snomONE/macos/snomone-5.0.2-installer.mpkg.zip

that is working.

 

So far so good.

I was able to run it.

 

Then I've tried to update it with the suggested link: http://snomone.com/downloads/snomONE/version-5.0.10a.xml

but still some problems.

I've solved it taking away the "a": http://snomone.com/downloads/snomONE/version-5.0.10.xml

and the update was successfully...

 

Then the disaster:

I've tried to upload the italian language prompt:

http://snomone.com/downloads/snomONE/audio/audio_it.xml

The web page said that the update was successful... but when I restarted (the link in the web is not working so I had to do it with the console) nothing is working any longer!

 

I've checked with the console and here is the starting of the log:

sh-3.2# ./pbxctrl --dir . --no-daemon

Starting up

[1] 20130625172305: Starting up version 5.0.10

[1] 20130625172305: Adding DNS server 85.37.17.57 to the dns server list

[1] 20130625172305: Adding DNS server 85.38.28.80 to the dns server list

[1] 20130625172306: Working Directory is /usr/Applications/snomone

[5] 20130625172306: Starting threads

[0] 20130625172306: TCP(IPv4):Could not bind socket to port 80 on IP 0.0.0.0

[0] 20130625172306: FATAL: Could not open TCP port 80 for HTTP/HTTPS

[0] 20130625172306: (IPv6)Could not bind socket to port 80 on IP [::]

[0] 20130625172306: FATAL: Could not open TCP port 80 for HTTP/HTTPS

[0] 20130625172306: TCP(IPv4):Could not bind socket to port 443 on IP 0.0.0.0

[0] 20130625172306: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 20130625172306: (IPv6)Could not bind socket to port 443 on IP [::]

[0] 20130625172306: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 20130625172306: TCP(IPv4):Could not bind socket to port 389 on IP 0.0.0.0

[0] 20130625172306: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20130625172306: (IPv6)Could not bind socket to port 389 on IP [::]

[0] 20130625172306: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20130625172306: UDP(IPv4): bind() to port 0.0.0.0:161 failed

[0] 20130625172306: Could not open UDP port 161 for SNMP

[0] 20130625172306: UDP(IPv6): bind() to port [::]:161 failed (errno=48)

[0] 20130625172306: Could not open UDP port 161 for SNMP

[0] 20130625172306: UDP(IPv4): bind() to port 0.0.0.0:69 failed

[0] 20130625172306: Could not open UDP port 69 for TFTP

[0] 20130625172306: UDP(IPv6): bind() to port [::]:69 failed (errno=48)

[0] 20130625172306: Could not open UDP port 69 for TFTP

[0] 20130625172306: UDP(IPv4): bind() to port 0.0.0.0:5060 failed

[0] 20130625172306: FATAL: Could not open UDP port 0.0.0.0:5060 for SIP

[0] 20130625172306: UDP(IPv6): bind() to port [::]:5060 failed (errno=48)

[0] 20130625172306: FATAL: Could not open UDP port [::]:5060 for SIP

[0] 20130625172306: TCP(IPv4):Could not bind socket to port 5060 on IP 0.0.0.0

[0] 20130625172306: FATAL: Could not open TCP port 5060 for SIP

[0] 20130625172306: (IPv6)Could not bind socket to port 5060 on IP [::]

[0] 20130625172306: FATAL: Could not open TCP port 5060 for SIP

[0] 20130625172306: TCP(IPv4):Could not bind socket to port 5061 on IP 0.0.0.0

[0] 20130625172306: FATAL: Could not open TCP port 5061 for SIP

[0] 20130625172306: (IPv6)Could not bind socket to port 5061 on IP [::]

[0] 20130625172306: FATAL: Could not open TCP port 5061 for SIP

[5] 20130625172306: Set scheduling priority to 15

 

 

It seems like all the port are closed... but are not!

I've little snitch running and checking all the connections...

 

If I try to delete the directory in /usr/Application/snomone and try to reinstall nothing change...

what's going on?

 

Let me know please

 

Marco

Share this post


Link to post
Share on other sites

We are about to release 5.1.0; but in the meantime you can take http://snomone.com/downloads/snomONE/version-5.0.10i.xml. The socket binding was a problem if the port was used before, either by the PBX itself or another service. We have smartened up the logic to grab the necessary ports.

 

The process must run with root permissions, if you want to try to run it manually, use sudo.

Share this post


Link to post
Share on other sites

We are about to release 5.1.0; but in the meantime you can take http://snomone.com/downloads/snomONE/version-5.0.10i.xml. The socket binding was a problem if the port was used before, either by the PBX itself or another service. We have smartened up the logic to grab the necessary ports.

 

The process must run with root permissions, if you want to try to run it manually, use sudo.

 

thanks for the reply, but how can I take that xml if I can not run the program?

Share this post


Link to post
Share on other sites

We are about to release 5.1.0; but in the meantime you can take http://snomone.com/downloads/snomONE/version-5.0.10i.xml. The socket binding was a problem if the port was used before, either by the PBX itself or another service. We have smartened up the logic to grab the necessary ports.

 

The process must run with root permissions, if you want to try to run it manually, use sudo.

 

 

After a bit of trying I did this command:

sh-3.2# ./pbxctrl --config version-5.0.10i.xml

 

nothing happen apart from this log file:

[0] 20130625183736: Upgrading from 1.x to 2.0

[1] 20130625183736: Starting up version 5.0.2

[1] 20130625183736: Adding DNS server 85.37.17.57 to the dns server list

[1] 20130625183736: Adding DNS server 85.38.28.80 to the dns server list

[1] 20130625183737: Working Directory is /usr/Applications/snomone

[5] 20130625183737: Starting threads

[0] 20130625183737: TCP(IPv4):Could not bind socket to port 80 on IP 0.0.0.0

[0] 20130625183737: FATAL: Could not open TCP port 80 for HTTP/HTTPS

[0] 20130625183737: (IPv6)Could not bind socket to port 80 on IP [::]

[0] 20130625183737: FATAL: Could not open TCP port 80 for HTTP/HTTPS

[0] 20130625183737: TCP(IPv4):Could not bind socket to port 443 on IP 0.0.0.0

[0] 20130625183737: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 20130625183737: (IPv6)Could not bind socket to port 443 on IP [::]

[0] 20130625183737: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 20130625183737: TCP(IPv4):Could not bind socket to port 389 on IP 0.0.0.0

[0] 20130625183737: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20130625183737: (IPv6)Could not bind socket to port 389 on IP [::]

[0] 20130625183737: FATAL: Could not open TCP port 389 for HTTP/HTTPS

[0] 20130625183737: UDP(IPv4): bind() to port 0.0.0.0:161 failed

[0] 20130625183737: Could not open UDP port 161 for SNMP

[0] 20130625183737: UDP(IPv6): bind() to port [::]:161 failed (errno=48)

[0] 20130625183737: Could not open UDP port 161 for SNMP

[0] 20130625183737: UDP(IPv4): bind() to port 0.0.0.0:69 failed

[0] 20130625183737: Could not open UDP port 69 for TFTP

[0] 20130625183737: UDP(IPv6): bind() to port [::]:69 failed (errno=48)

[0] 20130625183737: Could not open UDP port 69 for TFTP

[0] 20130625183737: UDP(IPv4): bind() to port 0.0.0.0:5060 failed

[0] 20130625183737: FATAL: Could not open UDP port 0.0.0.0:5060 for SIP

[0] 20130625183737: UDP(IPv6): bind() to port [::]:5060 failed (errno=48)

[0] 20130625183737: FATAL: Could not open UDP port [::]:5060 for SIP

[0] 20130625183737: TCP(IPv4):Could not bind socket to port 5060 on IP 0.0.0.0

[0] 20130625183737: FATAL: Could not open TCP port 5060 for SIP

[0] 20130625183737: (IPv6)Could not bind socket to port 5060 on IP [::]

[0] 20130625183737: FATAL: Could not open TCP port 5060 for SIP

[0] 20130625183737: TCP(IPv4):Could not bind socket to port 5061 on IP 0.0.0.0

[0] 20130625183737: FATAL: Could not open TCP port 5061 for SIP

[0] 20130625183737: (IPv6)Could not bind socket to port 5061 on IP [::]

[0] 20130625183737: FATAL: Could not open TCP port 5061 for SIP

[5] 20130625183737: Set scheduling priority to 15

 

 

it seems that same problem :(

Share this post


Link to post
Share on other sites

Did you try to run it as root? Without it, you might not have the permissions to open sockets. Also, check what other applications are using the ports using netstat -a. Maybe there is even another PBX already running, ps auxww|grep pbxctrl will show you that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...