Jump to content

Polycom not addiding additional lines


sudo
 Share

Recommended Posts

Ive got a 5.0.10 ver box and im having a new issue with a Polycom IP 550.

 

Under the registration section of the extension I set the 'lines' field to 4, but the phone only provisions 1 line. This has workeed in the past to add additional line buttons.

 

Under the domain settings I made the max ammount of colines: 4. Im not seeing anything else that would cause this.

 

Anyone got any ideas on fixing this via PnP? It used to work and I do not want to have to go to the web ui of the phone and manually provision the additional lines.

 

Thanks.

 

Sudo

Link to comment
Share on other sites

Under the registrations section again - Lines was set to 4 and Max. number of concurrent registrations per extension was blank. I set that to 4 as well and still getting 1 line.

 

I when I log into the webui of the polycom, I can manually enter the lines.... Wonder why PnP broke for this piece? Eveything else seems to be working as far as PnP goes. I wonder if its the new Polycom firmware?

 

Running:

 

UC Software Version 4.0.3.7562

BootROM Software Version 5.0.3.1667

Link to comment
Share on other sites

The problem is related to the "last one who saves the MAC wins" problem that we have already discovered and even fixed. It is already fixed and available in the 5.0.10i version (http://snomone.com/d...ion-5.0.10i.xml).

 

After upgrading, remove the MAC and save them again.

 

So - I hope I understood what you meant. This is what I did.

 

I upgraded to ver 5.0.10i (CentOS64), removed the MAC from the extension and saved. Re added the MAC into the ext. Re provisioned via MAC addr. Its still only pulling up 1 line.

 

I did the above steps again, but this time I removed the snomone/generated/pbx-domain/extension file and I got the same result. 1 registered line.

 

Any more suggestions?

Link to comment
Share on other sites

Well you need to remove and add the MAC to all extensions that share the same MAC. But apart from that, you did it right. The generated folder is not read, only written and should help you figure out what was sent to the device.

 

You can double check the macs directory if the PBX got it right.

Link to comment
Share on other sites

Well you need to remove and add the MAC to all extensions that share the same MAC. But apart from that, you did it right. The generated folder is not read, only written and should help you figure out what was sent to the device.

 

You can double check the macs directory if the PBX got it right.

Checking the macs/ dir, there is only 1 corresponding .xml. If I understand correctly, I should see more than one to create this conflict (?). This MAC is not used by any other extension. I do see that this MAC is in 2 different extensions in the generated/ dir but this should not matter as the generated dir is only written to.

 

This phone is only going to be associated with one extension and I need multiple lines on it.

Link to comment
Share on other sites

Ohhhhh.... Okay now I understand you. I thought you wanted difference extensions on the same phone.

 

So what you want are several private lines on the phone. You actually have that by default, even though there is only one button associated with it. Did you try setting the "lines" parameters in the registrations tab? At least in the old pbxnsip days, that provisioned several lines on the phone; though with the latest version that could conflict with the explicit button assignments (but worth a quick try). But again, I would personally not put several lines on the precious buttons on the phone, instead use the phone user interface to toggle between the different calls on the phone.

Link to comment
Share on other sites

Ohhhhh.... Okay now I understand you. I thought you wanted difference extensions on the same phone.

 

So what you want are several private lines on the phone. You actually have that by default, even though there is only one button associated with it. Did you try setting the "lines" parameters in the registrations tab? At least in the old pbxnsip days, that provisioned several lines on the phone; though with the latest version that could conflict with the explicit button assignments (but worth a quick try). But again, I would personally not put several lines on the precious buttons on the phone, instead use the phone user interface to toggle between the different calls on the phone.

 

I thought that I was clear, but apparently not. My apologies.

 

You have hit the nail on the head as that is exactly my problem. I add more lines in the "lines" field under the registrations tab and it still only shows up with one line on the phone. The phone is configured via PnP. This was working great before and now its broken.

 

The webui is a great option, but this particular cust is specifically asking for them back on the phone.

 

I appreciate your advice. Do you have any more suggestions?

 

~Sudo

Link to comment
Share on other sites

Well in the old times we used that 150 KB template for Polycom which somewhere must have included the settings that told the phone to use so-and-so many lines. I guess we need to dig that settings out again, and then insert it into the new template--if the settings is set. I think the default behavior now is good and we should change it only if the user has specifically added the settings to the extension.

Link to comment
Share on other sites

I see in the polycom_all.xml:

 

{loop-start}

reg.{lc}.address="{account}"

reg.{lc}.auth.password="{password}"

reg.{lc}.auth.userId="{account}"

reg.{lc}.label="{account}"

reg.{lc}.auth.domain="{domain}"

reg.{lc}.displayName="{display-name}"

reg.{lc}.outboundProxy.address="{ip-adr}"

reg.{lc}.outboundProxy.port="{sip-port tcp}"

reg.{lc}.outboundProxy.transport="TCPOnly"

reg.{lc}.serverFeatureControl.signalingMethod="subscribeAsFeatureEvent"

reg.{lc}.serverFeatureControl.subscribeToUri="{account}"

reg.{lc}.server.1.address="{domain}"

reg.{lc}.server.1.port="{sip-port tcp}"

reg.{lc}.server.1.register="1"

reg.{lc}.server.1.transport="TCPOnly"

{loop-end}

 

Im no programmer but I believe there is an issue with "{lc}" (line count?) seems like this may be the broken piece.

 

I assume the this script pulls the line count from the snomone gui config. Do you think im close? How do we fix this?

Link to comment
Share on other sites

I appended the above string to the beginning of the stanza and it worked. Thanks for your help!

 

For reference the working stanza is as follows:

 

{loop-start}

reg.{lc}.lineKeys="{lines}"

reg.{lc}.address="{account}"

reg.{lc}.auth.password="{password}"

reg.{lc}.auth.userId="{account}"

reg.{lc}.label="{account}"

reg.{lc}.auth.domain="{domain}"

reg.{lc}.displayName="{display-name}"

reg.{lc}.outboundProxy.address="{ip-adr}"

reg.{lc}.outboundProxy.port="{sip-port tcp}"

reg.{lc}.outboundProxy.transport="TCPOnly"

reg.{lc}.serverFeatureControl.signalingMethod="subscribeAsFeatureEvent"

reg.{lc}.serverFeatureControl.subscribeToUri="{account}"

reg.{lc}.server.1.address="{domain}"

reg.{lc}.server.1.port="{sip-port tcp}"

reg.{lc}.server.1.register="1"

reg.{lc}.server.1.transport="TCPOnly"

{loop-end}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...