Jump to content

Phone requires + to dial out


Fisher Networks
 Share

Recommended Posts

I am using the * wildcard in my Dial Plans setup with a single trunk. However the phone complains about needing me to dial in this fashion: +1xxxxxxxxxx. I need no plus, and for local calls I'd prefer being able to dial out without putting the 1 in, and just dial areacode + 7. Is this possible?

 

Would the + requirement be the SNOM phone?

Link to comment
Share on other sites

It is the phone. It says it needs to be dialed using the e164 dialing or something along those lines when you dial without the + sign.

It is a new installation.

 

I don't know. I have never seen a installation where people had to put a + sign at the beginning of a number in order to dial out. I would rather look at the dial plan and then maybe put the + at the front of the number.

Link to comment
Share on other sites

I just enabled ENUM on the phone, put in 1 for country code and 206 for the area code and it automatically added the +1206 when dialing a seven digit number. Now the only problem is when I put in an area code (as in to dial a different number) it doesn't put a +1xxx in front, it just dials the number as I put it in and this is what PBXNSIP says:

 

SIP/2.0 404 Number not in e164 format, example +12125551212

Via: SIP/2.0/UDP 67.xxx.xxx.xxx:2054;branch=z9hG4bK-lic0jur614u1;rport=2054

From: "Tanya" <sip:501@domain.com>;tag=7pss29b2s0

To: <sip:4255551212@domain.com;user=phone>;tag=e95c35967e

Call-ID: 3c27ab34c484-13ayr4lhwsm5

CSeq: 2 INVITE

Contact: <sip:501@67.xxx.xxx.xxx:5060>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: pbxnsip-PBX/2.1.5.2357

Content-Length: 0

Link to comment
Share on other sites

I would not enable ENUM on the phone just to be able to dial regular numbers. ENUM is a long long topic that you probably don't want to touch just to solve that problem. I would solve the problem with that dial plan on the PBX above.

 

I hooked up a SNOM 320 at my home since it would be easier to test than going back and forth to the office, and it worked almost immediately. There is no + requirement, the dial plan setup on the SIP server works great, and strangely, the phone doesn't list anything in it's own dial plan field. I'm not sure no whether there is some strange legacy setting on the 360 causing this, a firmware version issue or what. I'll wipe out the settings and try and set it up again.

 

I'm very excited that the 320 works though, thanks for the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...