Jump to content
MornayD

snom one mini::one way audio on sip trunks only

Recommended Posts

Hi

 

Have one way audio over sip trunk. when making calls internally or over BRI / FXO no issues at all. calls over SIP all end up with one way audio.

have tested with sonicwall and netgear firewalls / routers, same result. have replaced snom one mini with 3cx, changed rtp ranges and audio works great in both directions. replaced 3cx with mini and back to one way audio (obviously i have updated the rtp ranges again).

 

also, itsp says we ar sending this data in the sip invite. cannot see where to remove this on the mini. the itsp thinks this may have something to do with this.

“a=rtcp-xr:rcvr-rtt=all voip-metrics”

 

Thank you for your assistance

 

4.5.0.1097 Epsilon Geminids (snom ONE mini)

Share this post


Link to post
Share on other sites

thank you for your reply. unfortunately i cannot find any reference to disabling this attribute on the link you have posted, only that it can be turned back on again. could you please just point me in the right direction?

Share this post


Link to post
Share on other sites

Ahh... There are settings in the pbx.xml file that you can tweak. Search for "rtcp_" and change the settings all to false, then restart the service. This completely disables RTCP-XR on the system, including the phones. But at least you can make calls to that service provider.

Share this post


Link to post
Share on other sites

thank you. i have found the rtcp_ tags and set their values to false.

unfortunately the one way audio remains.

i have swapped with mini for a 3cx server, changes the rtp port ranges and tested ok with audio working in both directions. it therefore seems to be a problem with the mini / sip trunk configuration.

i did notice many out of sequence rtp packets on wireshark. is there something else i can check to address this problem?

Share this post


Link to post
Share on other sites

I've personally found that one way audio on the trunks can be caused by a router that does not properly handle the layer 7 SIP translations if you are behind a firewall. If you can disable the routers attempt to translate the SIP headers you can configure the Snom One Mini to create and process the headers correctly on the Admin Settings Ports page using the "IP Routing List" configuration line.

Share this post


Link to post
Share on other sites

thanks Dale for your post.

if it were a natting / routing problem, would we not expect to receive no rtp packets in pcap? in our case we do receive packets, they just appear to contain no audio.

if i am misunderstand, please feel free to correct me.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...