Jump to content
Vodia PBX forum

Recommended Posts

Still, we can't make it working (inter-domain calls)

 

But this issue is not the most serious one... With 5.1.2 and 5.1.3, our users are not able to register on the PBX after a while (normally one day or less).

 

PBX restart always helps.

 

It never happens with 5.1.1 and lower, but always happens with 5.1.3.

 

Web interface looks normal, no any issues - but all clients (including soft phones and Snom 870 devices) are simply not able to use PBX ("registering..." forever).

 

Networks are not blocked.

Share this post


Link to post
Share on other sites

Second question (again regarding inter domain calls).

 

Let's make it simple.

 

We've got some customers with 4 digit internal numbers. (i.e. 3000).

 

There are some other companies (in the same holding) with numbers 70xx, 71xx, etc.

 

They are not willing to change internal numbers (therefore it is not acceptable to set "more than 6 digits" numbers), they'll better change provider (us).

 

It is not a problem to allow inter-domain calls in 4.x and 5.x ( lower than 5.1.2), but Vodia developers changed something in the code and now it is simply not possible to make it working again.

 

We tried to rewrite numbers (adding "+" before extension), use additional trunk, etc. It is simply not working. The issue is very serious for us.

 

Please provide correct steps, how to achieve old, simple and reliable behavior - call from 3000 to 7000 should be made locally without any additional numbers to dial. That's is.

 

Customers don't like to use more than 4 digits numbers (hard to remember and address book is not useable from some soft phones), don't like to dial any additional digits, etc.

 

Your own sample (http://wiki.snomone.com/index.php?title=Dial_Plan_Inter-domain ) not works on 5.1.3 (however it works fine on 5.1.1)

Share this post


Link to post
Share on other sites

We experience strange Problems when updating to 5.1.3. After Login the browser opens http://localhost/reg_domains.htm and shows us crazy stuff like this:

 

 

#2 help:ADOlis1

#3

pic_warning.gif#localhost

 

#reg_edit_domain.htm 1 help:ADOedi1

#reg_edit_domain.htm 2

#reg_edit_domain.htm 7 #reg_edit_domain.htm 8 #reg_edit_domain.htm 9 #reg_edit_domain.htm max_extensions #reg_edit_domain.htm max_attendants #reg_edit_domain.htm max_callingcards #reg_edit_domain.htm max_hunts #reg_edit_domain.htm max_hoots #reg_edit_domain.htm max_srvflags #reg_edit_domain.htm max_ivrnodes #reg_edit_domain.htm max_acds #reg_edit_domain.htm max_conferences #reg_edit_domain.htm max_colines #reg_edit_domain.htm max_calls #reg_settings.htm max_regs #reg_edit_domain.htm admins

 

 

#reg_create_domain.htm 1 help:ADOcre1

#reg_create_domain.htm 2

#reg_create_domain.htm 8 #reg_create_domain.htm 9 #reg_create_domain.htm file

 

 

By exchanging pbxctrl.old everything is fine (V 5.1.2). I wonder, why the filesize of the 5.1.3 is less (9.252 KB) than the 5.1.2 (11.020 KB). Exchanging the exe-file back causes the same error again. Even a complete deinstallation and new Installation starts with the above issue.

 

Never had a Problem after updating before. Any help?

 

We've installed the 64-bit Version on a Win2008R2 System...

Share this post


Link to post
Share on other sites

This is caused by the new JavaScript loading of the translations. We have also seen those patterns sometimes. It seems to depend on the browser type and the cache status. it is not critical. We'll try to fix this with the next release. Usually it disappears after pressing F5 and logging in the next time.

 

Yes the file size is less; we have removed a lot legacy stuff that was never referenced ("junk").

Share this post


Link to post
Share on other sites
Polycom phones are now using TLS? the problem is its broken? the PBX does not have a cert for polycoms ?



1231112547|sip |4|03|MakeTlsConnection: SSL_connect error 1

1231112547|sip |4|03|MakeTlsConnection: connection failed error -1

1231112631|sip |4|03|Server certificate verification failed, Untrusted Cetificate

1231112631|sip |4|03|MakeTlsConnection: SSL_connect error 1

1231112631|sip |4|03|MakeTlsConnection: connection failed error -1


fixed by altering the master template to use TCP/UDP

Share this post


Link to post
Share on other sites

The certificate is provisioned into the phones. For this, you must have Polycom version 4 or higher. If it is less than version 4, then the PBX provisions the phones without TLS. Unfortunately it is difficult to provision the Polycom phones the right firmware. The firmware has to be copied into the PBX directory and this must be done manually because of the licence agreement before the download.

Share this post


Link to post
Share on other sites

Any news regarding inter-domain calls?

 

Currently we are using 5.1.1 with zero problems, but we'd lilke to be able to upgrade...

Share this post


Link to post
Share on other sites

regarding TLS, does the phone need a real cert? or is there a polycom cert already built in.

 

I had to adjust the PnP master file to get the older 501's working but they work now. I can send over my template file if needed.

Share this post


Link to post
Share on other sites

No, the Polycoms take any cert (even the built-in one). The older Polycom are becoming more and more difficult, especially when used in networks that also use the newer phones (VVX). We have a hard time to come up with a TFTP folder that serves them all.

Share this post


Link to post
Share on other sites

There is a glitch in 5.1.3 when editing domains. If there is no alias name set, then it would not take it. Workaround: Assign a dummy alias name to the domain.

Share this post


Link to post
Share on other sites

No, the Polycoms take any cert (even the built-in one). The older Polycom are becoming more and more difficult, especially when used in networks that also use the newer phones (VVX). We have a hard time to come up with a TFTP folder that serves them all.

I don't think this is correct, I have a cheap godaddy wildcard cert on all my servers.. and the polycom complains about it and wont register... (fyi)

Share this post


Link to post
Share on other sites

Oh, We did not test with wildcard certificates... Maybe the Polycoms have a problem with that! As for the PBX, it treads all certificates the same, including wildcard certs.

Share this post


Link to post
Share on other sites

snom360 having problems registering after upgrade from 5.1.1 to 5.1.3.

 

Log on the phone shows:

1/1/1970 01:01:53 [ERROR ] PHN: Warning: Certificate verification omitted. TLS Server authentication is switched off! 
1/1/1970 01:01:55 [NOTICE] LID: TCP: SIP-0 1 connect timeout
1/1/1970 01:01:55 [ERROR ] PHN: SIP: transport error: 1000000 -> tls:192.168.13.8:5061
1/1/1970 01:01:55 [NOTICE] PHN: SIP: Add dirty host: tls:192.168.13.8:5061 (0 sec)
1/1/1970 01:01:55 [NOTICE] PHN: SIP: final transport error: 1000000 -> tls:192.168.13.8:5061
1/1/1970 01:01:55 [ERROR ] PHN: SIP: transport error 1000000: generating fake 597

After going to Settings / Identity / Reregister User it succeeds.

Share this post


Link to post
Share on other sites

Well it seems it also has problems getting the time? Did it upgrade to 8.7.3.25? We had seen cases where you need to "nuke" it (factory reset) to make it work properly.

Share this post


Link to post
Share on other sites

I have a query regarding the CDR email reports, On this version of software it has changed to be the same format as the web interface reports. Is it possible to add the direction column back in? it doesn't appear on the email reports anymore.

Share this post


Link to post
Share on other sites

The direction makes only sense when you report trunk calls (or extensions). The new call display deals with calls per se; however it might make sense to add a flag to the trunk indication so that it becomes visible if the call came in on the trunk or went out on the trunk.

Share this post


Link to post
Share on other sites

Well it seems it also has problems getting the time? Did it upgrade to 8.7.3.25? We had seen cases where you need to "nuke" it (factory reset) to make it work properly.

 

Tried the factory reset, same result. The problem also happens when the time on the phone is correct (normal reboot). The 1970 time setting happens only after a power-on reset.

Share this post


Link to post
Share on other sites

Well, we are kind of shrugging our shoulders. We have changed something in the template that had to do with the LED; But I don't think that can have any impact on the phone not properly booting up. Maybe the phone is just getting old and sending signals that it wants a hardware upgrade :blink: . Do you have other phones in the network that are newer?

Share this post


Link to post
Share on other sites

Hi,

 

I put the country code in all domains but had to remove it immediately. The issue is that my carriers started to get digits that they do not need and that messed up calls. In other words, the chain of digits that are produced from the dial plan, were fine without the country code, but started to get the country code at the beginning (after adding it in the domain) and distorted what the carriers were expecting.

 

I would like to allow for inter-domain calling, but, obviously, normal outbound calls need to continue as always. How should I configure things?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

You can also control what the carrier will see. For that the trunk has the setting "rewrite global numbers". I know 5.1.3 changed a couple of things, and the trunk area keeps on being dynamic. However the normalization is important in order to make it possible to call international numbers without problems.

Share this post


Link to post
Share on other sites

By way of trial and error, during the wee hours of Sunday, I was able to find out that if I change the value of the parameter "Rewrite Global Numbers" to "ROW (0 and 00 format)", the outbound trunk calls work fine with my carriers. That was the only value that would work in my case. Fortunately, now I can have inter domain calls as well as good outbound trunk calls. Now I have a new question. Is there a way to present the DID as the displayed number for the inter domain calls? It seems that we are showing the extension.

 

Regards

Share this post


Link to post
Share on other sites

×
×
  • Create New...