Jump to content

Call from asterisk to snom One does not work


fangeli
 Share

Recommended Posts

The problem is definitely an incorrect configuration.

I created a sip trunk between an Asterisk and a snom one , the first have two trunks (one inbound and one outbound) type "SIP Gateway"

pointing to a single trunk sull'asterisk .

Calls from an extension registered on snom one, are rotated correctly toward the Asterisk, while the opposite does not happen.

On the snom one I get the following error


[8] 2013/12/20 12:33:26: Could not find a trunk (2 trunks)

[7] 2013/12/20 12:33:26: Set packet length to 20

[6] 2013/12/20 12:33:26: Call-leg 24: Sending RTP for 5d667fb07f40a34e5884ff734539d1d8@192.168.XXX.4:5060 to 192.168.XXX.4:13694, codec not set yet

[8] 2013/12/20 12:33:26: Incoming call: Request URI sip:601@192.168.YYY.4, To is <sip:601@192.168.YYY.4>

[5] 2013/12/20 12:33:26: Received incoming call without trunk information and user has not been found

[8] 2013/12/20 12:33:26: call port 24: state code from 0 to 404

[7] 2013/12/20 12:33:26: Set packet length to 20

[8] 2013/12/20 12:33:26: Hangup: Call 24 not found

[8] 2013/12/20 12:33:26: Clearing call port 24, SIP call id 5d667fb07f40a34e5884ff734539d1d8@192.168.XXX.4:5060


I have checked all of the trunk and outbound route of the Asterisk, without finding obvious problems.


Thank for the help


Link to comment
Share on other sites

The PBX needs to find out where the call comes from. It does that by going through a couple of rules (see http://wiki.snomone.com/index.php?title=Inbound_Calls). When the PBX says "Received incoming call without trunk information and user has not been found" it was not able to match the SIP request to any of the provided IP addresses in any trunk. I guess you need to double check the source IP of the request coming from the Asterisk server.

Link to comment
Share on other sites

Thanks to all for the answers, now I understand where is the problem.

I need to figure out how to use the "Send call to extension" option to route the incoming calls to various extensions.

Currently if I call the extension 601, 602 or 603 from the main pbx, the call stops within the snom one with the error mentioned in the first post.

I have read the document on the management of inbound call, but I have not figured out how to do this configuration.


Thanks to all

Link to comment
Share on other sites

  • 2 weeks later...

I use this setup in "Send call to extension": !([0-9]*)!\1!t!yy! where yy are the extension the call route to if nothing else match in the number plan.

 

In V5 we have turned that into a small JavaScript that offers some popular patterns. Whenever it comes to ERE, the road becomes slippery!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...