Jump to content
Vodia PBX forum
djanjic

Caller ID

Recommended Posts

Before we moved to PBXNSIP we used asterisk box. On that box incoming call will properly display the whole information about the caller, number plus the name. Ever since we moved to pbxnsip incoming caller id on our Snom 360 looks something like this 5404633279@192.168.1.1, IP address of our gateway, caller ID on Snom 320 shows up only as a number. It didn?t bother me that much until one of our new customers had asked me would they be able to see the name of the person or business which called. I didn?t have an answer for this customer. Does any one know if this is something we did during the initial set up or it is the way it is? I know that our gateway is passing proper information to the PBX because it used to work on asterisk which was connected to the same gateway.

Share this post


Link to post
Share on other sites

A very simple trick is to add the IP address as alias name for the domain. Then the PBX will change the IP address to the primary domain name.

 

If the domain is not a local name, it is neccessary to keep the domain name. Otherwise, calls from sip:123@pbxnsip.com to your domain would always appear as a call from extension 123.

Share this post


Link to post
Share on other sites
A very simple trick is to add the IP address as alias name for the domain. Then the PBX will change the IP address to the primary domain name.

 

I am sorry, I am bit confused. Are you talking about adding an IP address of the gateway or the pbx itself?

 

If the domain is not a local name, it is neccessary to keep the domain name. Otherwise, calls from sip:123@pbxnsip.com to your domain would always appear as a call from extension 123.

 

And my main question was regarding the way PBX passes the information about the caller to the phone. As I said we used to be able to see full name and the number of the person which was calling in, now we cannot, only the number. I understand if we include some of these numbers in to our contact list that they will be displayed by name. That is the feature customer is requesting, they want the name not just the number.

Share this post


Link to post
Share on other sites

The PBX normalizes the From and To headers on new calls. This means is checks if the domain name is a known local domain name, and if that is the case, it replaces it with the primary name. If you use the name "localhost", it will match all domain names.

 

On the snom phones, make sure that the domain name for the registration is the same as the primary name of the domain. Usually the easiest way to make this happen (considering domain names like "localhost"!) is to use the outbound proxy feature on the phone.

Share this post


Link to post
Share on other sites

I am using version 1.5.1.6 with an Audiocodes MP-118 FXO and our celler id only works some of the time. Most of the time we only get 1001, 1002, 1003 etc instead of the actual phone number. Has anyone seen this? Is there a fix?

 

I have been through everything with Audiocodes support and even changed the config of every possible option with no luck. Any help would be appreciated.

 

 

Mike

Share this post


Link to post
Share on other sites

Did you try the prefix setting for the trunk? This way, you can put something in front of the extension number. In most parts of Europe and the rest of this planet except NANPA that solves the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...