Jump to content
Vodia PBX forum
shapa

Please add 600s settings to TCP/TLS NAT Refresh (s):

Recommended Posts

iOS applications requiring for backgrounding support at least 600s refresh time.

 

Right now it is not possible to set (maximum available setting is 180s), only "default" settings works, but we'd like to be able to control refresh period (default == client control, right?)

 

Share this post


Link to post
Share on other sites

So, "default" is not working at all - iOS client stopping to complain, but all incoming calls are not going to iOS application (neither foreground nor background).

 

Please add 600s ASAP as we've got a lot of users who is complaining about this issue (iOS SIP)

 

It should be just a few seconds for you to "fix" it. Thanks in advance.

 

Screenshot is here:

 

https://www.dropbox.com/s/kicnpegzg886f6i/Screenshot%202015-05-17%2014.15.46.jpg?dl=0

 

p.s. manual change in pbx.xml seems to work (<nat_tcp2>600</nat_tcp2), but it should be supported officially

Share this post


Link to post
Share on other sites

Ok. Next version will have this.

 

In the meantime, you can exit the pbx.xml and change the nat_tcp2 setting to 600 (which requires a restart). As long as you don't save anything on the page, this should be working fine for you.

Share this post


Link to post
Share on other sites

One small add-on: 600 is not enough sometimes, >600 (like 660s) works

 

Yes, I made a change manually and it works now.

 

iOS clients are able to receive calls for a whole day...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×