Jump to content

Sending 1 email at a time?


Tim_TC911
 Share

Recommended Posts

Email appears to be working in that we do receive emails from the PBX, but it appears to be only sending one message at a time per trigger. For example, when i miss a call that triggers the PBX to send an email but the email i get is a test message from 4 days ago because there are many emails "queued" to be sent. Is there a way to view the email message queue and clear it out, or better yet, have it send everything in the queue? Why would it only be sending one message at a time?

Link to comment
Share on other sites

Our email is an on-prem Exchange 2010 server. logs don't reveal too much, here is the most recent email event from the log (slightly sanitized):

 

[8] 12:34:30.548 EMAI: Received SMTP traffic
220 *********************************************************************************************
[8] 12:34:30.548 EMAI: Send SMTP traffic
EHLO localhost
[8] 12:34:30.558 EMAI: Received SMTP traffic
250-TCOMEXCH01.xxxxxx.local Hello [192.168.xx.xxx]
250-SIZE 62914560
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-XXXXXXXA
250-AUTH
250-8BITMIME
250-BINARYMIME
250 XXXXXXXB
[8] 12:34:30.558 EMAI: Send SMTP traffic
MAIL FROM:<PBX@xxxxx.org>
[8] 12:34:30.568 EMAI: Received SMTP traffic
250 2.1.0 Sender OK
[8] 12:34:30.568 EMAI: Send SMTP traffic
RCPT TO:<tim.xxxxx@xxxxx.org>
[8] 12:34:30.578 EMAI: Received SMTP traffic
250 2.1.5 Recipient OK
[8] 12:34:30.578 EMAI: Send SMTP traffic
DATA
[8] 12:34:30.578 EMAI: Received SMTP traffic
354 Start mail input; end with <CRLF>.<CRLF>
[8] 12:34:30.578 EMAI: Send SMTP traffic (8599 bytes)
Subject:Missed Call from THURSTON COUNTY (3605551212)
Content-Type:text/html;charset="utf-8"
Content-Transfer-Encoding:base64
From:<PBX@xxxxx.org>
To:<tim.xxxx@xxx.org>
Date:Thu, 11 Jun 2015 19:34:30 -0000
MIME-Version:1.0
Content-Length:8332
PGh0bWw+CiAgPGhlYWQ+CiAgICA8bWV0YSBodHRwLWVxdWl2PSJDb250ZW50LVR5cGUiIGNv
bnRlbnQ9InRleHQvaHRtbDsgY2hhcnNldD11dGYtOCI+CiAgICA8bWV0YSBodHRwLWVxdWl2
PSJDb250ZW50LUxhbmd1YWdlIiBjb250ZW50PSJlbi11cyI+CiAgICA8bWV0YSBodHRwLWVx
dWl2PSJDb250ZW50
[8] 12:34:32.288 EMAI: Received SMTP traffic
250 2.6.0 <7101bae8-2cb8-43c7-8967-b2e6019dc2bd@TCOMEXCH01.xxxx.local> [internalId=1552213] Queued mail for delivery
Link to comment
Share on other sites

No it is something embedded. The log above looks good, nothing special. A 2xx code at the end reads to me as "ok got it". Can it be that the message is sitting on the Exchange locally and does not get out?! Any way to see if the message made it to the Exchange server? Is any other service or user using that email server and has no problem?

Link to comment
Share on other sites

Yes we have several other applications and services using exchange with no issues. The messages are definitely not sitting on the exchange server because that was my first thought too so i have been monitoring the queues. I am thinking i may just need to reboot my PBX and see if that resolves it.

Link to comment
Share on other sites

Digging deeper... The PBX should send a QUIT message after "Queued mail for delivery", but in the log that is missing. I guess you did not just forgot to paste that in... Can you get us a Wireshark trace (in a private message)? Maybe there is something going on TCP level that is unexpected by the PBX, like the server closes the connection right after the 250.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...