Jump to content
Sign in to follow this  
IPNOX

Auto Attendent + Exchange UM

Recommended Posts

Hi guys,

 

I'm currently using an ITSP to allow callers to make connection to the Exchange

UM . I have no issues with touch tones with other options of the pbxnsip's Auto Attendent.

 

The following is my test.......

 

SIP callers -> ITSP -> PBXnSIP -> Auto-Attendent (1000) -> Exchange UM

Gateway -> UM Extension (2000)

 

With this setup...... we can connect to the Exchange UM and we receive the greeting "Welcome to Microsoft Exchange......"

but the DTMF tones are not working for the Exchange UM.... the autoattendent for PBXnSIP works.

 

Hence, I dun think the prob lies on the ITSP's dtmf tones.......its between the pbxnSIP and

Exchange UM that might be broken.......

 

Option "7" on the Auto-Attendent (1000) re-directs to 2000 Exchange UM.

I've review my trace logs and I can see "DTMF received 7" and after that no other of such DTMF acknowledgements are seen.

 

Please advice how this can be overcomed...

 

regards

Fei Yu

Share this post


Link to post
Share on other sites
Guest Paul McCabe

Fei,

 

I did some testing on the softphone that I use (Kapanga) and DTMF works properly with Exchange UM when the DTMF transport on the phone is set to RFC2833. DTMF recognition on Exchange does not work properly when it is set to Inband. Does your phone have this setting and how is it set?

 

Also, there is a UM test program that can be run on the UM server via the Exchange Management Shell called 'Test-UMConnectivity'. When I ran it initially, DTMF tones were not recognized properly by Exchange. To pass this DTMF test, I had to change the 'Exchange' trunk setting RINGBACK on the PBX from 'Media' to 'Message 180'. I don't know if this will fix your problem but you might take a look at that as well.

Share this post


Link to post
Share on other sites
Fei,

 

I did some testing on the softphone that I use (Kapanga) and DTMF works properly with Exchange UM when the DTMF transport on the phone is set to RFC2833. DTMF recognition on Exchange does not work properly when it is set to Inband. Does your phone have this setting and how is it set?

 

Also, there is a UM test program that can be run on the UM server via the Exchange Management Shell called 'Test-UMConnectivity'. When I ran it initially, DTMF tones were not recognized properly by Exchange. To pass this DTMF test, I had to change the 'Exchange' trunk setting RINGBACK on the PBX from 'Media' to 'Message 180'. I don't know if this will fix your problem but you might take a look at that as well.

 

 

Hi Paul... I have tested.... its still the same....

I have even checked with my ITSP provider.... they are on Asterix..... and they are using the RFC 2833 for DTMF.... but tis doesn't work....

 

Hope to get an answer soon otherwise nothing seems useful without working DTMF

Share this post


Link to post
Share on other sites
I have even checked with my ITSP provider.... they are on Asterix..... and they are using the RFC 2833 for DTMF.... but tis doesn't work....

 

We had a case where Asterisk was sending RFC 2833 DTMF, but extremly short ("Blitz DTMF"). It was so short (0 ms) that the PBX never had the chance to transcode it into inband DTMF. Maybe that is the problem here as well.

Share this post


Link to post
Share on other sites

Hi there,

 

This is exactly what I am trying to do, but not having any luck. Currently have a demo license, and as 14 days is not much, I fear time will run out before I get to properly evaluate the product. Im trying to use the Exchange AA and OVA etc through a SIP provider via pbxnsip. My SIP Trunk is running, but not getting the exchange hookup working properly. More detail on your config will be much appreciated.

 

Many thanks

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...