Jump to content

Auto provision for Linksys SPA942


brundle
 Share

Recommended Posts

Does anyone have the lines necessary to add to the provisioning script to auto provision the Linksys SPA942 phones?

 

Just point the tftp server to the PBX. It should work already... Also make sure that you do provision the passwords (Admin/Ports/TFTP). The problem is here that Linksys requires their own little secret algorithm for encrypting config files, which they won't gibt to use (the secret, not the program :rolleyes: ).

 

Also, it helps if you are using Option 66 on DHCP.

Link to comment
Share on other sites

Doesn't look like the SPA942 has tftp options via the interface. Is it just a matter of specifying the tftp port after the IP of the pbx?

 

And by setting passwords - do you mean the extension passwords? There is no place to specify password in Admin/Ports/TFTP

Link to comment
Share on other sites

Doesn't look like the SPA942 has tftp options via the interface. Is it just a matter of specifying the tftp port after the IP of the pbx?

Just put the IP address in... Then the phone will automatically choose TFTP.

 

And by setting passwords - do you mean the extension passwords? There is no place to specify password in Admin/Ports/TFTP

 

The setting is called "Allow TFTP Password" - just set it to "always", then later when everything works you can lock this down.

Link to comment
Share on other sites

If I just give the phone the IP of the pbx:

 

Profile Rule: 192.168.32.30

 

Then the phone doesn't register. In fact there are no log entries so it looks like it doesn't even try.

 

Hmm. Maybe better forget about TFTP... Check out the attached files (you can also put them into the html directory, if it does not exist yet create it). There it says you should out http://192.168.1.2//spa$MA.cfg (if 192.168.1.2 is a PBX IP address) into the Profile Rule.

 

I assume you have put a MAC address or just a star into one of your extensions? There is some general information at http://wiki.pbxnsip.com/index.php/Prepare_...r_Plug_and_Play.

spa_1st.txt

spa_phone.txt

Link to comment
Share on other sites

1.) I posted the spa_phone file attached to the last post as spa_phone.xml

 

2.) I added this to pnp.xml and restarted pbxnsip:

 

  <file name="spa_phone.xml" encoding="xml">
   <pattern>!spa_phone_([0-9a-f]{12})\.cfg!\1!</pattern>
   <vendor>Linksys SPAxxx</vendor>
 </file>

 

3.) In the profile field of the phone I pasted:

 

http://192.168.32.30/spa_phone_$MA.cfg

 

4.) DHCP serves up option 66 as 192.168.32.30

 

5.) I tried entering both the MAC and * in the Bind Mac address field for an extension.

 

It is almost as though the phone isn't trying to register with these settings. If I set the proxy address and specify a userid/password it regiaters no problem.

Link to comment
Share on other sites

That did it. The phone is registered and usuable!

 

I had to add the MAC address to the Bind MAC field for the extension I want the phone to register as. IF I put in * then the phone wouldn't register and I couldn't figure out how to associate the phone with the extension.

 

 

 

So provisioning additional settings like dial plans, address books, etc... is done through the spa_phone.xml file correct?

Link to comment
Share on other sites

So provisioning additional settings like dial plans, address books, etc... is done through the spa_phone.xml file correct?

 

Well, if you have something working now you can start doing your own changes. Now you can take the SPA documentation and drill deeper from there.

Link to comment
Share on other sites

  • 8 months later...

Here are the steps I took to get my SPA941 and SPA942 phones auto-provisioned.

 

All phones are running the 6.1.3(a) firmware.

My PBX is running on a Windows 2008 64bit server.

I first provisioned these phones under pbxnsip version 2.1.10. We are now running version 3.2.

 

 

1.) Posted the attached files in the PBX install dir \ html folder.

 

You may want to merge the spa_phone section of the pnp.xml file with your existing pnp.xml file to not overwrite the settings for other vendors you may have already customized in that file.

You will probably need to change the dial plan in the <!-- Dial Plan --> section of the spa_phone.xml file to suit your needs.

 

2.) Added the option 66 in the DHCP pool specifying the IP of the PBX server.

3.) Added the MAC address of the phone sets to the extensions - the Account \ Registration \ Bind to MAC Address field in the PBX admin for the domain.

4.) Make sure other customizations to the phone won't conflict - reset to factory defaults then continue after the phone resets.

5.) Browsed to the web GUI of the phone. Selected Admin Login and advanced mode.

6.) In the web GUI of the phone, on the Provisioning tab, in the Profile Rule field I pasted: http://<pbx server ip>/provisioning/spa_phone_$MA.cfg

7.) After saving the settings the phone resets. After a bit it should pick up it's configs from the PBX then reset again.

 

You should now see the username and extension registered on the phone and in various fields in the phone's web GUI. There is much that can be customized and set via the template config files - ours is pretty default.

 

That should do it.

 

 

-b

spa_phone_files.zip

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
  • 2 weeks later...
  • 2 months later...
  • 2 weeks later...
  • 1 month later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...