Jump to content

Trunk and DDIs plus Service Flag


comspec
 Share

Recommended Posts

I've been playing around with snom one for about a month now to get familiar with the setup procedure and also taken a look on here and the documentation.

 

I have 2 issues really and I'll try and explain them so I hope someone can help.

 

1

Senario

I have one main number and six DDi's to setup.

I've created the Trunk for the main number and a test Trunk for one of the DDIs.

Each trunk pointed to the respective - main trunk to 72 the hunt group - test DDi to extension 41

Both trunks enteries were in the 'send call to extension':

From this I noticed that no calls were going to the hunt group but only hitting the DDI therefore after following the comments in the documentaion I added the main telephone number along side the 72 in the line Account Number(s): and the same for the DDI to the exension number the DDI should hit.

 

I tried to the expressions setout in the documentaion to no avail, so reverted back to adding the CLIs to the extension numbers and hunt group as above.

 

My question on this one - am I doing something wrong and why is the expression not working?

 

2

Senario

When setting the Service Flag for out of hours into the Dialplan you cannot call out.

It would be ideal that some customes may need to stop taking inbound calls after hours but they may wish to still make calls.

What is the correct way of setting this so they can make outbound calls even though the service flag kicks in?

Link to comment
Share on other sites

I've been playing around with snom one for about a month now to get familiar with the setup procedure and also taken a look on here and the documentation.

 

I have 2 issues really and I'll try and explain them so I hope someone can help.

 

1

Senario

I have one main number and six DDi's to setup.

I've created the Trunk for the main number and a test Trunk for one of the DDIs.

Each trunk pointed to the respective - main trunk to 72 the hunt group - test DDi to extension 41

Both trunks enteries were in the 'send call to extension':

From this I noticed that no calls were going to the hunt group but only hitting the DDI therefore after following the comments in the documentaion I added the main telephone number along side the 72 in the line Account Number(s): and the same for the DDI to the exension number the DDI should hit.

 

I tried to the expressions setout in the documentaion to no avail, so reverted back to adding the CLIs to the extension numbers and hunt group as above.

 

My question on this one - am I doing something wrong and why is the expression not working?

 

....

 

From how many different ITSPs do your DIDs come from? If they all come from the same ITSP, then you should only need 1 trunk + six extensions. Then--as you did--assign each DID to the Account Number field of each extension, i.e.

40 999-888-7770

41 999-888-7771

42 999-888-7772

43 999-888-7773

44 999-888-7774

45 999-888-7775

If you want the outbound caller ID for every extension to publish the same number, simply put your "main number" in the ANI field of each extension.

Link to comment
Share on other sites

Has anyone been able to suss-out why once you have set the service flag to out of hours that you cannot make outboud calls?

 

for example

service flag 9:00-17:00

 

when you try to dial out after 17:01 you cannot make the call.

 

I do understand that the service flag is blocking the outbound calls, so how can I bypass this other than creating a manual service flag for OOH which I don't want as if the customer forgets to set this or unset it, could lead to problems.

Link to comment
Share on other sites

Has anyone been able to suss-out why once you have set the service flag to out of hours that you cannot make outboud calls?

 

for example

service flag 9:00-17:00

 

when you try to dial out after 17:01 you cannot make the call.

 

I do understand that the service flag is blocking the outbound calls, so how can I bypass this other than creating a manual service flag for OOH which I don't want as if the customer forgets to set this or unset it, could lead to problems.

 

In the Dial Plan settings, make sure you leave the Service Flag field "unassigned." Or, in the alternative, create a specific entry for outbound calls when the Service Flag is activated.

Link to comment
Share on other sites

I've worked this one out...

 

I created a 2nd dial plan and called it 'outbound call dialplan' without a flag assigned. Then assigned this to the extension 'dial plan' by selecting it from the drop down box.

This now allows outbound calls even though all inbound calls go direct to the voicemail of the extension assign to out of hours.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...