Jump to content
Vodia PBX forum
Eric

Exchange SP1 UM Voicemail Not Working.. Help!!

Recommended Posts

Hi everyone,

 

I cannot figure out how to get exchange unified messaging voicemail working.

 

Phones: Polycom SoundPoint IP 501 SIP

Revision: 3.1.2.0392

BootRom: 4.1.2.0037

 

PBXnSIP Server: 3.2.0.3144

 

Microsoft Exchange Server 2007 SP1

 

PBXnSIP and Exchange are on separate servers.

 

I've followed the wiki at http://wiki.pbxnsip.com/index.php/Microsoft_Exchange and still cannot get this working correctly. I'm thinking the External Voicemail System option under Domain Settings, which is currently at 7$u, may be the problem, but I'm not sure what to change it to. I've attached a .zip file that contains screenshots of both pbxnsip and exchange settings and the pbxnsip log showing the SIP/2.0 403 Forbidden error.

 

Although, I can dial, for example 72010 on extension 2010's phone and get the Exchange voicemail system and program all my settings, but when I make a call to my number, it will not go to voicemail.

 

This is a business critical issue, because when people dial our number and nobody responds, it hangs up, which means our company phones are currently sending unanswered calls to the gutter. We desperately need voicemail working with our Unified Messaging server! Please help!

 

Thanks in advance,

 

Eric

pbxnsip.zip

Share this post


Link to post
Share on other sites

Based on the screen shots, the setup looks good. The log file shows that the UM is rejecting the call.

 

Looking at http://forum.pbxnsip.com/index.php?showtopic=1635, we may have to verify the UM dial plan type (E164, Extension or SIP) and the security (unsecured, secured, sip secured?). Changing these values may make a difference.

 

 

 

 

Hi everyone,

 

I cannot figure out how to get exchange unified messaging voicemail working.

 

Phones: Polycom SoundPoint IP 501 SIP

Revision: 3.1.2.0392

BootRom: 4.1.2.0037

 

PBXnSIP Server: 3.2.0.3144

 

Microsoft Exchange Server 2007 SP1

 

PBXnSIP and Exchange are on separate servers.

 

I've followed the wiki at http://wiki.pbxnsip.com/index.php/Microsoft_Exchange and still cannot get this working correctly. I'm thinking the External Voicemail System option under Domain Settings, which is currently at 7$u, may be the problem, but I'm not sure what to change it to. I've attached a .zip file that contains screenshots of both pbxnsip and exchange settings and the pbxnsip log showing the SIP/2.0 403 Forbidden error.

 

Although, I can dial, for example 72010 on extension 2010's phone and get the Exchange voicemail system and program all my settings, but when I make a call to my number, it will not go to voicemail.

 

This is a business critical issue, because when people dial our number and nobody responds, it hangs up, which means our company phones are currently sending unanswered calls to the gutter. We desperately need voicemail working with our Unified Messaging server! Please help!

 

Thanks in advance,

 

Eric Carnagey

Share this post


Link to post
Share on other sites

OK. I've been testing this all morning and have got the voicemail working via exchange unified messaging. Here are the results from the tests (I've attached the log files from the results in troubleshooting.zip):

 

Using the UM dial plan type E.164 w/ Mailbox enabled on the pbxnsip: When trying to go to voicemail, it will say : the subscriber you have dialed is not available or has traveled outside the coverage area.

Using the UM dial plan type E.164 w/ Mailbox disabled on the pbxnsip: Phone beeps a few times then hangs up instead of going to voicemail.

 

 

Using the UM dial plan type Telephone Extension w/ Mailbox enabled on the pbxnsip: WORKS!

Using the UM dial plan type Telephone Extension w/ Mailbox disabled on the pbxnsip: Phone beeps a few times then hangs up instead of going to voicemail.

 

 

Using the UM dial plan type SIP URI and Autogenerated SIP Remote Identifier (eric@garygoddard.com) w/ Mailbox enabled on the pbxnsip: When trying to go to voicemail, it will say : the subscriber you have dialed is not available or has traveled outside the coverage area.

Using the UM dial plan type SIP URI and Autogenerated SIP Remote Identifier (eric@garygoddard.com) w/ Mailbox disabled on the pbxnsip: Phone beeps a few times then hangs up instead of going to voicemail.

 

 

Using the UM dial plan type SIP URI and Manual SIP Remote Identifier (2010@192.168.40.31) w/ Mailbox enabled on the pbxnsip: When trying to go to voicemail, it will say : the subscriber you have dialed is not available or has traveled outside the coverage area.

Using the UM dial plan type SIP URI and Manual SIP Remote Identifier (2010@192.168.40.31) w/ Mailbox disabled on the pbxnsip: Phone beeps a few times then hangs up instead of going to voicemail.

 

 

Here's the problem now. Whenever making any long distance calls out of the 310 area code, it dials right into the Microsoft Exchange voicemail system. Any ideas? I've also attached the log file of this scenario: oubound-calls-go-to-voicemail-instead-of-dialing-out.txt

 

Thanks!

 

 

 

Based on the screen shots, the setup looks good. The log file shows that the UM is rejecting the call.

 

Looking at http://forum.pbxnsip.com/index.php?showtopic=1635, we may have to verify the UM dial plan type (E164, Extension or SIP) and the security (unsecured, secured, sip secured?). Changing these values may make a difference.

troubleshooting.zip

oubound_calls_go_to_voicemail_instead_of_dialing_out.txt

Share this post


Link to post
Share on other sites

OK. It turns out that the outbound calls that were going to voicemail instead of thru the paetec trunk ALL start with a 7. Outbound calls to numbers that do not start with a 7 obviously work. So I checked the PBXNSIP Dial Plan and it shows the Exchange Trunk with a pattern of 7* and replacement *, which I assume is sending anything dialed with a 7 thru to the exchange voicemail. I've attached the screenshot. Right now we dial 7 + the extension to retrieve voicemail. I.e. 72010 for extension 2010.

 

I'm sure this is a simple fix to make outgoing calls that start with 7 work. Any suggestions?

 

 

Here's the problem now. Whenever making any long distance calls out of the 310 area code, it dials right into the Microsoft Exchange voicemail system. Any ideas? I've also attached the log file of this scenario: oubound-calls-go-to-voicemail-instead-of-dialing-out.txt

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Eric,

 

I think you can easily solve this problem using e.g. 9999* instead of 7* The 7* is just an example and my 9999* is also just an example.

 

Dialplan Exchange Entry: Pattern 9999* Replacement *

 

External Voicemail System: 99999$u

 

This is how we use it. :) No conflicts so far (since 2006 with MS Exchange Unified Messaging beta3 :) Ohh How time flies!).

 

btw: dont forget to assign the exchange trunk another preference in your dialplan.

 

best regards,

Jan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...