Jump to content

New version of PBX (3.3.1.3177) breaks dialplan


Jon Heese
 Share

Recommended Posts

Okay, we recently upgraded from v3.2.x (I forget the exact version) to the 3.3.1.3177 executable, and everything seemed fine, until I tried to dial a long-distance number...

 

Our dial plan is set up like this:

 

dialplan.jpg

 

The general idea is to make it easy for our users that are used to an old "dial 9 first" system, as well as to make 7-digit dialing possible for numbers in our area's main area code, 305. Then out-of-area dialing is handled.

 

Our trunk is a 4-port Patton FXO box, with 4 PSTN lines plugged into it. Those lines require 1+areacode+number when dialing out-of-area numbers, and areacode+number for local (305 & 786) calls.

 

Local numbers dial fine, with the 7-digit dialing, 786-xxx-xxxx and 305-xxx-xxxx dialing rules (and probably the 9+<local number>, I didn't check), but when I dial 1+areacode+number, I get a tritone error message about how I have to dial 1 before the number... But my dial plan IS dialing 1 before the number...

 

Examples:

 

I dial 18005551212, the dial plan should be following the "150" pref rule, and sending 18005551212 to the trunk, but I get the tritone telling me to dial 1 first.

 

I dial 8005551212, the dial plan should be following the "160" pref rule (those are 10 x's), and sending 1800551212 to the trunk, but I get the tritone telling me to dial 1 first.

 

So it's acting like it's stripping the 1 off the front of the number before it sends it to the trunk (Patton), yet the logs show that it's being sent with the 1...

 

I tried resetting the config on my Patton gateway, with no change. I also tried a little two-stage dialing, using my "230" pref rule, which sends a *67 (caller ID block) to the trunk and then hands me dial tone on the trunk, and I can dial 18005551212 (or whatever) fine and it successfully dials and connects.

 

So then I tried rolling back to the old (3.2.x) pbxctrl.exe executable, and voila, now it's working perfectly. So it's definitely something that changed in the dial plan handling code of the new version.

 

Anyone know what could be causing this? How to nail down my problem? What I can do to fix it? Thanks in advance for any help.

 

Regards,

Jon Heese

Link to comment
Share on other sites

In an effort make it easier for the users, we introduced use of country code in 3.3. Under the Domain->Settings, there's a Country Code field. Set that to 1. Also, you can set the area code if you like.

 

Then on the trunk settings, there is field "Rewrite Global Numbers", you can set the NANPA 11 digits. These 2 settings should take care of the problem.

 

 

Okay, we recently upgraded from v3.2.x (I forget the exact version) to the 3.3.1.3177 executable, and everything seemed fine, until I tried to dial a long-distance number...

 

Our dial plan is set up like this:

 

dialplan.jpg

 

The general idea is to make it easy for our users that are used to an old "dial 9 first" system, as well as to make 7-digit dialing possible for numbers in our area's main area code, 305. Then out-of-area dialing is handled.

 

Our trunk is a 4-port Patton FXO box, with 4 PSTN lines plugged into it. Those lines require 1+areacode+number when dialing out-of-area numbers, and areacode+number for local (305 & 786) calls.

 

Local numbers dial fine, with the 7-digit dialing, 786-xxx-xxxx and 305-xxx-xxxx dialing rules (and probably the 9+<local number>, I didn't check), but when I dial 1+areacode+number, I get a tritone error message about how I have to dial 1 before the number... But my dial plan IS dialing 1 before the number...

 

Examples:

 

I dial 18005551212, the dial plan should be following the "150" pref rule, and sending 18005551212 to the trunk, but I get the tritone telling me to dial 1 first.

 

I dial 8005551212, the dial plan should be following the "160" pref rule (those are 10 x's), and sending 1800551212 to the trunk, but I get the tritone telling me to dial 1 first.

 

So it's acting like it's stripping the 1 off the front of the number before it sends it to the trunk (Patton), yet the logs show that it's being sent with the 1...

 

I tried resetting the config on my Patton gateway, with no change. I also tried a little two-stage dialing, using my "230" pref rule, which sends a *67 (caller ID block) to the trunk and then hands me dial tone on the trunk, and I can dial 18005551212 (or whatever) fine and it successfully dials and connects.

 

So then I tried rolling back to the old (3.2.x) pbxctrl.exe executable, and voila, now it's working perfectly. So it's definitely something that changed in the dial plan handling code of the new version.

 

Anyone know what could be causing this? How to nail down my problem? What I can do to fix it? Thanks in advance for any help.

 

Regards,

Jon Heese

Link to comment
Share on other sites

In an effort make it easier for the users, we introduced use of country code in 3.3. Under the Domain->Settings, there's a Country Code field. Set that to 1. Also, you can set the area code if you like.

 

Then on the trunk settings, there is field "Rewrite Global Numbers", you can set the NANPA 11 digits. These 2 settings should take care of the problem.

Aha!

 

We already had the country code set to 1, but changing the "Rewrite global numbers" field to "For NANPA (11 digits)" fixed this issue. Thanks for the tip.

 

Regards,

Jon Heese

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...