Jump to content

PNP with SNOM 360's. Assigns wrong info for sip proxy


kellenw
 Share

Recommended Posts

CS410 Software Version: 3.3.2.3181

Snom 360 Firmware: 7.3.14

 

This is what the CS410 is assigning for the sip proxy in the phone --- sip:64.151.xx.xxx:5061;transport=tls

This is what the CS410 should assign for the sip proxy in the phone --- sip:64.151.xx.xxx:5060;transport=udp

 

I have entered udp for the transport method. I don't actually see a place to change the port number in the web admin.

 

I'm wanting udp as the transport as that is what works well for remote phones for me. I've set it up that way in the pnp settings through the web gui. Also 5060 is my sip port, not 5061. I'm confused why the cs410 would be pushing this info when it's not what I've selected, AND I don't even see a place to edit the port number in the pnp settings.

 

With the settings the cs410 provides, the phone doesn't work properly. If I manually change the sip port back to 5060 and the transport method to udp on the phone, it works perfectly. Any advice?

Link to comment
Share on other sites

Snom phones support TLS (security, security, ...) and PBX chooses TLS as the default for snom phones. The standard port for TLS is 5061. So all is good.

 

If you change the transport to UDP and then reboot the phone, the phones should have sip:64.151.xx.xxx:5060;transport=udp after the reboot.

 

 

CS410 Software Version: 3.3.2.3181

Snom 360 Firmware: 7.3.14

 

This is what the CS410 is assigning for the sip proxy in the phone --- sip:64.151.xx.xxx:5061;transport=tls

This is what the CS410 should assign for the sip proxy in the phone --- sip:64.151.xx.xxx:5060;transport=udp

 

I have entered udp for the transport method. I don't actually see a place to change the port number in the web admin.

 

I'm wanting udp as the transport as that is what works well for remote phones for me. I've set it up that way in the pnp settings through the web gui. Also 5060 is my sip port, not 5061. I'm confused why the cs410 would be pushing this info when it's not what I've selected, AND I don't even see a place to edit the port number in the pnp settings.

 

With the settings the cs410 provides, the phone doesn't work properly. If I manually change the sip port back to 5060 and the transport method to udp on the phone, it works perfectly. Any advice?

Link to comment
Share on other sites

Snom phones support TLS (security, security, ...) and PBX chooses TLS as the default for snom phones. The standard port for TLS is 5061. So all is good.

 

If you change the transport to UDP and then reboot the phone, the phones should have sip:64.151.xx.xxx:5060;transport=udp after the reboot.

 

Thanks for the reply.

 

The problem is that the pnp function of the cs410 appears to be ignoring the fact that I've changed the transport method from tls to udp in the cs410 pnp settings. It still hands out tls as the transport method regardless of what I have entered in the box. I can manually change it in the phone after provisioning, but that sort of removes the advantage of pnp.

 

I'm using udp instead of tls because for whatever reason, tls results in one way audio when the phone is behind a nat firewall (cs410 is wide open on it's own public ip). Still can't figure out why that's happenning either. hehe

Link to comment
Share on other sites

Thanks for the reply.

 

The problem is that the pnp function of the cs410 appears to be ignoring the fact that I've changed the transport method from tls to udp in the cs410 pnp settings. It still hands out tls as the transport method regardless of what I have entered in the box. I can manually change it in the phone after provisioning, but that sort of removes the advantage of pnp.

 

I'm using udp instead of tls because for whatever reason, tls results in one way audio when the phone is behind a nat firewall (cs410 is wide open on it's own public ip). Still can't figure out why that's happenning either. hehe

 

 

Ok. this was a defect on the PBX part. We are making changes to the software to fix this. Meanwhile you can download the attached file and place it under <pbx install dir>/html folder. (Please create html folder, if it is not present). Then reboot the phone. Just to verify the change, you can open and see the 'generated/<domain>/extension/snom_3xx_phone.xml' file.

snom_3xx_phone.xml

Link to comment
Share on other sites

Ok. this was a defect on the PBX part. We are making changes to the software to fix this. Meanwhile you can download the attached file and place it under <pbx install dir>/html folder. (Please create html folder, if it is not present). Then reboot the phone. Just to verify the change, you can open and see the 'generated/<domain>/extension/snom_3xx_phone.xml' file.

 

Thanks for the reply and the xml file. Where do I find (or make) this html folder in the directory structure of the cs410 setup? I'm using WinSCP to log in using the root user just fine, but I'm just not sure where I'm required to place this file.

 

Thanks for your help!

Link to comment
Share on other sites

Thanks for the reply and the xml file. Where do I find (or make) this html folder in the directory structure of the cs410 setup? I'm using WinSCP to log in using the root user just fine, but I'm just not sure where I'm required to place this file.

 

Thanks for your help!

 

 

Oh! On CS410, you can ssh to the box (or if WinSCP lets you see the directory structure on the CS410, that's fine too). The default working directory is /pbx. So you would have to create 'html' folder under /pbx and copy the file into that folder.

Link to comment
Share on other sites

Oh! On CS410, you can ssh to the box (or if WinSCP lets you see the directory structure on the CS410, that's fine too). The default working directory is /pbx. So you would have to create 'html' folder under /pbx and copy the file into that folder.

 

Great! Thank you!

 

By the way, it would probably be a big help to newbies if you added WinSCP as a file manager suggestion to the wiki. It is extremely easy to use, and for me, a real time saver.

 

Thanks again for your help!

Link to comment
Share on other sites

Thought I would just follow up really quickly and let you know this bug still persists with the 4.0.0.3204 beta version. No matter what you assign in the pnp settings (udp, tcp, tls) it always assigns tls during provisioning for snom 360's (and I assume 320's also, though I haven't tried any of my 320's yet).

Link to comment
Share on other sites

Thought I would just follow up really quickly and let you know this bug still persists with the 4.0.0.3204 beta version. No matter what you assign in the pnp settings (udp, tcp, tls) it always assigns tls during provisioning for snom 360's (and I assume 320's also, though I haven't tried any of my 320's yet).

 

We have tested both 320 and 360 PnP and both work OK. Make sure that you do not have custom pnp.xml and snom_3xx_phone.xml under the html folder.

Link to comment
Share on other sites

We have tested both 320 and 360 PnP and both work OK. Make sure that you do not have custom pnp.xml and snom_3xx_phone.xml under the html folder.

 

I don't have any custom xml files in the html folder at all currently. What firmware are you using on the Snom 360/320 with version PBXNSIP CS410 4.0.0.3204? I am on 7.2.23 at the moment, but I had the same problems with previous firmware also. Strange it's working for you and not me. I'll keep digging and report back.

Link to comment
Share on other sites

I don't have any custom xml files in the html folder at all currently. What firmware are you using on the Snom 360/320 with version PBXNSIP CS410 4.0.0.3204? I am on 7.2.23 at the moment, but I had the same problems with previous firmware also. Strange it's working for you and not me. I'll keep digging and report back.

 

You can verify the generated "snom_3xx_phone.xml" file under <working dir>/generated/<domain>/<extension>. Ex:/pbx/generated/localhost/40/snom_3xx_phone.xml. If this file still show "transport=tls" then we might have some issue with the CS410 build. Then we'll take a look at the builld.

Link to comment
Share on other sites

You can verify the generated "snom_3xx_phone.xml" file under <working dir>/generated/<domain>/<extension>. Ex:/pbx/generated/localhost/40/snom_3xx_phone.xml. If this file still show "transport=tls" then we might have some issue with the CS410 build. Then we'll take a look at the builld.

 

I have udp as my selected transport method in pnp settings. It shows udp in the web gui. My snom_3xx_phone.xml file in <working dir>/generated/<domain>/<extension> shows:

 

<user_outbound idx="1" perm="RW">sip:64.xxx.xx.xxx:5061;transport=tls</user_outbound>

 

(x's were used to replace actual ip when pasting the line)

 

Looks like it's still an issue.

Link to comment
Share on other sites

I have udp as my selected transport method in pnp settings. It shows udp in the web gui. My snom_3xx_phone.xml file in <working dir>/generated/<domain>/<extension> shows:

 

<user_outbound idx="1" perm="RW">sip:64.xxx.xx.xxx:5061;transport=tls</user_outbound>

 

(x's were used to replace actual ip when pasting the line)

 

Looks like it's still an issue.

 

Meanwhile we quickly verified here in our lab and we saw the issue too on CS410. It worked on the Windows version. So we made a new build (same version number), tested it on the CS410 and verified it works fine now. You can download http://pbxnsip.com/cs410/update-4.0.0.3204.tgz and update the CS410.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...