Jump to content

Inbound Calls On Trunk Doesn't Get Route Properly


Guest Pats
 Share

Recommended Posts

It is running release 2.1.10.2474 (win32), and the issue is an inbound calls on trunk does not get route properly. There two domains configured in the system; localhost and a real FQDN domain which is connecting to an ITSP. According that ITSP, it does not support the "Line Parameter" due to there is no way to tell it to cache the line entry in their end. There are some DID numbers associated with this real FQDN assign to this trunk. When incoming calls on those DID, it should get route to that trunk because I have an alias tel:DID’s assigned to a Hunt Group, but somehow it keeps routing/rolling to the other trunk which is configured to localhost domain instead.

PBX_Log.txt

Link to comment
Share on other sites

Well, the service provider obviously uses software that discards the line parameter in the URI. This is not RFC compliant, and that is because of the problem we are facting here - someone (the PBX) registeres several contacts and when the call comes it it needs to know where exactly it should go.

 

The workaround it to send the call to a tel:alias. But this is not very reliable and the PBX needs to perform a table scan on the trunks to locate the right trunk. If you have a lot of trunks that will take some time, and if you have a lot of calls the CPU will start choking.

 

Maybe you can tell the service provider they need to fix this problem. The RFC was released in 2001 and it is time to support this.

Link to comment
Share on other sites

  • 4 weeks later...
It is running release 2.1.10.2474 (win32), and the issue is an inbound calls on trunk does not get route properly. There two domains configured in the system; localhost and a real FQDN domain which is connecting to an ITSP. According that ITSP, it does not support the "Line Parameter" due to there is no way to tell it to cache the line entry in their end. There are some DID numbers associated with this real FQDN assign to this trunk. When incoming calls on those DID, it should get route to that trunk because I have an alias tel:DID’s assigned to a Hunt Group, but somehow it keeps routing/rolling to the other trunk which is configured to localhost domain instead.

 

 

We installed a PROXY server between ourselves and various carriers and this completely solved the problem for us with the line parameter. You can contact Kevin Moroz re availability of this product.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...