Jump to content

UK settings?


Kristan
 Share

Recommended Posts

Trying out a CS410 in the UK and generally works ok, except it doesn't seem to detect ringing correctly (thinks it's connected) and the same for busy (just connects regardless). I've tried the "enable busy detection" and also disabled the reverse polarity as it seems the UK doesn't use this setting.

 

All the values needed are here :

 

http://www.provu.co.uk/pdf/sipura/sipura_u...al_settings.pdf

 

I assume one of you boffins can translate into what settings I need to put into PBXnSIP?

 

Ta!

Link to comment
Share on other sites

Just adding a bit more detail if helpful, this is what the log shows when dialling out (I've taken the DTMF digits out as it's my phone number :) ). From what I can see, as soon as the last DTMF is sent it goes straight to TALKING - shouldn't it go to RINGING or something first?

 

[5] 2008/01/01 00:07:31: PSTN: Country Code set to 64

[5] 2008/01/01 00:07:31: PSTN: Tone Detection set to 0

[3] 2008/01/01 00:07:31: PSTN: Channel 0 going to DIALLING

[6] 2008/01/01 00:07:31: Sending RTP for d68e4385@pbx#1344858385 to 1.1.1.2:2050

[7] 2008/01/01 00:07:32: PSTN: DTMF: x

[7] 2008/01/01 00:07:32: PSTN: DTMF: x

[7] 2008/01/01 00:07:32: PSTN: DTMF: x

[7] 2008/01/01 00:07:33: PSTN: DTMF: x

[7] 2008/01/01 00:07:33: PSTN: DTMF: x

[7] 2008/01/01 00:07:33: PSTN: DTMF: x

[7] 2008/01/01 00:07:34: Call d68e4385@pbx#1344858385: Clear last INVITE

[7] 2008/01/01 00:07:34: Set packet length to 20

[9] 2008/01/01 00:07:34: Resolve 55: url sip:127.0.0.1:5062

[9] 2008/01/01 00:07:34: Resolve 55: udp 127.0.0.1 5062

[7] 2008/01/01 00:07:34: Determine pass-through mode after receiving response

[3] 2008/01/01 00:07:34: PSTN: Channel 0 going to TALKING

Link to comment
Share on other sites

Guys, I could do with a response to this - I'm happy to try and get it working myself, but have no idea where to start as none of the settings are exposed I need to change as far as I can tell. I've got a customer waiting for the cs410, and I'd like to get it in as soon as possible.

Link to comment
Share on other sites

Guys, I could do with a response to this - I'm happy to try and get it working myself, but have no idea where to start as none of the settings are exposed I need to change as far as I can tell. I've got a customer waiting for the cs410, and I'd like to get it in as soon as possible.

 

Make sure that you are using the latest build which includes the settings for impendance and the tone timers (should be at least update-2987.tgz). Also, not every carrier has the same settings.

Link to comment
Share on other sites

Make sure that you are using the latest build which includes the settings for impendance and the tone timers (should be at least update-2987.tgz). Also, not every carrier has the same settings.

 

What's the latest build? Most recent I can see on the website is 2933? I've grabbed 2987 now though, I'll have a little play and let you know how I get on.

Link to comment
Share on other sites

Ok there are a load more settings now... But I'm not really sure what I'm looking at to be honest. The settings from the sipura (which work fine for our carrier btw) don't seem to translate to anything on the PSTN settings page, so I'm a bit lost. And there also seems to be lots of settings on the sipura vs what's on the cs410. Are these important? :)

 

I'm definitely no PSTN expert, so I suspect I may need a bit of help getting this running...

Link to comment
Share on other sites

Ok, after some playing around, I'm now seeing this :

 

[3] 2008/01/01 00:21:49: PSTN: Channel 0 going to TALKING

[7] 2008/01/01 00:21:49: b0e94e45@pbx#880541485: RTP pass-through mode

[7] 2008/01/01 00:21:49: 3c2aac33c832-xeq3o76mhyze@snom300-000413258E11#6f76d7b172: RTP pass-through mode

[5] 2008/01/01 00:21:50: PSTN: Busy Tone detected on 0 (version: 2.4.2)n

[5] 2008/01/01 00:21:52: Last message repeated 3 times

 

However the call shows as "connected" in the calls screen and as far as the phone is concerned, it's also connected - yet the call hasn't been connected and is busy. What should the correct sequence be?

I'm also seeing this at the end of the call :

 

[3] 2008/01/01 00:21:53: PSTN: Channel 0: Hangup

[5] 2008/01/01 00:21:53: PSTN: Channel 0 goes onhook

[5] 2008/01/01 00:21:53: PSTN: enable_callerid 0

[3] 2008/01/01 00:21:53: PSTN: Channel 0 going to GO_ONHOOK

[5] 2008/01/01 00:21:53: PSTN: Busy Tone detected on 0 (version: 2.4.2)n

[3] 2008/01/01 00:21:54: PSTN: Channel 0 going to IDLE

 

I guess it shouldn't be detecting a busy tone then?

 

See, this is why I prefer ISDN..... :)

Link to comment
Share on other sites

I am really thinking if we need to change the busy tone detection strategy.

 

As with DTMF, maybe we cannot rely on the PSTN gateway to perform this job. And the PBX has one benefit - it knows when a real user is taking to the PBX and in that case it can leave it up to the extension to disconnect the call. Otherwise if the call is connected to say the auto attendant, it is clear that a busy tone is no valid input and a clear signal to disconnect the call.

 

Just thinking. Any opinions out there?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...