Jump to content
Vodia PBX forum
Sign in to follow this  
collinsit

Problem dialing into Exchange.

Recommended Posts

Hi there, I have been using PBXnSIP with Exchange 2007 integration for a while now. I am running a CS410 with the newest release of the software. I have 2 VoIP lines plus the trunk to my Exchange server. It used to work fine but at some point the Exchange integration stopped working. I didn't have time to troubleshoot it then so I just forwarded the extension to my cell phone.

 

I have been looking at it now and the issue I can see so far is that the dialplan doesn't appear to be connecting to the Exchange server. I have a very simple dialplan that says 7* -> * out the Exchange trunk. This has always worked in the past. The issue I am getting is very strange, when I dial 7100 to reach my extension, the phone automatically dials when I get to 710 and doesn't wait for the last digit. The logs do say that the call is being sent out the Exchange trunk but obviously the extension doesn't exist on the Exchange server. I have gone through the entire setup of the PBX and can't find a problem. I even reset the PBX to default and reset both the Snom phones but after setting it up again I am still getting this problem. This seems to happen whenever I dial a number that starts with 4, 5, 6, or 7, they all dial after the third digit. I use 9 to get an outgoing line and it doesn't dial until I press the checkmark on the Snom phone.

 

Other than the 9* dialplan to go out through the VoIP trunk and the 7* dialplan to go out through Exchange there are no other dialplan entries. Both the CS410 and the Snom phones are fully updated to the newest versions of the software. Should I roll back to an earlier firmware on the CS410 or does anyone have any other suggestions why this might not be working?

 

Any help would be greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
I have been looking at it now and the issue I can see so far is that the dialplan doesn't appear to be connecting to the Exchange server. I have a very simple dialplan that says 7* -> * out the Exchange trunk. This has always worked in the past. The issue I am getting is very strange, when I dial 7100 to reach my extension, the phone automatically dials when I get to 710 and doesn't wait for the last digit. The logs do say that the call is being sent out the Exchange trunk but obviously the extension doesn't exist on the Exchange server. I have gone through the entire setup of the PBX and can't find a problem. I even reset the PBX to default and reset both the Snom phones but after setting it up again I am still getting this problem. This seems to happen whenever I dial a number that starts with 4, 5, 6, or 7, they all dial after the third digit. I use 9 to get an outgoing line and it doesn't dial until I press the checkmark on the Snom phone.

 

You probably selected a dial plan scheme for the domain and then provisioned the phone through the PBX. Select "user must press enter" as scheme and reboot the phone.

 

The other thing is that you don't have to dial 7100, you probably should just try 8100. Then the PBX will realize the call should go to the mailbox, and then it says "hey there is a redirection to 7xxx" for the mailbox. The point here is that the PBX includes a redirection header in SIP that Exchange needs to work properly.

 

Other than the 9* dialplan to go out through the VoIP trunk and the 7* dialplan to go out through Exchange there are no other dialplan entries. Both the CS410 and the Snom phones are fully updated to the newest versions of the software. Should I roll back to an earlier firmware on the CS410 or does anyone have any other suggestions why this might not be working?

 

No don't rollback, the latest and greatest has the best support for Exchange.

Share this post


Link to post
Share on other sites

thanks for the suggestion, you are right, I had the default PNP scheme set to 3 digit extensions. I changed this to user must press enter and rebooted the phone but I am getting the same problem. I then changed the dial plan to use an 8* to connect the exchange server and then it starts dialing after the 3rd digit is typed. I have gone through the documentation about setting up Exchange on your website several times but it seems to all be about version 2 of the software. The setup is pretty close but I am not sure if there are any differences between the setup of the two versions.

 

Any other suggestions of things to check here?

 

Thanks

 

You probably selected a dial plan scheme for the domain and then provisioned the phone through the PBX. Select "user must press enter" as scheme and reboot the phone.

 

The other thing is that you don't have to dial 7100, you probably should just try 8100. Then the PBX will realize the call should go to the mailbox, and then it says "hey there is a redirection to 7xxx" for the mailbox. The point here is that the PBX includes a redirection header in SIP that Exchange needs to work properly.

 

 

 

No don't rollback, the latest and greatest has the best support for Exchange.

Share this post


Link to post
Share on other sites

I changed the default scheme setting to the to require the pressing of enter as I mentioned in my last post and even after restarting the phone it didn't work so I tried resetting the phone to defaults. Now, when I dial extension 7100 which is the Exchange server to one of the mailboxes it does except the full entry and the logs say that it is sending through the Exchange SIP Gateway. The problem I am getting now is I get an error on the phone saying Forbidden: 7100.

 

What would cause this error?

Share this post


Link to post
Share on other sites

Hi Again, I have been playing with this more and I think it seems to be working now. That last error seemed to be an Exchange problem but I am able to dial into the Exchange server now.

 

I do have one question that isn't totally related to this but does apply somewhat. I now have the PBX setup to require the user to press the checkmark to dial any extension and that is ok for the most part but I have tried to get dialplans to work so that they dial the moment the number is typed. For example; if I dial 7100 I would like it to dial the moment the last digit is entered. The same thing goes if I enter a users extension, I have to press the checkmark to make the call go through. It seems that by changing the default scheme setting the phone never automatically dials and I have to press the checkmark to make the call go through.

 

I have gone through the dialplan documentation but can't still seem to figure this out.

 

Thanks for all your help.

Share this post


Link to post
Share on other sites
I do have one question that isn't totally related to this but does apply somewhat. I now have the PBX setup to require the user to press the checkmark to dial any extension and that is ok for the most part but I have tried to get dialplans to work so that they dial the moment the number is typed. For example; if I dial 7100 I would like it to dial the moment the last digit is entered. The same thing goes if I enter a users extension, I have to press the checkmark to make the call go through. It seems that by changing the default scheme setting the phone never automatically dials and I have to press the checkmark to make the call go through.

 

I have gone through the dialplan documentation but can't still seem to figure this out.

 

Technically that is a problem of the phone now. The "dial plan" of the PBX has nothing to do with that. So the first source is to check the phone vendor documentation.

 

For a few phones, the PBX automatically generates a phone dial plan (e.g. snom). The generation of this plan depends on the domains "Default PnP Dialplan Scheme". "User must press enter" means that there is no dialplan for the phone, the North America (NANPA) styles generate a dial plan for internal calls and eleven-digit calls.

Share this post


Link to post
Share on other sites

Ok, I am fine with hitting the checkmark button on the phone when I am making calls for now. All my phones are Snom phones so I will see what I can figure out about this on their site.

 

The only other issue I am having with this Exchange setup is related to the Exchange Auto Attendant. I want to use Exchange for the AA because it supports dial by name and I have the mailboxes there. I setup the VoIP line to automatically go to the auto attendant of the Exchange server. When I dial into the line the Auto Attendant answers fine. The problem is, when I try to enter any extension to connect to a phone I get the error "We are sorry but you are not allowed to place this call". That happens regardless of which extension I dial through the system. The Exchange AA also gives you the option to press # after you dial an extension to go directly to the users voicemail. If I do this I transfer successfully to the mailbox so it seems like the routing within Exchange is working but I am not routing back out to the PBX.

 

I have gone through the forum and the wiki looking for a solution to this but haven't been able to find any configuration information for working with the Exchange Auto Attendant. I used to use the PBXNSIP AA and it worked fine but would like to use the Exchange one now.

 

Any help with this would be appreciated.

 

Thanks

Share this post


Link to post
Share on other sites
Ok, I am fine with hitting the checkmark button on the phone when I am making calls for now. All my phones are Snom phones so I will see what I can figure out about this on their site.

 

The only other issue I am having with this Exchange setup is related to the Exchange Auto Attendant. I want to use Exchange for the AA because it supports dial by name and I have the mailboxes there. I setup the VoIP line to automatically go to the auto attendant of the Exchange server. When I dial into the line the Auto Attendant answers fine. The problem is, when I try to enter any extension to connect to a phone I get the error "We are sorry but you are not allowed to place this call". That happens regardless of which extension I dial through the system. The Exchange AA also gives you the option to press # after you dial an extension to go directly to the users voicemail. If I do this I transfer successfully to the mailbox so it seems like the routing within Exchange is working but I am not routing back out to the PBX.

 

I have gone through the forum and the wiki looking for a solution to this but haven't been able to find any configuration information for working with the Exchange Auto Attendant. I used to use the PBXNSIP AA and it worked fine but would like to use the Exchange one now.

 

Oh did you put into the trunk an account that "pays" for the call? This is called "Assume that call comes from user" - and that user must have a dial plan that allows dialling this number. And of course the Exchange trunk on the PBX must "accept redirect".

Share this post


Link to post
Share on other sites

I see the option to set who the call comes from. You're right, I didn't have anything set in this option. I set this option to one of the PBX extensions but I am still getting the error. I do have redirect enabled on the trunk. Does it matter which extension I use for this billing option and do I have to restart the pbx after I make this change? It seems like a pretty simple option but I am still getting the error that I don't have permission to transfer to the extensions.

Share this post


Link to post
Share on other sites
I see the option to set who the call comes from. You're right, I didn't have anything set in this option. I set this option to one of the PBX extensions but I am still getting the error. I do have redirect enabled on the trunk. Does it matter which extension I use for this billing option and do I have to restart the pbx after I make this change? It seems like a pretty simple option but I am still getting the error that I don't have permission to transfer to the extensions.

 

Well, make sure that this extension can really dial that number - check the dial plan what was assigned to the domain and the extension.

 

No restart neccessary for this.

Share this post


Link to post
Share on other sites

Thanks for all your help. I have tried everything to get this to work and for some reason couldn't get it going. I was looking through the forums and came across a solution in another post. The user mentioned that he had the same problem and ended up changing the pbxnsip domain back to localhost from the fqdn domain name he was using. Since I had tried everything else, I gave this a shot too and voila it seemed to work.

 

The reason I was looking through the other forum posts is because during my testing a found another error with my setup. When I dial into the pbx from an external number and pickup the call on one of the phones, I can hear the audio from the remote phone but they can't hear anything from me. If I dial out from the PBX this works fine. I know that normally this is considered a NAT problem but this used to work fine and nothing with my NAT setup has changed. I have an access-list on my firewall allowing everything through to the PBX and because I have several public IP addresses I have forwarded an entire IP through to the box so there should be nothing blocking it at all. The only thing that has changed is that I have upgraded my CS410 to the newest firmware software release.

 

The logs see the calls being established but don't give any indication as to why they don't go through.

 

Any ideas about this?

Share this post


Link to post
Share on other sites
Thanks for all your help. I have tried everything to get this to work and for some reason couldn't get it going. I was looking through the forums and came across a solution in another post. The user mentioned that he had the same problem and ended up changing the pbxnsip domain back to localhost from the fqdn domain name he was using. Since I had tried everything else, I gave this a shot too and voila it seemed to work.

 

Oh yea, that is a good point... But then make the "localhost" a alias name, so that if you get a call for something else than the primary domain the PBX would still take it.

 

The reason I was looking through the other forum posts is because during my testing a found another error with my setup. When I dial into the pbx from an external number and pickup the call on one of the phones, I can hear the audio from the remote phone but they can't hear anything from me. If I dial out from the PBX this works fine. I know that normally this is considered a NAT problem but this used to work fine and nothing with my NAT setup has changed. I have an access-list on my firewall allowing everything through to the PBX and because I have several public IP addresses I have forwarded an entire IP through to the box so there should be nothing blocking it at all. The only thing that has changed is that I have upgraded my CS410 to the newest firmware software release.

 

The logs see the calls being established but don't give any indication as to why they don't go through.

 

The newer versions check your IP configuration in a JavaScript. There are a couple of combinations that screw up the default gateway in Linux. The script checks those when you hit the save button.

 

In the newer software releases there is (AFAIK) no change regarding the handling of NAT and IP routing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...