Jump to content

Dual forking with Communicator


daniel
 Share

Recommended Posts

Hi everyone

 

I have been trying unusucesffully to register Office Communicator client thru PBXNSIP suing the Mediation Server.

 

I succesfully setup the Mediation server and enabled outgoing phone call from Office Communicator which works fine except for some dialplan issues

 

However I can't seemt to get the Communicator client to register with PBXNSIP. I followed the setup in the wiki page and created static registration but not sure how to setup the users because we don't have DID

1. How should the line URI be setup in OCS User properties, we do not use DID and have an auto-attendant with extension, should the lineURI: be tel:+main phone number; ext=101

2. How to register the static registration should it be sip:+main number;ext=101@pbxnsipip

 

I would appreciate some insight on how to set this up

 

Daniel

Link to comment
Share on other sites

However I can't seemt to get the Communicator client to register with PBXNSIP. I followed the setup in the wiki page and created static registration but not sure how to setup the users because we don't have DID

1. How should the line URI be setup in OCS User properties, we do not use DID and have an auto-attendant with extension, should the lineURI: be tel:+main phone number; ext=101

2. How to register the static registration should it be sip:+main number;ext=101@pbxnsipip

 

Static registrations are described in http://wiki.pbxnsip.com/index.php/Extension#Registrations. The registration string should look like "sip:+493039978418@ocs03.extranet.itacs.de;transport=tcp". I guess it does not matter if you really own that DID number (how can OCS know?). I would not put that strange Microsoft parameter into the username... Don't forget the tcp parameter, OCS does not talk much on UDP.

Link to comment
Share on other sites

Static registrations are described in http://wiki.pbxnsip.com/index.php/Extension#Registrations. The registration string should look like "sip:+493039978418@ocs03.extranet.itacs.de;transport=tcp". I guess it does not matter if you really own that DID number (how can OCS know?). I would not put that strange Microsoft parameter into the username... Don't forget the tcp parameter, OCS does not talk much on UDP.

 

Thanks for the quick response, this seems to work as expected.

Now I do I fix the Caller ID, calls are not apparently coming from the "fake" number and not from the main number.

 

Do I need to change something in PBXNSIP or manipulate DialPlan in OCS

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...