Jump to content

Inbound calls fail after a short time


Detlef
 Share

Recommended Posts

I am using Version 2.0.3.1715 (Win32) on a Windows XP Prof workstation.

 

So far I figured everything out, just one problem I am having is incoming calls. I have to restart the pbxnsip service, and then I can receive incoming calls from "callcentric.com" for about 1 minute. After that the auto attendant doesn?t pick up any more till I restart the service again.

 

I don't see anything incoming in the pbxnsip log (set to report everything). Somehow something seems to time out and callcentric doesn't find its way in any more. If I check my NAT router the pbxnsip workstation is still active on the NAT port it registered on. I set the trunk (no STUN) with keep-alive every 60 sec, which is does (seen in the log). Re-registering the trunk per web interface does not help either. Is there a way to figure this problem out easily?

 

Outgoing calls always work, even if the incoming calls quit working.

Link to comment
Share on other sites

Usually callcentric does not require STUN and they keep the registration alive every 20-30 seconds. That should be working in almost all environments.

 

If you can, try a different NAT/firewall. Some firewalls change the ports when a NAT binding is being refreshed.

Link to comment
Share on other sites

I am using a DLink DI-804HV, it lists the pbxnsip workstation on the same NAT port as it registered with callcentric.com in the log file on the pbxnsip. So unless the DLink is lying it should still be good. In the active session status screen it lists the pbxnsip session to call centric.com with 300sec as time-out, which gets renewed when it reaches 240sec while the NAT port stays the same.

 

Playing around with this problem it seems more like a timeout issue than number of calls. If I am quick after a restart calling and hanging up I get more than 2 calls answered by the auto attendant. Seems to me it?s somewhere in a 60 second +/- range when it quits.

 

If I delete the keep-alive value it goes to the default 30sec minimum refresh. If I put for example 3600sec in that field to prevent pbxnsip from reregistering then the DLink router lists it with 300sec time-out but I still have the same problem. No answer from the auto attendant. Going further and letting the 300 sec expire the pbxnsip disappears of the active session lists, reregistering creates a new active session with new NAT port and still not answer for incoming calls.

 

Weird problem?

 

Thanks for all your input!

Link to comment
Share on other sites

Well, NAT is a very difficult topic. I have seen routers that allocate ports by the fifo-principle with maximum of 32 ports (and keep them open forever). Until I figured it out, it was driving me nuts. Therefore, if you have another router, it is worth a try and see if it changes the behavior.

Link to comment
Share on other sites

I read somewhere on the internet that the DLINK DI804HV has a NAT table of 10. That doesn't sound much to me and might relate to the problem. The other option I have is an old Cisco 1700 series router that I briefly configured as gateway but it didnt work at all yet.

 

I think as next test I disconnect all other stations temporarily that use this router's NAT in order to see if that makes a difference. What makes me wonder is that I have two Linksys PAP2T phone adapter running over the same DLink DI804HV and they never fail to accept an incomming call. Its only pbxnsip that accepts calls for aprx 60sec and then quits answering.

 

Thanks for your input!!

Link to comment
Share on other sites

Ah, now I feel stupid!

 

I figured out my problem with thos failing incomming calls. It was not the router, it was a multiple use of the same callcentric account. While I was experimenting with pbxnsip I used the same callcentric account that was assigned to a Linksys PAP2T analogue adapter. The line itself was disconnected but it was still connected to the network and registering with callcentric and as they state in their support it will cause trouble with incoming calls using multiple registrations.

 

Nevermind wasting your time...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...